aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2012-08-15 13:57:01 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2012-08-15 13:57:01 +0000
commit68a1991ea3a5105345932467fd4edbc7b14fc413 (patch)
treef6ad13c86cd88cf93aa96f3093024d35468d10f2 /security
parente0b76a0df4e38c28175b3d1c6c267ffe6833a02c (diff)
downloadports-68a1991ea3a5105345932467fd4edbc7b14fc413.tar.gz
ports-68a1991ea3a5105345932467fd4edbc7b14fc413.zip
- Drop automatic dependency detection [1]
- Do not link to -lphread directly [2] - Use USE_PKGCONFIG [2] - Pet portlint by removing ABI number references [2] - Drop no longer actual --with-lzo=no switch, lzo support is disabled by default anyway [2] - Bump PORTREVISION PR: 170390 [2] Submitted by: Jason E. Hale [2], A.J. Kehoe IV (Nanoman) [1]
Notes
Notes: svn path=/head/; revision=302578
Diffstat (limited to 'security')
-rw-r--r--security/gnutls/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index e84ca30e8813..b025ee4f7f95 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnutls
PORTVERSION= 2.12.18
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_GNU} \
${MASTER_SITE_GNUPG}
@@ -15,15 +16,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= novel@FreeBSD.org
COMMENT= GNU Transport Layer Security library
-LIB_DEPENDS= nettle.4:${PORTSDIR}/security/nettle \
- gpg-error.0:${PORTSDIR}/security/libgpg-error \
- p11-kit.0:${PORTSDIR}/security/p11-kit
+LIB_DEPENDS= nettle:${PORTSDIR}/security/nettle \
+ gpg-error:${PORTSDIR}/security/libgpg-error \
+ p11-kit:${PORTSDIR}/security/p11-kit
CONFLICTS= gnutls-devel-[0-9]*
USE_BZIP2= yes
USE_ICONV= yes
-USE_GNOME= pkgconfig ltverhack gnomehack
+USE_PKGCONFIG= build
+USE_GNOME= ltverhack gnomehack
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
@@ -36,17 +38,15 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
-.if (defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.4)) && !defined(WITHOUT_LIBTASN1)
-LIB_DEPENDS+= tasn1.4:${PORTSDIR}/security/libtasn1
+.if defined(WITH_LIBTASN1)
+LIB_DEPENDS+= tasn1:${PORTSDIR}/security/libtasn1
.else
CONFIGURE_ARGS+= --with-included-libtasn1
.endif
-.if (defined(WITH_LZO) || exists(${LOCALBASE}/lib/liblzo2.so)) && !defined(WITHOUT_LZO)
+.if defined(WITH_LZO)
LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
CONFIGURE_ARGS+= --with-lzo
-.else
-CONFIGURE_ARGS+= --with-lzo=no
.endif
.if defined(WITHOUT_CXX)
@@ -67,6 +67,10 @@ PLIST_SUB+= NLS=""
PORTDOCS= AUTHORS NEWS README THANKS
PORTEXAMPLES= *.c
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" -type f | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|[$$][(]LTLIBPTHREAD[)]||g'
+
post-install:
.if !defined (NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}