aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-02-01 18:51:34 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-02-01 18:51:34 +0000
commit6fd55f7db60c6a0e766c3c62c18bfa5d381ac4e4 (patch)
treebb65ee25df5ce7ff7b724886be2d94bd31a261b3 /security
parentc622075b3a96b5b2eef05bee2066f6386be08492 (diff)
downloadports-6fd55f7db60c6a0e766c3c62c18bfa5d381ac4e4.tar.gz
ports-6fd55f7db60c6a0e766c3c62c18bfa5d381ac4e4.zip
Add security/p5-Authen-Simple-Kerberos, Kerberos backend for
p5-Authen-Simple.
Notes
Notes: svn path=/head/; revision=378264
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-Simple-Kerberos/Makefile19
-rw-r--r--security/p5-Authen-Simple-Kerberos/distinfo2
-rw-r--r--security/p5-Authen-Simple-Kerberos/pkg-descr3
-rw-r--r--security/p5-Authen-Simple-Kerberos/pkg-plist2
5 files changed, 27 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 96909ec159e6..ec5a6ebd9f95 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -426,6 +426,7 @@
SUBDIR += p5-Authen-Simple-DBI
SUBDIR += p5-Authen-Simple-DBM
SUBDIR += p5-Authen-Simple-HTTP
+ SUBDIR += p5-Authen-Simple-Kerberos
SUBDIR += p5-Authen-Simple-LDAP
SUBDIR += p5-Authen-Simple-Net
SUBDIR += p5-Authen-Simple-PAM
diff --git a/security/p5-Authen-Simple-Kerberos/Makefile b/security/p5-Authen-Simple-Kerberos/Makefile
new file mode 100644
index 000000000000..26c406618ed5
--- /dev/null
+++ b/security/p5-Authen-Simple-Kerberos/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= Authen-Simple-Kerberos
+PORTVERSION= 0.1
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Simple Kerberos authentication
+
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
+ p5-Authen-Krb5-Simple>=0:${PORTSDIR}/security/p5-Krb5-Simple
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild
+
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-Simple-Kerberos/distinfo b/security/p5-Authen-Simple-Kerberos/distinfo
new file mode 100644
index 000000000000..e7cfd8bcafcc
--- /dev/null
+++ b/security/p5-Authen-Simple-Kerberos/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Authen-Simple-Kerberos-0.1.tar.gz) = bd3e57546674988d83b3fb31bb92a8e943ed8d45e7426bae4d5be27203cb5ec7
+SIZE (Authen-Simple-Kerberos-0.1.tar.gz) = 2430
diff --git a/security/p5-Authen-Simple-Kerberos/pkg-descr b/security/p5-Authen-Simple-Kerberos/pkg-descr
new file mode 100644
index 000000000000..0f534b236ed2
--- /dev/null
+++ b/security/p5-Authen-Simple-Kerberos/pkg-descr
@@ -0,0 +1,3 @@
+Simple Kerberos authentication
+
+WWW: http://search.cpan.org/dist/Authen-Simple-Kerberos/
diff --git a/security/p5-Authen-Simple-Kerberos/pkg-plist b/security/p5-Authen-Simple-Kerberos/pkg-plist
new file mode 100644
index 000000000000..b34334a2498e
--- /dev/null
+++ b/security/p5-Authen-Simple-Kerberos/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/Authen::Simple::Kerberos.3.gz
+%%SITE_PERL%%/Authen/Simple/Kerberos.pm