aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-26 01:35:42 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-26 01:35:42 +0000
commit72779aaeef5f81e5d9d1bf9b6301a8d5830afda7 (patch)
treed9027d48da88a704dfab1ef61afd9578a98b5abe /security
parentf4fe205fb8b5b0f3d92b8de89157996f6e235961 (diff)
downloadports-72779aaeef5f81e5d9d1bf9b6301a8d5830afda7.tar.gz
ports-72779aaeef5f81e5d9d1bf9b6301a8d5830afda7.zip
- add new port: security/ykclient
This project implements online validation of Yubikey OTPs. It is written in C and provides a shared library for use by other software. WWW: https://code.google.com/p/yubico-c-client PR: 175503 Submitted by: matt@mjslabs.com
Notes
Notes: svn path=/head/; revision=310995
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/ykclient/Makefile34
-rw-r--r--security/ykclient/distinfo2
-rw-r--r--security/ykclient/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e9dd4334db38..7650af2f2e19 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -985,6 +985,7 @@
SUBDIR += yara
SUBDIR += yassl
SUBDIR += yersinia
+ SUBDIR += ykclient
SUBDIR += zebedee
SUBDIR += zenmap
SUBDIR += zombiezapper
diff --git a/security/ykclient/Makefile b/security/ykclient/Makefile
new file mode 100644
index 000000000000..132a6eeb44a1
--- /dev/null
+++ b/security/ykclient/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= ykclient
+PORTVERSION= 2.9
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= matt@mjslabs.com
+COMMENT= Yubico C client library
+
+LICENSE= BSD
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= curl-config:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/ykclient \
+ include/ykclient.h \
+ include/ykclient_server_response.h \
+ lib/libykclient.a \
+ lib/libykclient.la \
+ lib/libykclient.so \
+ lib/libykclient.so.7
+
+PROJECTHOST= yubico-c-client
+
+MAKE_JOBS_UNSAFE= yes
+
+regression-test: build
+ @(cd ${WRKSRC}; ${MAKE} check)
+
+.include <bsd.port.mk>
diff --git a/security/ykclient/distinfo b/security/ykclient/distinfo
new file mode 100644
index 000000000000..51344b290f80
--- /dev/null
+++ b/security/ykclient/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ykclient-2.9.tar.gz) = f5f93d77dd9f2e3fd1854f7fcfbbc3cfbf4227c3ebe145c8a3f7a2339efbeca5
+SIZE (ykclient-2.9.tar.gz) = 352183
diff --git a/security/ykclient/pkg-descr b/security/ykclient/pkg-descr
new file mode 100644
index 000000000000..07c99eb8bc48
--- /dev/null
+++ b/security/ykclient/pkg-descr
@@ -0,0 +1,4 @@
+This project implements online validation of Yubikey OTPs. It is written in C
+and provides a shared library for use by other software.
+
+WWW: https://code.google.com/p/yubico-c-client