aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2014-07-12 20:49:36 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2014-07-12 20:49:36 +0000
commit76403ff943eebce573c277b2c50cee4890e396a0 (patch)
treec3584283d5d3d1bd6c267a23dfaaf3636000521f /security
parent087e042fee8aee1540d953be124aa19e3cb5eb35 (diff)
downloadports-76403ff943eebce573c277b2c50cee4890e396a0.tar.gz
ports-76403ff943eebce573c277b2c50cee4890e396a0.zip
- Fix OPENSSL_VERSION_NUMBER to identify that libressl supports features of
openssl 1.0.1g only - Add LIBRESSL_VERSION_NUMBER to distinguish from openssl - Strip libraries correctly - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=361642
Diffstat (limited to 'security')
-rw-r--r--security/libressl/Makefile3
-rw-r--r--security/libressl/files/patch-include-openssl-opensslv.h12
2 files changed, 15 insertions, 0 deletions
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index ff5386a5ba00..1a2809d2d8e7 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libressl
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= ${MASTER_SITE_OPENBSD}
MASTER_SITE_SUBDIR= LibreSSL
@@ -18,6 +19,8 @@ GNU_CONFIGURE= yes
USES= libtool
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
test: build
cd ${WRKSRC} && ${MAKE} check
diff --git a/security/libressl/files/patch-include-openssl-opensslv.h b/security/libressl/files/patch-include-openssl-opensslv.h
new file mode 100644
index 000000000000..029abfab60e4
--- /dev/null
+++ b/security/libressl/files/patch-include-openssl-opensslv.h
@@ -0,0 +1,12 @@
+--- include/openssl/opensslv.h.orig 2014-07-12 21:41:27.634267326 +0100
++++ include/openssl/opensslv.h 2014-07-12 21:42:21.944270045 +0100
+@@ -2,7 +2,8 @@
+ #ifndef HEADER_OPENSSLV_H
+ #define HEADER_OPENSSLV_H
+
+-#define OPENSSL_VERSION_NUMBER 0x20000000L
++#define OPENSSL_VERSION_NUMBER 0x1000107fL
++#define LIBRESSL_VERSION_NUMBER 0x20000000L
+ #define OPENSSL_VERSION_TEXT "LibreSSL 2.0"
+ #define OPENSSL_VERSION_PTEXT " part of " OPENSSL_VERSION_TEXT
+