aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-05 04:52:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-05 04:52:49 +0000
commit77f0ad5b323e8226e230881b1bcf3d41b20f3404 (patch)
tree9c50073aa37dbe05ffd3eb639dcf7373b2510a37 /security
parent5ab881a5d9e41945e066f0332b891e12e66d0841 (diff)
downloadports-77f0ad5b323e8226e230881b1bcf3d41b20f3404.tar.gz
ports-77f0ad5b323e8226e230881b1bcf3d41b20f3404.zip
New port: security/py-netmiko: Multi-vendor library to simplify SSH connections to network devices
PR: 227088 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=466533
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-netmiko/Makefile25
-rw-r--r--security/py-netmiko/distinfo3
-rw-r--r--security/py-netmiko/pkg-descr23
4 files changed, 52 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8beca02ca1f0..cd45bac0f789 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -945,6 +945,7 @@
SUBDIR += py-mhash
SUBDIR += py-mixbox
SUBDIR += py-mnemonic
+ SUBDIR += py-netmiko
SUBDIR += py-ntlm-auth
SUBDIR += py-oauth2client
SUBDIR += py-oauthlib
diff --git a/security/py-netmiko/Makefile b/security/py-netmiko/Makefile
new file mode 100644
index 000000000000..f4a2b051ddfa
--- /dev/null
+++ b/security/py-netmiko/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= netmiko
+DISTVERSION= 2.1.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Multi-vendor library to simplify SSH connections to network devices
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=2.0.0:security/py-paramiko@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}serial>0:comms/py-serial@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scp>=0.10.0:security/py-scp@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}textfsm>0:textproc/py-textfsm@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-netmiko/distinfo b/security/py-netmiko/distinfo
new file mode 100644
index 000000000000..18e72f49ded2
--- /dev/null
+++ b/security/py-netmiko/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522350835
+SHA256 (netmiko-2.1.1.tar.gz) = f9051df1895e27b7f245e8a350d9116ae476bec811776a9fe63e827b8dedcf9b
+SIZE (netmiko-2.1.1.tar.gz) = 71410
diff --git a/security/py-netmiko/pkg-descr b/security/py-netmiko/pkg-descr
new file mode 100644
index 000000000000..d80db3ea213d
--- /dev/null
+++ b/security/py-netmiko/pkg-descr
@@ -0,0 +1,23 @@
+Multi-vendor library to simplify Paramiko SSH connections to network devices.
+
+Supports following platforms:
+
+- Arista vEOS
+- Cisco ASA/IOS/IOS-XE/IOS-XR/NX-OS/SG300/WLC
+- HP Comware7/ProCurve
+- Juniper JunOS
+- Linux
+
+Following platforms are also supported:
+
+- Alcatel AOS6/AOS8
+- Avaya ERS/VSP
+- Brocade VDX/MLX/NetIron
+- Calix B6
+- Dell-Force10 and Dell PowerConnect
+- Huawei, Mellanox, NetApp cDOT, Palo Alto PAN-OS
+- Pluribus, Ruckus ICX/FastIron, Ubiquiti EdgeSwitch, Vyatta VyOS
+
+There is also experimental support for more platforms not listed here.
+
+WWW: https://github.com/ktbyers/netmiko