aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-08-03 15:34:45 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-08-03 15:34:45 +0000
commit90d97bb7c0b335bf482b1243aaab6676246ab4ea (patch)
tree840e8379f841715c5db9a647458ff49f7766d803 /security
parent3699fb2fba0a69c608a43ba48f60a0bf905f0f1c (diff)
downloadports-90d97bb7c0b335bf482b1243aaab6676246ab4ea.tar.gz
ports-90d97bb7c0b335bf482b1243aaab6676246ab4ea.zip
Add DOCS, EXAMPLES and NLS to OPTIONS_DEFINE to my ports
Notes
Notes: svn path=/head/; revision=301957
Diffstat (limited to 'security')
-rw-r--r--security/checkpassword/Makefile9
-rw-r--r--security/clamav-devel/Makefile4
-rw-r--r--security/clamav/Makefile4
-rw-r--r--security/cmd5checkpw/Makefile9
-rw-r--r--security/keychain/Makefile9
-rw-r--r--security/scanhill/Makefile3
6 files changed, 27 insertions, 11 deletions
diff --git a/security/checkpassword/Makefile b/security/checkpassword/Makefile
index 7a52e6a84e01..26a50c3a2703 100644
--- a/security/checkpassword/Makefile
+++ b/security/checkpassword/Makefile
@@ -15,6 +15,9 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= garga@FreeBSD.org
COMMENT= A simple password-checking interface
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
+
ALL_TARGET= it
INSTALL_TARGET= setup
@@ -23,6 +26,8 @@ MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/checkpassword
PORTDOCS= CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e "s,gcc,${CC},g" ${WRKSRC}/find-systype.sh
@@ -32,11 +37,11 @@ do-configure:
@${ECHO_CMD} ${PREFIX} >${WRKSRC}/conf-home
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 6048fa0e9f05..eff0f0c787ac 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -18,7 +18,7 @@ COMMENT= Command line virus scanner written entirely in C
LICENSE= GPLv2
-OPTIONS_DEFINE= ARC ARJ LHA UNZOO UNRAR LLVM TESTS MILTER LDAP ICONV STDERR
+OPTIONS_DEFINE= ARC ARJ LHA UNZOO UNRAR LLVM TESTS MILTER LDAP ICONV STDERR DOCS
ARC_DESC= Enable arch archives support
ARJ_DESC= Enable arj archives support
@@ -30,7 +30,7 @@ TESTS_DESC= Run compile-time tests (req. python)
MILTER_DESC= Compile the milter interface
STDERR_DESC= Print logs to stderr instead of stdout
-OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM TESTS
+OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM TESTS DOCS
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index e693e4356fc9..3e163e6e9a8b 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -17,7 +17,7 @@ COMMENT= Command line virus scanner written entirely in C
LICENSE= GPLv2
OPTIONS_DEFINE= ARC ARJ LHA UNZOO UNRAR LLVM TESTS MILTER LDAP ICONV STDERR \
- EXPERIMENTAL
+ EXPERIMENTAL DOCS
ARC_DESC= Enable arch archives support
ARJ_DESC= Enable arj archives support
@@ -30,7 +30,7 @@ MILTER_DESC= Compile the milter interface
STDERR_DESC= Print logs to stderr instead of stdout
EXPERIMENTAL_DESC= Build experimental code
-OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM TESTS
+OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM TESTS DOCS
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/security/cmd5checkpw/Makefile b/security/cmd5checkpw/Makefile
index ee20f31e2256..437180ecfbc3 100644
--- a/security/cmd5checkpw/Makefile
+++ b/security/cmd5checkpw/Makefile
@@ -13,11 +13,16 @@ MASTER_SITES= http://beautytech.googlecode.com/svn-history/r6/trunk/src/qmail/ta
MAINTAINER= garga@FreeBSD.org
COMMENT= Checkpassword compatible authentication program that uses CRAM-MD5
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
+
MAN8= cmd5checkpw.8
PORTDOCS= CHANGES CREDITS INSTALL README rfc1321.txt rfc2104.txt
PLIST_FILES= bin/cmd5checkpw etc/poppasswd.dist
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc/poppasswd|${LOCALBASE}/etc/poppasswd|' \
${WRKSRC}/main.c
@@ -29,11 +34,11 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/cmd5checkpw ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/poppasswd ${PREFIX}/etc/poppasswd.dist
@${INSTALL_MAN} ${WRKSRC}/cmd5checkpw.8 ${MANPREFIX}/man/man8
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
. endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/keychain/Makefile b/security/keychain/Makefile
index 6a73d666a3d3..5cfcb4fdb67d 100644
--- a/security/keychain/Makefile
+++ b/security/keychain/Makefile
@@ -15,6 +15,9 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= garga@FreeBSD.org
COMMENT= A user-friendly front-end to ssh-agent(1)
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
@@ -25,6 +28,8 @@ PLIST_FILES= bin/keychain
PORTDOCS= ChangeLog README.rst
+.include <bsd.port.pre.mk>
+
.if !exists(${LOCALBASE}/bin/ssh-agent) && !exists(/usr/bin/ssh-agent)
RUN_DEPENDS+= ssh-agent:${PORTSDIR}/security/openssh-portable
.endif
@@ -32,11 +37,11 @@ RUN_DEPENDS+= ssh-agent:${PORTSDIR}/security/openssh-portable
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/keychain ${PREFIX}/bin/keychain
${INSTALL_MAN} ${WRKSRC}/keychain.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/scanhill/Makefile b/security/scanhill/Makefile
index 2a38a431e5ee..baa7e7f8a528 100644
--- a/security/scanhill/Makefile
+++ b/security/scanhill/Makefile
@@ -23,7 +23,8 @@ MAKE_JOBS_SAFE= yes
PORTDOCS= README.txt INSTALL.txt mysql.sql
-OPTIONS_DEFINE= MYSQL
+OPTIONS_DEFINE= MYSQL DOCS
+OPTIONS_DEFAULT=DOCS
.include <bsd.port.pre.mk>