aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-15 22:48:30 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-15 22:48:30 +0000
commit9209bd43dfe3b97a1ae123ef93220eb95242ff60 (patch)
treea1ba27d7ce85fd9c48024caf820062468246686c /security
parentf5d45a7b0d4d2406946961030cdde10bf795f7a5 (diff)
downloadports-9209bd43dfe3b97a1ae123ef93220eb95242ff60.tar.gz
ports-9209bd43dfe3b97a1ae123ef93220eb95242ff60.zip
security/lime: New Port
LIME is an end-to-end encryption library for one-to-one and group instant messaging, allowing users to exchange messages privately and asynchronously. It uses modern ciphering curve X448 and double ratchet algorithm for perfect forward secrecy. LIME is composed of a portable client library coupled with a public key server developed by Belledonne Communications to allow end-to-end encryption for messaging, without having to exchange cryptographic keys simultaneously. The library exposes a C, C++, Python and Java API for easy integration in mobile and desktop environments. LIME supports multiple devices per user and multiple users per device. WWW: https://www.linphone.org/technical-corner/lime
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/lime/Makefile25
-rw-r--r--security/lime/distinfo3
-rw-r--r--security/lime/pkg-descr16
-rw-r--r--security/lime/pkg-plist12
5 files changed, 57 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 46f8b786c3cc..c0f28b886a9e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -314,6 +314,7 @@
SUBDIR += libxcrypt
SUBDIR += libyubikey
SUBDIR += libzrtpcppcore
+ SUBDIR += lime
SUBDIR += linux-bitwarden-cli
SUBDIR += linux-c7-cyrus-sasl2
SUBDIR += linux-c7-gnutls
diff --git a/security/lime/Makefile b/security/lime/Makefile
new file mode 100644
index 000000000000..66b66501df73
--- /dev/null
+++ b/security/lime/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= lime
+PORTVERSION= 5.0.8
+CATEGORIES= security
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= End-to-end encryption library for instant messaging
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libbctoolbox.so:net/bctoolbox \
+ libbellesip.so:net/belle-sip \
+ libsoci_sqlite3.so:databases/soci
+
+USES= cmake
+USE_GITLAB= yes
+GL_SITE= https://gitlab.linphone.org/BC
+GL_ACCOUNT= public
+GL_COMMIT= 242c5b26a62ccd8d9ecaa7efbd15aa7697fe027b
+
+CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
+ -DENABLE_STATIC=NO \
+ -DENABLE_STRICT=NO
+
+.include <bsd.port.mk>
diff --git a/security/lime/distinfo b/security/lime/distinfo
new file mode 100644
index 000000000000..01f6ee384bbf
--- /dev/null
+++ b/security/lime/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1655332338
+SHA256 (public-lime-242c5b26a62ccd8d9ecaa7efbd15aa7697fe027b_GL0.tar.gz) = 611d7e42ba853b7d038ed137dc3b6a36ee816ee31b9866ebce7051be3ed0d375
+SIZE (public-lime-242c5b26a62ccd8d9ecaa7efbd15aa7697fe027b_GL0.tar.gz) = 526442
diff --git a/security/lime/pkg-descr b/security/lime/pkg-descr
new file mode 100644
index 000000000000..a48748eae081
--- /dev/null
+++ b/security/lime/pkg-descr
@@ -0,0 +1,16 @@
+LIME is an end-to-end encryption library for one-to-one and group
+instant messaging, allowing users to exchange messages privately and
+asynchronously. It uses modern ciphering curve X448 and double ratchet
+algorithm for perfect forward secrecy.
+
+LIME is composed of a portable client library coupled with a public key
+server developed by Belledonne Communications to allow end-to-end
+encryption for messaging, without having to exchange cryptographic keys
+simultaneously.
+
+The library exposes a C, C++, Python and Java API for easy integration
+in mobile and desktop environments.
+
+LIME supports multiple devices per user and multiple users per device.
+
+WWW: https://www.linphone.org/technical-corner/lime
diff --git a/security/lime/pkg-plist b/security/lime/pkg-plist
new file mode 100644
index 000000000000..04eed13c394e
--- /dev/null
+++ b/security/lime/pkg-plist
@@ -0,0 +1,12 @@
+bin/lime_tester
+include/lime/lime.hpp
+lib/liblime.so
+lib/liblime.so.0
+%%DATADIR%%/cmake/limeConfig.cmake
+%%DATADIR%%/cmake/limeTargets-%%CMAKE_BUILD_TYPE%%.cmake
+%%DATADIR%%/cmake/limeTargets.cmake
+%%DATADIR%%_tester/data/cacert.pem
+%%DATADIR%%_tester/data/pattern_getSelfIk.C25519.sqlite3
+%%DATADIR%%_tester/data/pattern_getSelfIk.C448.sqlite3
+%%DATADIR%%_tester/data/sip5.linphone.org.selfsigned-cert.pem
+%%DATADIR%%_tester/data/x3dh-cert.pem