aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2022-03-06 23:44:43 +0000
committerLarry Rosenman <ler@FreeBSD.org>2022-03-06 23:46:06 +0000
commit97091cc2d84362ffc39752bf300665cf39344f68 (patch)
treee7d0ab3747de257de0f358b03368fee3b9f00fce /security
parente1839db543a7d79daf9e6728a783714cdcbccafe (diff)
downloadports-97091cc2d84362ffc39752bf300665cf39344f68.tar.gz
ports-97091cc2d84362ffc39752bf300665cf39344f68.zip
security/1password-client, security/1password-client-devel: updates
security/1password-client: Upgrade to 1.12.4 security/1password-client-devel: New port at 2.0.0.beta.14
Diffstat (limited to 'security')
-rw-r--r--security/1password-client-devel/Makefile44
-rw-r--r--security/1password-client-devel/distinfo9
-rw-r--r--security/1password-client-devel/pkg-descr6
-rw-r--r--security/1password-client/Makefile4
-rw-r--r--security/1password-client/distinfo18
5 files changed, 70 insertions, 11 deletions
diff --git a/security/1password-client-devel/Makefile b/security/1password-client-devel/Makefile
new file mode 100644
index 000000000000..77cf1965cdce
--- /dev/null
+++ b/security/1password-client-devel/Makefile
@@ -0,0 +1,44 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+
+PORTNAME= 1password-client-devel
+DISTVERSION= 2.0.0-beta.14
+CATEGORIES= security
+MASTER_SITES= https://cache.agilebits.com/dist/1P/op2/pkg/v${DISTVERSION}/ \
+ LOCAL/ler/op
+
+MAINTAINER= ler@FreeBSD.org
+COMMENT= 1Password CLI client
+
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
+
+USES= zip
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/op
+CONFLICTS_INSTALL= security/op security/1password-client
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/op ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+DISTNAME= op_freebsd_amd64_v${DISTVERSION}
+.elif ${ARCH} == armv6 || ${ARCH} == armv7
+DISTNAME= op_freebsd_arm_v${DISTVERSION}
+.elif ${ARCH} == aarch64
+DISTNAME= op_freebsd_arm64_v${DISTVERSION}
+.elif ${ARCH} == i386
+DISTNAME= op_freebsd_386_v${DISTVERSION}
+.endif
+
+.if ${.TARGETS} == "makesum"
+DISTFILES= op_freebsd_amd64_v${DISTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_arm64_v${DISTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_arm_v${DISTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_386_v${DISTVERSION}${EXTRACT_SUFX}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/1password-client-devel/distinfo b/security/1password-client-devel/distinfo
new file mode 100644
index 000000000000..67f976b88cb9
--- /dev/null
+++ b/security/1password-client-devel/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1646610168
+SHA256 (op_freebsd_amd64_v2.0.0-beta.14.zip) = 5ff926d2e18861f0bc3abe3c33444f2af2ce31eccaaa3da7b692a6f8572496b2
+SIZE (op_freebsd_amd64_v2.0.0-beta.14.zip) = 4710894
+SHA256 (op_freebsd_arm64_v2.0.0-beta.14.zip) = 9b0443df10826d2028c63b1b97f81e3577c705f4f622a7455c97682ff0210731
+SIZE (op_freebsd_arm64_v2.0.0-beta.14.zip) = 4245913
+SHA256 (op_freebsd_arm_v2.0.0-beta.14.zip) = 8308bd0ca5a7a96257ea3954d4ee19f39ee04a8816b8466cd9908cd4ff521b9b
+SIZE (op_freebsd_arm_v2.0.0-beta.14.zip) = 4324594
+SHA256 (op_freebsd_386_v2.0.0-beta.14.zip) = 88863048fe54b27723f2b9a39b9266ac60ce5d54123a980d1ef5b399520f0b62
+SIZE (op_freebsd_386_v2.0.0-beta.14.zip) = 4375730
diff --git a/security/1password-client-devel/pkg-descr b/security/1password-client-devel/pkg-descr
new file mode 100644
index 000000000000..aeb648213981
--- /dev/null
+++ b/security/1password-client-devel/pkg-descr
@@ -0,0 +1,6 @@
+This is a command-line interface to the 1Password password management
+service.
+
+This is the development release of the CLI Version 2.
+
+WWW: https://developer.1password.com/docs/cli/upgrade
diff --git a/security/1password-client/Makefile b/security/1password-client/Makefile
index 3a7a1f7a4de3..9815d1ff6953 100644
--- a/security/1password-client/Makefile
+++ b/security/1password-client/Makefile
@@ -1,7 +1,7 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
PORTNAME= 1password-client
-DISTVERSION= 1.12.2
+DISTVERSION= 1.12.4
CATEGORIES= security
MASTER_SITES= https://cache.agilebits.com/dist/1P/op/pkg/v${DISTVERSION}/ \
LOCAL/ler/op
@@ -17,7 +17,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/op
-CONFLICTS_INSTALL= security/op
+CONFLICTS_INSTALL= security/op security/1password-client-devel
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/op ${STAGEDIR}${PREFIX}/bin
diff --git a/security/1password-client/distinfo b/security/1password-client/distinfo
index 4151aba09695..9b6738c67587 100644
--- a/security/1password-client/distinfo
+++ b/security/1password-client/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1635018158
-SHA256 (op_freebsd_amd64_v1.12.2.zip) = 706756ccba8dce6c3c413fd7f76160c90cce8856ff626d781d4546f2fbb24f65
-SIZE (op_freebsd_amd64_v1.12.2.zip) = 3889288
-SHA256 (op_freebsd_arm64_v1.12.2.zip) = d270ce756e2987246552e70228abc81bd6ab4ac9ca7de60b50f99efb6cd62a38
-SIZE (op_freebsd_arm64_v1.12.2.zip) = 3502277
-SHA256 (op_freebsd_arm_v1.12.2.zip) = d90eae606d54cb48700988860b7d0aa0e1195b69cad09bedda5a727ecd078d1d
-SIZE (op_freebsd_arm_v1.12.2.zip) = 3585203
-SHA256 (op_freebsd_386_v1.12.2.zip) = 49fd6afc42800e9551bb93833eee2a20eb8aa33cd37108b820549cf3815150e8
-SIZE (op_freebsd_386_v1.12.2.zip) = 3625729
+TIMESTAMP = 1646610267
+SHA256 (op_freebsd_amd64_v1.12.4.zip) = ecdf2c858c2fee2467b58c386401d07435de2deee3e5fec54132a73b78fcfb1b
+SIZE (op_freebsd_amd64_v1.12.4.zip) = 3889614
+SHA256 (op_freebsd_arm64_v1.12.4.zip) = abb65ec8d3c980906d3970be70d97fd3d17384a3c63e659d8479c6a70cb9de5b
+SIZE (op_freebsd_arm64_v1.12.4.zip) = 3502264
+SHA256 (op_freebsd_arm_v1.12.4.zip) = 5b7508aa605a210109aa93f9efcd8d44cda74a80dd7b98500cd9b3bf7fae77df
+SIZE (op_freebsd_arm_v1.12.4.zip) = 3586036
+SHA256 (op_freebsd_386_v1.12.4.zip) = 2bd7575c38dfb2d48ff3d153c9ebcc257845405055c082d3bb98e2f281001dbd
+SIZE (op_freebsd_386_v1.12.4.zip) = 3626170