aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-22 13:24:47 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-22 13:24:47 +0000
commit9afc4dd54f149757c82fd0c310447f5be79e739d (patch)
treedc0471a70259273cf7416e626d6cd6b11dcedd4c /security
parent238aa3b315d7356fc47912e6317f0ce82c6a6580 (diff)
downloadports-9afc4dd54f149757c82fd0c310447f5be79e739d.tar.gz
ports-9afc4dd54f149757c82fd0c310447f5be79e739d.zip
security/u2f-devd: Add Nitrokey FIDO 2 Support
PR: 250524 Submitted by: Henrik Rosenke <rosenke@dssgmbh.de>
Notes
Notes: svn path=/head/; revision=552975
Diffstat (limited to 'security')
-rw-r--r--security/u2f-devd/Makefile1
-rw-r--r--security/u2f-devd/files/u2f.conf16
2 files changed, 17 insertions, 0 deletions
diff --git a/security/u2f-devd/Makefile b/security/u2f-devd/Makefile
index 02a5d4e21b42..d03c913d76aa 100644
--- a/security/u2f-devd/Makefile
+++ b/security/u2f-devd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= u2f-devd
PORTVERSION= 1.1.10
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= #
DISTFILES= #
diff --git a/security/u2f-devd/files/u2f.conf b/security/u2f-devd/files/u2f.conf
index 8e5f6129afa8..b7434269ed92 100644
--- a/security/u2f-devd/files/u2f.conf
+++ b/security/u2f-devd/files/u2f.conf
@@ -178,6 +178,22 @@ attach 100 {
action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
};
+# Nitrokey FIDO 2
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x20a0";
+ match "product" "0x42b1";
+ action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
+};
+
+attach 100 {
+ match "vendor" "0x20a0";
+ match "product" "0x42b1";
+ action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
+};
+
# Google Titan U2F
notify 100 {
match "system" "USB";