aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-10-15 12:56:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-10-15 12:56:39 +0000
commita5d101735ab0718fa3d3f7c7ae59172f204165da (patch)
tree290fc7ef30f8c20996ad7e6d17746e74cd9eded0 /security
parent048bfa50cedb9af617599b1e8f1fbd219a2d1ae6 (diff)
downloadports-a5d101735ab0718fa3d3f7c7ae59172f204165da.tar.gz
ports-a5d101735ab0718fa3d3f7c7ae59172f204165da.zip
Remove psyco support
Notes
Notes: svn path=/head/; revision=330398
Diffstat (limited to 'security')
-rw-r--r--security/cfv/Makefile11
-rw-r--r--security/cfv/files/extra-psyco-patch-Makefile11
-rw-r--r--security/umit/Makefile18
3 files changed, 2 insertions, 38 deletions
diff --git a/security/cfv/Makefile b/security/cfv/Makefile
index 29c4d115e932..9f2c60acac52 100644
--- a/security/cfv/Makefile
+++ b/security/cfv/Makefile
@@ -15,19 +15,8 @@ INSTALL_TARGET= install-wrapper
MAN1= cfv.1
-OPTIONS_DEFINE_i386= PSYCO
-PSYCO_DESC= Enable devel/py-psyco optimization support
-
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPSYCO}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
-
-EXTRA_PATCHES+= ${FILESDIR}/extra-psyco-patch-Makefile
-.endif
-
.include <bsd.port.mk>
diff --git a/security/cfv/files/extra-psyco-patch-Makefile b/security/cfv/files/extra-psyco-patch-Makefile
deleted file mode 100644
index 373ea63294bc..000000000000
--- a/security/cfv/files/extra-psyco-patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2009-03-05 21:47:26.000000000 -0300
-+++ Makefile 2009-03-05 21:51:11.000000000 -0300
-@@ -37,7 +37,7 @@
- #this will create a wrapper script that calls python directly (if we can find it), or using the bin/env trick.
- #we don't need to check for PYTHON being set to something, since os.path.join handles the case of the component being an absolute path
- cfv.wrapper:
-- $(PYTHON) -c 'import string,os; py=filter(lambda x: os.path.isfile(x),map(lambda x: os.path.join(x,"$(PYTHON)"),string.split(os.environ["PATH"],":"))); py.append(" /usr/bin/env $(PYTHON)"); open("cfv.wrapper","w").write("#!%s\nimport cfv\ncfv.main()\n"%py[0])'
-+ $(PYTHON) -c 'import string,os; py=filter(lambda x: os.path.isfile(x),map(lambda x: os.path.join(x,"$(PYTHON)"),string.split(os.environ["PATH"],":"))); py.append(" /usr/bin/env $(PYTHON)"); open("cfv.wrapper","w").write("#!%s\ntry:\n import psyco\n import re\n psyco.cannotcompile(re.compile)\n psyco.profile()\nexcept ImportError:\n pass\nimport cfv\ncfv.main()\n"%py[0])'
-
- $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(bindir):
- $(install_dir) $@
diff --git a/security/umit/Makefile b/security/umit/Makefile
index 6fe4e9ce741e..b960ed09afe3 100644
--- a/security/umit/Makefile
+++ b/security/umit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= umit
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,22 +21,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386" || ${PYTHON_REL} > 260
-WITHOUT_PSYCO= yes
-.endif
-
-.ifndef(WITHOUT_PSYCO)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
-.endif
-
-pre-everything::
-.ifndef(WITHOUT_PSYCO)
- @${ECHO_MSG} '===> Define WITHOUT_PSYCO to disable devel/py-psyco optimization'
-.endif
post-patch:
${REINPLACE_CMD} 's/self.build_html_doc()//' ${WRKSRC}/setup.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>