aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-07-02 04:00:29 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-07-02 04:00:29 +0000
commitaff42c7199b9182b398eeda522cb9bcb182895f8 (patch)
tree1132ef2f7655593f25dfefe7bd682bbbb7a0d555 /security
parent83fac84d499abb25f1d93b9cce214a6daeca6e7d (diff)
downloadports-aff42c7199b9182b398eeda522cb9bcb182895f8.tar.gz
ports-aff42c7199b9182b398eeda522cb9bcb182895f8.zip
Mark ports broken on mips64 that are already broken on powerpc64. In
most cases, the failure mode is the same. Also, mark them broken on mips when necessary. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=473699
Diffstat (limited to 'security')
-rw-r--r--security/honggfuzz/Makefile2
-rw-r--r--security/pam_ssh_agent_auth/Makefile3
-rw-r--r--security/py-pysha3/Makefile1
-rw-r--r--security/py-python-nss/Makefile2
-rw-r--r--security/sha1collisiondetection/Makefile5
5 files changed, 10 insertions, 3 deletions
diff --git a/security/honggfuzz/Makefile b/security/honggfuzz/Makefile
index b88550540400..f750f8b330d9 100644
--- a/security/honggfuzz/Makefile
+++ b/security/honggfuzz/Makefile
@@ -11,6 +11,8 @@ COMMENT= General-purpose fuzzer with simple, command-line interface
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_mips= fails to compile: cc1: error: unrecognized command line option -Wframe-larger-than=131072
+BROKEN_mips64= fails to compile: cc1: error: unrecognized command line option -Wframe-larger-than=131072
BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -Wframe-larger-than=131072
USES= gmake
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
index 25d279651062..ababce940eaa 100644
--- a/security/pam_ssh_agent_auth/Makefile
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -10,7 +10,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PAM module which permits authentication via ssh-agent
BROKEN_SSL= openssl-devel
-BROKEN_powerpc64= fails to build: ed25519-donna-portable.h: warning: ALIGN redefined
+BROKEN_mips64= fails to compile: ed25519-donna-portable.h:85:4: Need a uint128_t implementation!
+BROKEN_powerpc64= fails to compile: ed25519-donna-portable.h: warning: ALIGN redefined
USES= perl5 ssl tar:bzip2
GNU_CONFIGURE= yes
diff --git a/security/py-pysha3/Makefile b/security/py-pysha3/Makefile
index f68ef48a0264..824c5262f4ee 100644
--- a/security/py-pysha3/Makefile
+++ b/security/py-pysha3/Makefile
@@ -13,6 +13,7 @@ COMMENT= SHA-3 (Keccak) for Python
LICENSE= PSFL
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_mips64= fails to compile: KeccakP-1600-opt64.c: error: Not yet implemented
BROKEN_powerpc64= fails to compile: KeccakP-1600-opt64.c: error: Not yet implemented
# Actually Python 2.7,3.4+
diff --git a/security/py-python-nss/Makefile b/security/py-python-nss/Makefile
index 54adb87c98ff..b5df5c88b46f 100644
--- a/security/py-python-nss/Makefile
+++ b/security/py-python-nss/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE_LGPL21+ = ${WRKSRC}/LICENSE.lgpl
LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE.gpl
LICENSE_FILE_MPL20= ${WRKSRC}/LICENSE.mpl
+BROKEN_mips= fails to compile: py_nss.c:20285: #pragma GCC diagnostic not allowed inside functions
+BROKEN_mips64= fails to compile: py_nss.c:20285: #pragma GCC diagnostic not allowed inside functions
BROKEN_powerpc64= fails to compile: py_nss.c:20285: #pragma GCC diagnostic not allowed inside functions
LIB_DEPENDS= libnspr4.so:devel/nspr \
diff --git a/security/sha1collisiondetection/Makefile b/security/sha1collisiondetection/Makefile
index f7574a47793f..d4f3f805bf25 100644
--- a/security/sha1collisiondetection/Makefile
+++ b/security/sha1collisiondetection/Makefile
@@ -14,14 +14,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN_aarch64= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv6= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv7= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
+BROKEN_mips= fails to compile: cc1: unrecognized command line option -std=c90
+BROKEN_mips64= fails to compile: cc1: unrecognized command line option -std=c90
BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option -std=c90
USE_GITHUB= yes
GH_ACCOUNT= cr-marcstevens
-USE_LDCONFIG= yes
-
USES= gmake libtool:build
+USE_LDCONFIG= yes
PLIST_FILES= bin/sha1dcsum \
bin/sha1dcsum_partialcoll \