aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2014-04-11 15:14:27 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2014-04-11 15:14:27 +0000
commitb15ebea930bbb0b0c4f6c596e9fa48dc906a5846 (patch)
treed85a0677738947e2d1460218e2815ceff77afa73 /security
parent2fde2038d83622e710bf693294d725ef4e2ea505 (diff)
downloadports-b15ebea930bbb0b0c4f6c596e9fa48dc906a5846.tar.gz
ports-b15ebea930bbb0b0c4f6c596e9fa48dc906a5846.zip
Instead of hardcoding the flags passed to OPTIMIZE, replace it
with the value of CFLAGS
Notes
Notes: svn path=/head/; revision=350979
Diffstat (limited to 'security')
-rw-r--r--security/p5-Crypt-Rabbit/Makefile3
-rw-r--r--security/p5-Crypt-Rabbit/files/patch-Makefile.PL10
2 files changed, 3 insertions, 10 deletions
diff --git a/security/p5-Crypt-Rabbit/Makefile b/security/p5-Crypt-Rabbit/Makefile
index 94ab9f8abd87..aeeb5b1b3081 100644
--- a/security/p5-Crypt-Rabbit/Makefile
+++ b/security/p5-Crypt-Rabbit/Makefile
@@ -15,4 +15,7 @@ LICENSE= GPLv2
USES= perl5
USE_PERL5= configure
+post-patch:
+ ${REINPLACE_CMD} -i '' -e '/OPTIMIZE/s/=>.*/=> "${CFLAGS}",/g' ${WRKSRC}/Makefile.PL
+
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Rabbit/files/patch-Makefile.PL b/security/p5-Crypt-Rabbit/files/patch-Makefile.PL
deleted file mode 100644
index 1480cb337aef..000000000000
--- a/security/p5-Crypt-Rabbit/files/patch-Makefile.PL
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.PL.orig 2014-04-04 14:56:24.000000000 +0000
-+++ Makefile.PL 2014-04-04 14:56:41.000000000 +0000
-@@ -1,6 +1,6 @@
- use ExtUtils::MakeMaker;
-
--my $opt = '-O3 -funroll-loops -fomit-frame-pointer -fschedule-insns2 -Os -fno-strength-reduce -Wall -pipe';
-+my $opt = '-O3 -funroll-loops -fomit-frame-pointer -Os -fno-strength-reduce -Wall -pipe';
-
- WriteMakefile(
- 'NAME' => 'Crypt::Rabbit',