aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-25 09:07:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-25 09:07:06 +0000
commitbe0ff535ce6de180fe60d3aa6b148b5eaa6152fb (patch)
tree536593d4674fe806421e4ba61a3aaf32bf9e2f14 /security
parenta1a41b5c37be3a3c003475b88ef82d29585a764b (diff)
downloadports-be0ff535ce6de180fe60d3aa6b148b5eaa6152fb.tar.gz
ports-be0ff535ce6de180fe60d3aa6b148b5eaa6152fb.zip
- Add p5-Crypt-Curve25519 0.05
Curve25519 is a state-of-the-art Diffie-Hellman function suitable for a wide variety of applications. Given a user's 32-byte secret key, Curve25519 computes the user's 32-byte public key. Given the user's 32-byte secret key and another user's 32-byte public key, Curve25519 computes a 32-byte secret shared by the two users. This secret can then be used to authenticate and encrypt messages between the two users. WWW: http://search.cpan.org/dist/Crypt-Curve25519/
Notes
Notes: svn path=/head/; revision=413972
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Curve25519/Makefile24
-rw-r--r--security/p5-Crypt-Curve25519/distinfo2
-rw-r--r--security/p5-Crypt-Curve25519/pkg-descr9
-rw-r--r--security/p5-Crypt-Curve25519/pkg-plist4
5 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b643eb859eb6..0e4e28698b52 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -492,6 +492,7 @@
SUBDIR += p5-Crypt-CipherSaber
SUBDIR += p5-Crypt-Cracklib
SUBDIR += p5-Crypt-Ctr
+ SUBDIR += p5-Crypt-Curve25519
SUBDIR += p5-Crypt-DES
SUBDIR += p5-Crypt-DES_EDE3
SUBDIR += p5-Crypt-DES_PP
diff --git a/security/p5-Crypt-Curve25519/Makefile b/security/p5-Crypt-Curve25519/Makefile
new file mode 100644
index 000000000000..90a301e5dc7b
--- /dev/null
+++ b/security/p5-Crypt-Curve25519/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Crypt-Curve25519
+PORTVERSION= 0.05
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Generate shared secret using elliptic-curve Diffie-Hellman function
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= perl5
+USE_OPENSSL= yes
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Crypt/Curve25519/Curve25519.so
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Curve25519/distinfo b/security/p5-Crypt-Curve25519/distinfo
new file mode 100644
index 000000000000..daf85b8902b7
--- /dev/null
+++ b/security/p5-Crypt-Curve25519/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-Curve25519-0.05.tar.gz) = d660922f36300f17b7de489c10939ff25043c5cb4a5b44fe53cc3becdeee318b
+SIZE (Crypt-Curve25519-0.05.tar.gz) = 73083
diff --git a/security/p5-Crypt-Curve25519/pkg-descr b/security/p5-Crypt-Curve25519/pkg-descr
new file mode 100644
index 000000000000..790ef3d7d668
--- /dev/null
+++ b/security/p5-Crypt-Curve25519/pkg-descr
@@ -0,0 +1,9 @@
+Curve25519 is a state-of-the-art Diffie-Hellman function suitable for a wide
+variety of applications.
+
+Given a user's 32-byte secret key, Curve25519 computes the user's 32-byte public
+key. Given the user's 32-byte secret key and another user's 32-byte public key,
+Curve25519 computes a 32-byte secret shared by the two users. This secret can
+then be used to authenticate and encrypt messages between the two users.
+
+WWW: http://search.cpan.org/dist/Crypt-Curve25519/
diff --git a/security/p5-Crypt-Curve25519/pkg-plist b/security/p5-Crypt-Curve25519/pkg-plist
new file mode 100644
index 000000000000..1adfe63b6eda
--- /dev/null
+++ b/security/p5-Crypt-Curve25519/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_ARCH%%/Crypt/Curve25519.pm
+%%SITE_ARCH%%/auto/Crypt/Curve25519/Curve25519.so
+%%SITE_ARCH%%/auto/Crypt/Curve25519/autosplit.ix
+%%PERL5_MAN3%%/Crypt::Curve25519.3.gz