aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-08 18:29:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-08 18:29:21 +0000
commitd810c2cdf60ebc461b25288b038ccadeb05572ad (patch)
tree4bc3808a8ed1fc6b6775b00017f1447d7df17f15 /security
parent4e40cf2000cd28d8d57082a679d104e97540de57 (diff)
downloadports-d810c2cdf60ebc461b25288b038ccadeb05572ad.tar.gz
ports-d810c2cdf60ebc461b25288b038ccadeb05572ad.zip
Add rubygem-omniauth-jwt 0.0.2
JSON Web Token (JWT) is a simple way to send verified information between two parties online. This can be useful as a mechanism for providing Single Sign-On (SSO) to an application by allowing an authentication server to send a validated claim and log the user in. This is how Zendesk does SSO, for example. OmniAuth::JWT provides a clean, simple wrapper on top of JWT so that you can easily implement this kind of SSO either between your own applications or allow third parties to delegate authentication. WWW: https://github.com/mbleigh/omniauth-jwt
Notes
Notes: svn path=/head/; revision=466815
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-omniauth-jwt/Makefile22
-rw-r--r--security/rubygem-omniauth-jwt/distinfo3
-rw-r--r--security/rubygem-omniauth-jwt/pkg-descr10
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index cd45bac0f789..52c3b2832529 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1117,6 +1117,7 @@
SUBDIR += rubygem-omniauth-cas
SUBDIR += rubygem-omniauth-cas3
SUBDIR += rubygem-omniauth-gitlab
+ SUBDIR += rubygem-omniauth-jwt
SUBDIR += rubygem-omniauth-multipassword
SUBDIR += rubygem-omniauth-oauth2-generic
SUBDIR += rubygem-omniauth-saml
diff --git a/security/rubygem-omniauth-jwt/Makefile b/security/rubygem-omniauth-jwt/Makefile
new file mode 100644
index 000000000000..bfca77fbd53b
--- /dev/null
+++ b/security/rubygem-omniauth-jwt/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= omniauth-jwt
+PORTVERSION= 0.0.2
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OmniAuth strategy to accept JWT-based single sign-on
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-jwt>=0:www/rubygem-jwt \
+ rubygem-omniauth>=1.1:security/rubygem-omniauth
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-jwt/distinfo b/security/rubygem-omniauth-jwt/distinfo
new file mode 100644
index 000000000000..a54377f75ca5
--- /dev/null
+++ b/security/rubygem-omniauth-jwt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523121359
+SHA256 (rubygem/omniauth-jwt-0.0.2.gem) = b9bfcc600c3ed34feb0976f1e99035f3d1dba839f713f0ea08da9d5b7e49b963
+SIZE (rubygem/omniauth-jwt-0.0.2.gem) = 9216
diff --git a/security/rubygem-omniauth-jwt/pkg-descr b/security/rubygem-omniauth-jwt/pkg-descr
new file mode 100644
index 000000000000..07e25d387893
--- /dev/null
+++ b/security/rubygem-omniauth-jwt/pkg-descr
@@ -0,0 +1,10 @@
+JSON Web Token (JWT) is a simple way to send verified information between two
+parties online. This can be useful as a mechanism for providing Single Sign-On
+(SSO) to an application by allowing an authentication server to send a validated
+claim and log the user in. This is how Zendesk does SSO, for example.
+
+OmniAuth::JWT provides a clean, simple wrapper on top of JWT so that you can
+easily implement this kind of SSO either between your own applications or allow
+third parties to delegate authentication.
+
+WWW: https://github.com/mbleigh/omniauth-jwt