aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-12-02 13:34:41 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-12-02 13:34:41 +0000
commite0cb52266988bb84d31862c1b25ed18b8f498f15 (patch)
tree7336c208ccf8e48d8c5e05800bb89716cb09e22d /security
parent137a04ceda3674c17a73ca7731f0895f0056a0ea (diff)
downloadports-e0cb52266988bb84d31862c1b25ed18b8f498f15.tar.gz
ports-e0cb52266988bb84d31862c1b25ed18b8f498f15.zip
Add STAGEDIR support.
Notes
Notes: svn path=/head/; revision=335485
Diffstat (limited to 'security')
-rw-r--r--security/trousers/Makefile13
-rw-r--r--security/trousers/Makefile.man90
-rw-r--r--security/trousers/pkg-plist90
3 files changed, 92 insertions, 101 deletions
diff --git a/security/trousers/Makefile b/security/trousers/Makefile
index d9da3ed2522b..cf4ed4706b9c 100644
--- a/security/trousers/Makefile
+++ b/security/trousers/Makefile
@@ -32,9 +32,8 @@ GROUPS= _tss
OPTIONS_DEFINE= EMULATOR DEBUG
EMULATOR_DESC= Build for use with the tpm-emulator
+DEBUG_CONFIGURE_ENABLE= debug
-NO_STAGE= yes
-.include "Makefile.man"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEMULATOR}
@@ -52,10 +51,6 @@ CONFLICTS+= tpm-emulator-[0-9]*
PLIST_SUB+= TDDL=""
.endif
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--enable-debug
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's/-liconv$$/${ICONV_LIB}/' \
${WRKSRC}/src/tspi/Makefile.am
@@ -67,10 +62,6 @@ run-autotools-autoreconf:
post-install:
${INSTALL_DATA} -o ${USERS} -g ${GROUPS} -m 0600 \
- ${WRKSRC}/dist/tcsd.conf ${PREFIX}/etc/tcsd.conf.dist
- @[ -f ${PREFIX}/etc/tcsd.conf ] || \
- ${INSTALL_DATA} -o ${USERS} -g ${GROUPS} -m 0600 \
- ${WRKSRC}/dist/tcsd.conf ${PREFIX}/etc/tcsd.conf
- @${CAT} ${PKGMESSAGE}
+ ${WRKSRC}/dist/tcsd.conf ${STAGEDIR}${PREFIX}/etc/tcsd.conf.dist
.include <bsd.port.mk>
diff --git a/security/trousers/Makefile.man b/security/trousers/Makefile.man
deleted file mode 100644
index f7cca6323a16..000000000000
--- a/security/trousers/Makefile.man
+++ /dev/null
@@ -1,90 +0,0 @@
-MAN3= Tspi_ChangeAuth.3 \
- Tspi_ChangeAuthAsym.3 \
- Tspi_Context_Close.3 \
- Tspi_Context_CloseObject.3 \
- Tspi_Context_Connect.3 \
- Tspi_Context_Create.3 \
- Tspi_Context_CreateObject.3 \
- Tspi_Context_FreeMemory.3 \
- Tspi_Context_GetCapability.3 \
- Tspi_Context_GetDefaultPolicy.3 \
- Tspi_Context_GetKeyByPublicInfo.3 \
- Tspi_Context_GetKeyByUUID.3 \
- Tspi_Context_GetRegisteredKeysByUUID.3 \
- Tspi_Context_GetRegisteredKeysByUUID2.3 \
- Tspi_Context_GetTpmObject.3 \
- Tspi_Context_LoadKeyByBlob.3 \
- Tspi_Context_LoadKeyByUUID.3 \
- Tspi_Context_RegisterKey.3 \
- Tspi_Context_UnregisterKey.3 \
- Tspi_DAA_IssueCredential.3 \
- Tspi_DAA_IssueInit.3 \
- Tspi_DAA_IssueSetup.3 \
- Tspi_DAA_IssuerKeyVerification.3 \
- Tspi_DAA_VerifyInit.3 \
- Tspi_DAA_VerifySignature.3 \
- Tspi_Data_Bind.3 \
- Tspi_Data_Seal.3 \
- Tspi_Data_Unbind.3 \
- Tspi_Data_Unseal.3 \
- Tspi_DecodeBER_TssBlob.3 \
- Tspi_EncodeDER_TssBlob.3 \
- Tspi_GetAttribData.3 \
- Tspi_GetAttribUint32.3 \
- Tspi_GetPolicyObject.3 \
- Tspi_Hash_GetHashValue.3 \
- Tspi_Hash_SetHashValue.3 \
- Tspi_Hash_Sign.3 \
- Tspi_Hash_UpdateHashValue.3 \
- Tspi_Hash_VerifySignature.3 \
- Tspi_Key_CertifyKey.3 \
- Tspi_Key_ConvertMigrationBlob.3 \
- Tspi_Key_CreateKey.3 \
- Tspi_Key_CreateMigrationBlob.3 \
- Tspi_Key_GetPubKey.3 \
- Tspi_Key_LoadKey.3 \
- Tspi_Key_UnloadKey.3 \
- Tspi_Key_WrapKey.3 \
- Tspi_PcrComposite_GetPcrValue.3 \
- Tspi_PcrComposite_SelectPcrIndex.3 \
- Tspi_PcrComposite_SetPcrValue.3 \
- Tspi_Policy_AssignToObject.3 \
- Tspi_Policy_FlushSecret.3 \
- Tspi_Policy_SetSecret.3 \
- Tspi_SetAttribData.3 \
- Tspi_SetAttribUint32.3 \
- Tspi_TPM_AuthorizeMigrationTicket.3 \
- Tspi_TPM_CertifySelfTest.3 \
- Tspi_TPM_CheckMaintenancePubKey.3 \
- Tspi_TPM_ClearOwner.3 \
- Tspi_TPM_CollateIdentityRequest.3 \
- Tspi_TPM_CreateEndorsementKey.3 \
- Tspi_TPM_CreateMaintenanceArchive.3 \
- Tspi_TPM_CMKSetRestrictions.3 \
- Tspi_TPM_DAA_JoinCreateDaaPubKey.3 \
- Tspi_TPM_DAA_JoinInit.3 \
- Tspi_TPM_DAA_JoinStoreCredential.3 \
- Tspi_TPM_DAA_Sign.3 \
- Tspi_TPM_DirRead.3 \
- Tspi_TPM_DirWrite.3 \
- Tspi_TPM_GetAuditDigest.3 \
- Tspi_TPM_GetCapability.3 \
- Tspi_TPM_GetEvent.3 \
- Tspi_TPM_GetEventLog.3 \
- Tspi_TPM_GetEvents.3 \
- Tspi_TPM_GetPubEndorsementKey.3 \
- Tspi_TPM_GetRandom.3 \
- Tspi_TPM_GetStatus.3 \
- Tspi_TPM_GetTestResult.3 \
- Tspi_TPM_KillMaintenanceFeature.3 \
- Tspi_TPM_LoadMaintenancePubKey.3 \
- Tspi_TPM_OwnerGetSRKPubKey.3 \
- Tspi_TPM_PcrExtend.3 \
- Tspi_TPM_PcrRead.3 \
- Tspi_TPM_Quote.3 \
- Tspi_TPM_SelfTestFull.3 \
- Tspi_TPM_SetStatus.3 \
- Tspi_TPM_StirRandom.3 \
- Tspi_TPM_TakeOwnership.3
-MAN5= tcsd.conf.5
-MAN8= tcsd.8
diff --git a/security/trousers/pkg-plist b/security/trousers/pkg-plist
index 24f4bec84695..3a09c781c8dc 100644
--- a/security/trousers/pkg-plist
+++ b/security/trousers/pkg-plist
@@ -30,6 +30,96 @@ lib/libtspi.la
lib/libtspi.so
lib/libtspi.so.3
sbin/tcsd
+man/man3/Tspi_ChangeAuth.3.gz
+man/man3/Tspi_ChangeAuthAsym.3.gz
+man/man3/Tspi_Context_Close.3.gz
+man/man3/Tspi_Context_CloseObject.3.gz
+man/man3/Tspi_Context_Connect.3.gz
+man/man3/Tspi_Context_Create.3.gz
+man/man3/Tspi_Context_CreateObject.3.gz
+man/man3/Tspi_Context_FreeMemory.3.gz
+man/man3/Tspi_Context_GetCapability.3.gz
+man/man3/Tspi_Context_GetDefaultPolicy.3.gz
+man/man3/Tspi_Context_GetKeyByPublicInfo.3.gz
+man/man3/Tspi_Context_GetKeyByUUID.3.gz
+man/man3/Tspi_Context_GetRegisteredKeysByUUID.3.gz
+man/man3/Tspi_Context_GetRegisteredKeysByUUID2.3.gz
+man/man3/Tspi_Context_GetTpmObject.3.gz
+man/man3/Tspi_Context_LoadKeyByBlob.3.gz
+man/man3/Tspi_Context_LoadKeyByUUID.3.gz
+man/man3/Tspi_Context_RegisterKey.3.gz
+man/man3/Tspi_Context_UnregisterKey.3.gz
+man/man3/Tspi_DAA_IssueCredential.3.gz
+man/man3/Tspi_DAA_IssueInit.3.gz
+man/man3/Tspi_DAA_IssueSetup.3.gz
+man/man3/Tspi_DAA_IssuerKeyVerification.3.gz
+man/man3/Tspi_DAA_VerifyInit.3.gz
+man/man3/Tspi_DAA_VerifySignature.3.gz
+man/man3/Tspi_Data_Bind.3.gz
+man/man3/Tspi_Data_Seal.3.gz
+man/man3/Tspi_Data_Unbind.3.gz
+man/man3/Tspi_Data_Unseal.3.gz
+man/man3/Tspi_DecodeBER_TssBlob.3.gz
+man/man3/Tspi_EncodeDER_TssBlob.3.gz
+man/man3/Tspi_GetAttribData.3.gz
+man/man3/Tspi_GetAttribUint32.3.gz
+man/man3/Tspi_GetPolicyObject.3.gz
+man/man3/Tspi_Hash_GetHashValue.3.gz
+man/man3/Tspi_Hash_SetHashValue.3.gz
+man/man3/Tspi_Hash_Sign.3.gz
+man/man3/Tspi_Hash_UpdateHashValue.3.gz
+man/man3/Tspi_Hash_VerifySignature.3.gz
+man/man3/Tspi_Key_CertifyKey.3.gz
+man/man3/Tspi_Key_ConvertMigrationBlob.3.gz
+man/man3/Tspi_Key_CreateKey.3.gz
+man/man3/Tspi_Key_CreateMigrationBlob.3.gz
+man/man3/Tspi_Key_GetPubKey.3.gz
+man/man3/Tspi_Key_LoadKey.3.gz
+man/man3/Tspi_Key_UnloadKey.3.gz
+man/man3/Tspi_Key_WrapKey.3.gz
+man/man3/Tspi_PcrComposite_GetPcrValue.3.gz
+man/man3/Tspi_PcrComposite_SelectPcrIndex.3.gz
+man/man3/Tspi_PcrComposite_SetPcrValue.3.gz
+man/man3/Tspi_Policy_AssignToObject.3.gz
+man/man3/Tspi_Policy_FlushSecret.3.gz
+man/man3/Tspi_Policy_SetSecret.3.gz
+man/man3/Tspi_SetAttribData.3.gz
+man/man3/Tspi_SetAttribUint32.3.gz
+man/man3/Tspi_TPM_AuthorizeMigrationTicket.3.gz
+man/man3/Tspi_TPM_CMKSetRestrictions.3.gz
+man/man3/Tspi_TPM_CertifySelfTest.3.gz
+man/man3/Tspi_TPM_CheckMaintenancePubKey.3.gz
+man/man3/Tspi_TPM_ClearOwner.3.gz
+man/man3/Tspi_TPM_CollateIdentityRequest.3.gz
+man/man3/Tspi_TPM_CreateEndorsementKey.3.gz
+man/man3/Tspi_TPM_CreateMaintenanceArchive.3.gz
+man/man3/Tspi_TPM_DAA_JoinCreateDaaPubKey.3.gz
+man/man3/Tspi_TPM_DAA_JoinInit.3.gz
+man/man3/Tspi_TPM_DAA_JoinStoreCredential.3.gz
+man/man3/Tspi_TPM_DAA_Sign.3.gz
+man/man3/Tspi_TPM_DirRead.3.gz
+man/man3/Tspi_TPM_DirWrite.3.gz
+man/man3/Tspi_TPM_GetAuditDigest.3.gz
+man/man3/Tspi_TPM_GetCapability.3.gz
+man/man3/Tspi_TPM_GetEvent.3.gz
+man/man3/Tspi_TPM_GetEventLog.3.gz
+man/man3/Tspi_TPM_GetEvents.3.gz
+man/man3/Tspi_TPM_GetPubEndorsementKey.3.gz
+man/man3/Tspi_TPM_GetRandom.3.gz
+man/man3/Tspi_TPM_GetStatus.3.gz
+man/man3/Tspi_TPM_GetTestResult.3.gz
+man/man3/Tspi_TPM_KillMaintenanceFeature.3.gz
+man/man3/Tspi_TPM_LoadMaintenancePubKey.3.gz
+man/man3/Tspi_TPM_OwnerGetSRKPubKey.3.gz
+man/man3/Tspi_TPM_PcrExtend.3.gz
+man/man3/Tspi_TPM_PcrRead.3.gz
+man/man3/Tspi_TPM_Quote.3.gz
+man/man3/Tspi_TPM_SelfTestFull.3.gz
+man/man3/Tspi_TPM_SetStatus.3.gz
+man/man3/Tspi_TPM_StirRandom.3.gz
+man/man3/Tspi_TPM_TakeOwnership.3.gz
+man/man5/tcsd.conf.5.gz
+man/man8/tcsd.8.gz
@unexec cmp -s %D/etc/tcsd.conf %D/etc/tcsd.conf.dist && rm -f %D/etc/tcsd.conf || true
etc/tcsd.conf.dist
@exec [ -f %D/etc/tcsd.conf ] || cp -p %D/etc/tcsd.conf.dist %D/etc/tcsd.conf