aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2018-04-09 18:17:32 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2018-04-09 18:17:32 +0000
commite84ed6ab716477a51a2fd6f6b178d24f10b06b98 (patch)
tree12ea6c2289d87c0aea9f47496d32d8687e2a9c32 /security
parent2415bff2912c7ead959fe11d9b6dc97b940c820d (diff)
downloadports-e84ed6ab716477a51a2fd6f6b178d24f10b06b98.tar.gz
ports-e84ed6ab716477a51a2fd6f6b178d24f10b06b98.zip
security/py-fail2ban: Update to 0.10.3
Changelog: https://github.com/fail2ban/fail2ban/blob/0.10.3.1/ChangeLog PR: 227389 Submitted by: theis@gmx.at (maintainer)
Notes
Notes: svn path=/head/; revision=466874
Diffstat (limited to 'security')
-rw-r--r--security/py-fail2ban/Makefile2
-rw-r--r--security/py-fail2ban/distinfo6
-rw-r--r--security/py-fail2ban/files/patch-fail2ban_client_csocket.py34
3 files changed, 38 insertions, 4 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index 9827d31186a9..b67f53bc3ea5 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fail2ban
-PORTVERSION= 0.10.2
+PORTVERSION= 0.10.3
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-fail2ban/distinfo b/security/py-fail2ban/distinfo
index 30a185f58cde..38822fdb3f84 100644
--- a/security/py-fail2ban/distinfo
+++ b/security/py-fail2ban/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516358804
-SHA256 (fail2ban-fail2ban-0.10.2_GH0.tar.gz) = 1c1a969137c56f7e8b90e5f14d78b80214d34d67209787bfddc8d5804ceb29cc
-SIZE (fail2ban-fail2ban-0.10.2_GH0.tar.gz) = 474624
+TIMESTAMP = 1523170020
+SHA256 (fail2ban-fail2ban-0.10.3_GH0.tar.gz) = 92ee35ec131f0005964f6794f69a9207827b428dd05877a6eacee584c5c11642
+SIZE (fail2ban-fail2ban-0.10.3_GH0.tar.gz) = 485453
diff --git a/security/py-fail2ban/files/patch-fail2ban_client_csocket.py b/security/py-fail2ban/files/patch-fail2ban_client_csocket.py
new file mode 100644
index 000000000000..c5b78b19b901
--- /dev/null
+++ b/security/py-fail2ban/files/patch-fail2ban_client_csocket.py
@@ -0,0 +1,34 @@
+--- fail2ban/client/csocket.py.orig 2018-04-08 10:28:39.135695000 +0200
++++ fail2ban/client/csocket.py 2018-04-08 10:35:39.403548000 +0200
+@@ -43,7 +43,7 @@
+ self.__csock.connect(sock)
+
+ def __del__(self):
+- self.close(False)
++ self.close()
+
+ def send(self, msg, nonblocking=False, timeout=None):
+ # Convert every list member to string
+@@ -56,13 +56,18 @@
+ def settimeout(self, timeout):
+ self.__csock.settimeout(timeout if timeout != -1 else self.__deftout)
+
+- def close(self, sendEnd=True):
++ def close(self):
+ if not self.__csock:
+ return
+- if sendEnd:
++ try:
+ self.__csock.sendall(CSPROTO.CLOSE + CSPROTO.END)
+- self.__csock.shutdown(socket.SHUT_RDWR)
+- self.__csock.close()
++ self.__csock.shutdown(socket.SHUT_RDWR)
++ except socket.error: # pragma: no cover - normally unreachable
++ pass
++ try:
++ self.__csock.close()
++ except socket.error: # pragma: no cover - normally unreachable
++ pass
+ self.__csock = None
+
+ @staticmethod