aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-07-13 13:28:47 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-07-13 13:39:44 +0000
commiteae623906cbfce158dc40f64793f738c4d3a6a42 (patch)
tree4b1f8edc0c9a57fa7e3868c9b7f27a98e0f206ea /security
parent41a3548060aa366986f36945c5a3303e4daa0009 (diff)
downloadports-eae623906cbfce158dc40f64793f738c4d3a6a42.tar.gz
ports-eae623906cbfce158dc40f64793f738c4d3a6a42.zip
*: Use angr.mk in the ports tree
Diffstat (limited to 'security')
-rw-r--r--security/py-ailment/Makefile11
-rw-r--r--security/py-angr/Makefile7
-rw-r--r--security/py-angr/Makefile.version2
-rw-r--r--security/py-pyvex/Makefile10
-rw-r--r--security/py-pyvex/distinfo6
5 files changed, 7 insertions, 29 deletions
diff --git a/security/py-ailment/Makefile b/security/py-ailment/Makefile
index 6701468ac479..c36bfbe58a59 100644
--- a/security/py-ailment/Makefile
+++ b/security/py-ailment/Makefile
@@ -12,23 +12,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}angr>=${ANGR_VERSION}:security/py-angr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}archinfo>=${ANGR_VERSION}:devel/py-archinfo@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyvex>=${ANGR_VERSION}:security/py-pyvex@${PY_FLAVOR} \
z3>0:math/z3
-USES= gmake localbase python:3.6+
+USES= angr:binaries,nose gmake localbase python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= angr
-GH_TUPLE= angr:binaries:${ANGR_BINARIES_TAGNAME}:binaries
USE_PYTHON= autoplist distutils
NO_ARCH= yes
-pre-test:
- @${LN} -Fs ${WRKSRC_binaries} ${WRKDIR}/binaries
-
-do-test:
- @(cd ${TEST_WRKSRC}/tests && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER})
-
-.include "${.CURDIR}/../../security/py-angr/Makefile.version"
.include <bsd.port.mk>
diff --git a/security/py-angr/Makefile b/security/py-angr/Makefile
index 6c60d4343227..6ccfc8d1b26f 100644
--- a/security/py-angr/Makefile
+++ b/security/py-angr/Makefile
@@ -39,9 +39,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ailment>=${ANGR_VERSION}:security/py-ailment
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keystone-engine>=0:devel/py-keystone-engine@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
-USES= gmake localbase:ldflags python:3.6+
+USES= angr:binaries gmake localbase:ldflags python:3.6+
USE_GITHUB= yes
-GH_TUPLE= ${PORTNAME}:binaries:${ANGR_BINARIES_TAGNAME}:binaries
USE_PYTHON= autoplist distutils
TEST_ENV= ${MAKE_ENV} \
@@ -85,11 +84,7 @@ _NOSE_EXCLUDE= (${_EXCLUDED_TESTS:S, , ,g:S, ,|,gW})
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/lib/angr_native*.so
-pre-test:
- @${LN} -Fs ${WRKSRC_binaries} ${WRKDIR}/binaries
-
do-test:
@(cd ${WRKSRC}/tests && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER} -v)
-.include "${.CURDIR}/Makefile.version"
.include <bsd.port.mk>
diff --git a/security/py-angr/Makefile.version b/security/py-angr/Makefile.version
deleted file mode 100644
index 57e11d9f7df6..000000000000
--- a/security/py-angr/Makefile.version
+++ /dev/null
@@ -1,2 +0,0 @@
-ANGR_VERSION= 9.0.5405
-ANGR_BINARIES_TAGNAME= v${ANGR_VERSION}
diff --git a/security/py-pyvex/Makefile b/security/py-pyvex/Makefile
index 4846ee46cc75..d82596ba229b 100644
--- a/security/py-pyvex/Makefile
+++ b/security/py-pyvex/Makefile
@@ -27,11 +27,10 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}angr>=${DISTVERSION}:security/py-angr@${PY_FLAVOR} \
z3>=0:math/z3
-USES= gmake localbase python:3.5+
+USES= angr:binaries gmake localbase python:3.5+
USE_CSTD= c99
USE_GITHUB= nodefault
-GH_TUPLE= angr:${PORTNAME}:v${DISTVERSION}:tests \
- angr:binaries:9bf9c59002c2fb751ae2357f08fb9f4f8171a4ff:binaries
+GH_TUPLE= angr:${PORTNAME}:v${DISTVERSION}:tests
USE_LDCONFIG= ${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/lib
USE_PYTHON= autoplist distutils
@@ -49,12 +48,7 @@ post-patch:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/lib/lib${PORTNAME}*.so
-pre-test:
- @${LN} -Fs ${WRKSRC_tests}/tests ${WRKSRC}/tests
- @${LN} -Fs ${WRKSRC_binaries} ${WRKDIR}/binaries
-
do-test:
@(cd ${WRKSRC} && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER} tests/*)
-.include "${.CURDIR}/../../security/py-angr/Makefile.version"
.include <bsd.port.mk>
diff --git a/security/py-pyvex/distinfo b/security/py-pyvex/distinfo
index e9c3ea4a7815..53e0a8892a67 100644
--- a/security/py-pyvex/distinfo
+++ b/security/py-pyvex/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1610804745
+TIMESTAMP = 1626098519
SHA256 (pyvex-9.0.5405.tar.gz) = 6d34fb801432b6c5f95ab6b86c462d3aec8c93b751544dad3b40ba7d12984c29
SIZE (pyvex-9.0.5405.tar.gz) = 1767188
SHA256 (angr-pyvex-v9.0.5405_GH0.tar.gz) = 63d3b4ca662c052a714e83e1d573ccf5865004cfd63cdbd5fb85b533864651be
SIZE (angr-pyvex-v9.0.5405_GH0.tar.gz) = 87680
-SHA256 (angr-binaries-9bf9c59002c2fb751ae2357f08fb9f4f8171a4ff_GH0.tar.gz) = 2c6f5130f5ee51e4cd8d891a137a347141cf155a6b2dbb248b02ac7cf11c2631
-SIZE (angr-binaries-9bf9c59002c2fb751ae2357f08fb9f4f8171a4ff_GH0.tar.gz) = 56723730
+SHA256 (angr-binaries-v9.0.5405_GH0.tar.gz) = c6cf9e357450d485ff9f32bba6f495e7a0336178b6d8dde1bb16430da8b58efe
+SIZE (angr-binaries-v9.0.5405_GH0.tar.gz) = 57764618