aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-12 10:14:08 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-12 10:14:08 +0000
commitf928a2ba453286a89bd0c0be659af73a3110a8dc (patch)
tree294f7d0c027bd591dee828d81e74645f37decdf7 /security
parent1493d9fb290ccbb7668dc50f9d0d6593152f0984 (diff)
downloadports-f928a2ba453286a89bd0c0be659af73a3110a8dc.tar.gz
ports-f928a2ba453286a89bd0c0be659af73a3110a8dc.zip
New port: security/rubygem-securecompare
securecompare borrows the secure_compare private method from ActiveSupport::MessageVerifier which lets you do safely compare strings without being vulnerable to timing attacks. Useful for Basic HTTP Authentication in your rack/rails application. WWW: https://github.com/samuelkadolph/securecompare
Notes
Notes: svn path=/head/; revision=443421
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-securecompare/Makefile18
-rw-r--r--security/rubygem-securecompare/distinfo3
-rw-r--r--security/rubygem-securecompare/pkg-descr6
4 files changed, 28 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 945d80121617..2c73e693affa 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1076,6 +1076,7 @@
SUBDIR += rubygem-ruby-rc4
SUBDIR += rubygem-ruby-saml
SUBDIR += rubygem-scrypt
+ SUBDIR += rubygem-securecompare
SUBDIR += rubygem-signet
SUBDIR += rubygem-six
SUBDIR += rubygem-sshkey
diff --git a/security/rubygem-securecompare/Makefile b/security/rubygem-securecompare/Makefile
new file mode 100644
index 000000000000..1b3957671e18
--- /dev/null
+++ b/security/rubygem-securecompare/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= securecompare
+PORTVERSION= 1.0.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Constant time string comparison
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-securecompare/distinfo b/security/rubygem-securecompare/distinfo
new file mode 100644
index 000000000000..c0ae80b662ac
--- /dev/null
+++ b/security/rubygem-securecompare/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497262188
+SHA256 (rubygem/securecompare-1.0.0.gem) = cb0c6599deaaedf6d28f8d88538b06e7198c4826b1b8edb1dbeb44a2162fc62b
+SIZE (rubygem/securecompare-1.0.0.gem) = 6656
diff --git a/security/rubygem-securecompare/pkg-descr b/security/rubygem-securecompare/pkg-descr
new file mode 100644
index 000000000000..ae78e5ed7100
--- /dev/null
+++ b/security/rubygem-securecompare/pkg-descr
@@ -0,0 +1,6 @@
+securecompare borrows the secure_compare private method from
+ActiveSupport::MessageVerifier which lets you do safely compare strings without
+being vulnerable to timing attacks. Useful for Basic HTTP Authentication in your
+rack/rails application.
+
+WWW: https://github.com/samuelkadolph/securecompare