aboutsummaryrefslogtreecommitdiff
path: root/shells/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-16 09:02:00 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-16 09:02:00 +0000
commitf8eeebacaa1df7c7e243d4e5f77eacfdb9f42711 (patch)
tree27de0aa6ad8374df9c06f838240488b2270cbe95 /shells/Makefile
parent0ef6a53da1a75a16261e1c66e2226aceb5992889 (diff)
downloadports-f8eeebacaa1df7c7e243d4e5f77eacfdb9f42711.tar.gz
ports-f8eeebacaa1df7c7e243d4e5f77eacfdb9f42711.zip
Add ruby-shell, a Ruby library to run commands and control jobs like a
shell. Pipes and redirections work just as expected: sh = Shell.cd("/foo") sh.cat("bar") | sh.tee("baz") > "baa" # or sh.transact do cat("bar") | tee("baz") > "baa" end
Notes
Notes: svn path=/head/; revision=39912
Diffstat (limited to 'shells/Makefile')
-rw-r--r--shells/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index a9eeb1f2fd97..acdd23eb6f55 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -14,6 +14,7 @@
SUBDIR += pdksh
SUBDIR += perlsh
SUBDIR += rc
+ SUBDIR += ruby-shell
SUBDIR += sash
SUBDIR += scsh
SUBDIR += tcsh