aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion-classic
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2010-09-06 20:30:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2010-09-06 20:30:14 +0000
commitd3a1b2b72b96d6f832bb39566e2c1f081383f176 (patch)
tree9ad5ec824d10894765bc5a6f687c09997a95d751 /shells/bash-completion-classic
parent886b0e93253ec03a29b2e59c8eaf932e88045fa1 (diff)
downloadports-d3a1b2b72b96d6f832bb39566e2c1f081383f176.tar.gz
ports-d3a1b2b72b96d6f832bb39566e2c1f081383f176.zip
The rsync completion plugin causes the shell to freeze on amd64.
Until that gets resolved, I'm disconnecting the rsync plugin from the build on amd64. PR: ports/150322 Submitted by: ehaupt
Notes
Notes: svn path=/head/; revision=260658
Diffstat (limited to 'shells/bash-completion-classic')
-rw-r--r--shells/bash-completion-classic/Makefile15
-rw-r--r--shells/bash-completion-classic/pkg-plist2
2 files changed, 14 insertions, 3 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
index 6fffcfb66900..ad0cec8ca4d6 100644
--- a/shells/bash-completion-classic/Makefile
+++ b/shells/bash-completion-classic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash-completion
PORTVERSION= 1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
@@ -21,6 +22,15 @@ RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+AMD64_REMOVE_RSYNC= /contrib\/rsync/d
+PLIST_SUB+= NOAMD64="@comment "
+.else
+PLIST_SUB+= NOAMD64=""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
@@ -31,10 +41,11 @@ post-patch:
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|\(FLAC\)|\1\|flv\|FLV|' \
+ s|\(FLAC\)|\1\|flv\|FLV|; \
+ ${AMD64_REMOVE_RSYNC}' \
${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/shells/bash-completion-classic/pkg-plist b/shells/bash-completion-classic/pkg-plist
index 5fc2329a0750..da9385be9452 100644
--- a/shells/bash-completion-classic/pkg-plist
+++ b/shells/bash-completion-classic/pkg-plist
@@ -124,7 +124,7 @@ etc/bash_completion.d/rpcdebug
etc/bash_completion.d/rpm
etc/bash_completion.d/rpmcheck
etc/bash_completion.d/rrdtool
-etc/bash_completion.d/rsync
+%%NOAMD64%%etc/bash_completion.d/rsync
etc/bash_completion.d/rtcwake
etc/bash_completion.d/samba
etc/bash_completion.d/sbcl