aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 12:44:15 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 12:44:15 +0000
commit8707ef668ec7744e12484cd49607a3edaf3a9e8a (patch)
tree6827111b8d905e12ebb2f035d8f4ce97419c3d05 /shells/bash-completion
parentc62519058d20e1868cd48fe8093e3111da285aeb (diff)
downloadports-8707ef668ec7744e12484cd49607a3edaf3a9e8a.tar.gz
ports-8707ef668ec7744e12484cd49607a3edaf3a9e8a.zip
New port: shells/bash-completion
The shells/bash-completion port installs Ian Macdonald's programmable completion library for Bash 2.04 and above. This gives users context- sensitive tab-completion for such things as program arguments, SSH hostnames, NFS mounts, and so on. PR: ports/52790 Submitted by: Kirk Strauser <kirk@strauser.com>
Notes
Notes: svn path=/head/; revision=89798
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile32
-rw-r--r--shells/bash-completion/distinfo1
-rw-r--r--shells/bash-completion/files/patch-aa21
-rw-r--r--shells/bash-completion/pkg-descr7
-rw-r--r--shells/bash-completion/pkg-message9
-rw-r--r--shells/bash-completion/pkg-plist1
6 files changed, 71 insertions, 0 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
new file mode 100644
index 000000000000..aa3d8c4a4ea5
--- /dev/null
+++ b/shells/bash-completion/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bash_completion
+# Date created: 29 May 2003
+# Whom: kirk@strauser.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= bash-completion
+PORTVERSION= 20030527
+CATEGORIES= shells
+MASTER_SITES= http://www.caliban.org/files/bash/
+
+MAINTAINER= kirk@strauser.com
+COMMENT= Programmable completion library for Bash 2.04 and up
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
+WRKSRC= ${WRKDIR}/bash_completion
+NO_BUILD= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+pre-patch:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc/bash_completion
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/shells/bash-completion/distinfo b/shells/bash-completion/distinfo
new file mode 100644
index 000000000000..001dd5df24ca
--- /dev/null
+++ b/shells/bash-completion/distinfo
@@ -0,0 +1 @@
+MD5 (bash-completion-20030527.tar.gz) = 3b4de4c03804fa97fd3123443a9667c6
diff --git a/shells/bash-completion/files/patch-aa b/shells/bash-completion/files/patch-aa
new file mode 100644
index 000000000000..c7f35671ccef
--- /dev/null
+++ b/shells/bash-completion/files/patch-aa
@@ -0,0 +1,21 @@
+--- bash_completion.orig Mon May 26 22:22:44 2003
++++ bash_completion Wed Jun 4 18:02:33 2003
+@@ -27,14 +27,14 @@
+ if [ -n "$FUNCNAME" ]; then
+ # we're being sourced from within a function, so we can't use
+ # 'declare', as this will create local variables within a function
+- BASH_COMPLETION=${BASH_COMPLETION:-/etc/bash_completion} 2>/dev/null
+- BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/etc/bash_completion.d} \
++ BASH_COMPLETION=${BASH_COMPLETION:-/usr/local/etc/bash_completion} 2>/dev/null
++ BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d} \
+ 2>/dev/null
+ else
+- declare -r BASH_COMPLETION=${BASH_COMPLETION:-/etc/bash_completion} \
++ declare -r BASH_COMPLETION=${BASH_COMPLETION:-/usr/local/etc/bash_completion} \
+ 2>/dev/null
+ declare -r \
+- BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/etc/bash_completion.d} \
++ BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d} \
+ 2>/dev/null
+ fi
+
diff --git a/shells/bash-completion/pkg-descr b/shells/bash-completion/pkg-descr
new file mode 100644
index 000000000000..4f48a96869d3
--- /dev/null
+++ b/shells/bash-completion/pkg-descr
@@ -0,0 +1,7 @@
+This is a programmable completion library for bash2 users. It features the
+ability to tab-complete arguments for many common programs.
+
+WWW: http://www.caliban.org/bash/index.shtml
+
+- Kirk Strauser
+kirk@strauser.com
diff --git a/shells/bash-completion/pkg-message b/shells/bash-completion/pkg-message
new file mode 100644
index 000000000000..7bbf0ac073f2
--- /dev/null
+++ b/shells/bash-completion/pkg-message
@@ -0,0 +1,9 @@
+
+The programmable completion library is not enabled by default for various
+reasons. To use it, you should source %%PREFIX%%/etc/bash_completion from
+your .bashrc file. For example:
+
+ if [ -f %%PREFIX%%/etc/bash_completion ]; then
+ . %%PREFIX%%/etc/bash_completion
+ fi
+
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
new file mode 100644
index 000000000000..82e3255c8c49
--- /dev/null
+++ b/shells/bash-completion/pkg-plist
@@ -0,0 +1 @@
+etc/bash_completion