aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-29 18:26:25 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-29 18:26:25 +0000
commitbc1db54600150e5f260f8a347539dbdf1a214965 (patch)
tree802e995205f07b146b4b3617d2e03c12b73653ac /shells/bash-completion
parenta30816f3bf24edd874604c3dfdfbecf7e59d9e8a (diff)
downloadports-bc1db54600150e5f260f8a347539dbdf1a214965.tar.gz
ports-bc1db54600150e5f260f8a347539dbdf1a214965.zip
[1]:
- Update to 20050721 - OPTIONSify Moreover: - Improve the FreeBSD integration by fixing paths in the script - Use SUB_FILES=pkg-message [1]: PR: ports/84305 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=140420
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile47
-rw-r--r--shells/bash-completion/distinfo4
-rw-r--r--shells/bash-completion/files/patch-aa40
-rw-r--r--shells/bash-completion/files/pkg-message.in (renamed from shells/bash-completion/pkg-message)0
4 files changed, 29 insertions, 62 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 4a1f38922bb4..153af1418772 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -6,43 +6,50 @@
#
PORTNAME= bash-completion
-PORTVERSION= 20050112
+PORTVERSION= 20050721
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
MAINTAINER= kirk@strauser.com
COMMENT= Programmable completion library for Bash 2.04 and up
+WRKSRC= ${WRKDIR}/bash_completion
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+SUB_FILES= pkg-message
+PLIST_FILES= etc/bash_completion
+
+OPTIONS= BASH2 "Use shells/bash2 instead of shells/bash" off \
+ GSED "Use GNU sed to enable additional completions" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_BASH2)
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash2
.else
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
.endif
.if defined(WITH_GSED)
RUN_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
.endif
-WRKSRC= ${WRKDIR}/bash_completion
-NO_BUILD= yes
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_FILES= etc/bash_completion
-
-pre-everything::
- @${ECHO}
- @${ECHO} "You can build ${PKGNAME} with the following options:"
- @${ECHO} "WITH_BASH2 use shells/bash2 instead of shells/bash"
- @${ECHO} "WITH_GSED use GNU sed to enable additional completions"
- @${ECHO}
-
-pre-patch:
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
+ s|/etc/bash_completion|${PREFIX}&|g; \
+ s|/usr\(/sbin/postconf\)|${LOCALBASE}\1|g; \
+ s|/usr\(/lib/rpm/macros\)|${LOCALBASE}\1|g; \
+ s|/usr/share\(/ssl/openssl.cnf\)|/etc\1|g; \
+ s|/usr/ports|${PORTSDIR}|g; \
+ s|/usr/lib\(/aspell\)|${LOCALBASE}/share\1|g; \
+ s|/usr/share/info|&:${LOCALBASE}/info:${X11BASE}/info|g' \
+ ${WRKSRC}/bash_completion
do-install:
- ${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc/bash_completion
+ ${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/shells/bash-completion/distinfo b/shells/bash-completion/distinfo
index f1e83bafe44b..8e3a848c9c92 100644
--- a/shells/bash-completion/distinfo
+++ b/shells/bash-completion/distinfo
@@ -1,2 +1,2 @@
-MD5 (bash-completion-20050112.tar.gz) = 474ce9d1e16be6229d730ed8385fc871
-SIZE (bash-completion-20050112.tar.gz) = 106710
+MD5 (bash-completion-20050721.tar.gz) = 08e5321ead7079c84822368d7a41deda
+SIZE (bash-completion-20050721.tar.gz) = 111271
diff --git a/shells/bash-completion/files/patch-aa b/shells/bash-completion/files/patch-aa
deleted file mode 100644
index dd36d6b3651d..000000000000
--- a/shells/bash-completion/files/patch-aa
+++ /dev/null
@@ -1,40 +0,0 @@
---- bash_completion.orig Mon Oct 25 10:10:30 2004
-+++ bash_completion Mon Oct 25 10:12:35 2004
-@@ -31,14 +31,15 @@
- if [ -n "${FUNCNAME:-}" ]; then
- # we're being sourced from within a function, so we can't use
- # 'declare', as this will create local variables within a function
-- BASH_COMPLETION="${BASH_COMPLETION:-/etc/bash_completion}" 2>/dev/null
-- BASH_COMPLETION_DIR="${BASH_COMPLETION_DIR:=/etc/bash_completion.d}" \
-+ BASH_COMPLETION="${BASH_COMPLETION:-/usr/local/etc/bash_completion}" \
-+ 2>/dev/null
-+ BASH_COMPLETION_DIR="${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d}" \
- 2>/dev/null
- else
-- declare -r BASH_COMPLETION="${BASH_COMPLETION:-/etc/bash_completion}" \
-+ declare -r BASH_COMPLETION="${BASH_COMPLETION:-/usr/local/etc/bash_completion}" \
- 2>/dev/null
- declare -r \
-- BASH_COMPLETION_DIR="${BASH_COMPLETION_DIR:=/etc/bash_completion.d}"\
-+ BASH_COMPLETION_DIR="${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d}"\
- 2>/dev/null
- fi
-
-@@ -1131,7 +1132,7 @@
- else
- len=${#cur}
- idx=0
-- for pval in $( /usr/sbin/postconf -m ); do
-+ for pval in $( postconf -m ); do
- if [[ "$cur" == "${pval:0:$len}" ]]; then
- COMPREPLY[$idx]="$pval:"
- idx=$(($idx+1))
-@@ -1207,7 +1208,7 @@
- fi
- len=${#cur}
- idx=0
-- for pval in $( /usr/sbin/postconf | cut -d ' ' -f 1 ); do
-+ for pval in $( postconf | cut -d ' ' -f 1 ); do
- if [[ "$cur" == "${pval:0:$len}" ]]; then
- COMPREPLY[$idx]="$pval$eqext"
- idx=$(($idx+1))
diff --git a/shells/bash-completion/pkg-message b/shells/bash-completion/files/pkg-message.in
index 7bbf0ac073f2..7bbf0ac073f2 100644
--- a/shells/bash-completion/pkg-message
+++ b/shells/bash-completion/files/pkg-message.in