aboutsummaryrefslogtreecommitdiff
path: root/shells/bash
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2013-01-22 16:58:21 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2013-01-22 16:58:21 +0000
commit22ae009ed5c712cd6b2b5004b5f2834e3dd3a6b6 (patch)
tree68cb29aa61cd3354b7e8f5d3c26ec2f1fc664b21 /shells/bash
parent9b05e6ee4ceee8ae93b65e0dded7b67e62f26745 (diff)
downloadports-22ae009ed5c712cd6b2b5004b5f2834e3dd3a6b6.tar.gz
ports-22ae009ed5c712cd6b2b5004b5f2834e3dd3a6b6.zip
Update to Bash 4.2 patchlevel 42.
* If a backslash-newline (which is removed) with no other input is given as input to `read', the shell tries to dereference a null pointer and seg faults. * Under certain circumstances, bash attempts to expand variables in arithmetic expressions even when evaluation is being suppressed. * Output redirection applied to builtin commands missed I/O errors if they happened when the file descriptor was closed, rather than on write (e.g., like with an out-of-space error on a remote NFS file system). * Process substitution incorrectly inherited a flag that inhibited using the (local) temporary environment for variable lookups if it was providing the filename to a redirection. The intent the flag is to enforce the POSIX command expansion ordering rules.
Notes
Notes: svn path=/head/; revision=310831
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile2
-rw-r--r--shells/bash/distinfo10
2 files changed, 11 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 9d8bfcd749da..4e2250945a58 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bash
-PATCHLEVEL= 37
+PATCHLEVEL= 42
PORTVERSION= 4.2.${PATCHLEVEL:S/^0//g}
PORTREVISION?= 0
CATEGORIES= shells
diff --git a/shells/bash/distinfo b/shells/bash/distinfo
index 23d64458f629..b39e830910c2 100644
--- a/shells/bash/distinfo
+++ b/shells/bash/distinfo
@@ -74,4 +74,14 @@ SHA256 (bash/bash42-036) = fe293a1bc92ac4d272ae9b9a0de3afef7c06145a2b52337a09cac
SIZE (bash/bash42-036) = 3123
SHA256 (bash/bash42-037) = c7578cddd3bb2430689c740f58a03403800726dcd1268b28f91bf37f368e1674
SIZE (bash/bash42-037) = 3483
+SHA256 (bash/bash42-038) = b8c9a81bdf206be58ba491dfad80373b3348af769e80aaf72f7611ddbbbe6d57
+SIZE (bash/bash42-038) = 1290
+SHA256 (bash/bash42-039) = f4f9300a60321a5088ae9e54052a64c4d3e876f9a3a17ca104d58fa38b9c1791
+SIZE (bash/bash42-039) = 1603
+SHA256 (bash/bash42-040) = b265f9caf3c7321f95bc8e0b9e2c46bd86c226f00f05e823699aafb83c4aaa6c
+SIZE (bash/bash42-040) = 1710
+SHA256 (bash/bash42-041) = 05cc1951bd9f6624088dd6067486ff47f1825e333273d7df5f1b06b23baaf5eb
+SIZE (bash/bash42-041) = 1463
+SHA256 (bash/bash42-042) = faaa5c1f456517b258b2a65eaa664dd6a01eeff73c8ca4447c3a6de371bbf304
+SIZE (bash/bash42-042) = 1571
SHA256 (bash/FAQ) = IGNORE