aboutsummaryrefslogtreecommitdiff
path: root/shells/bash
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2022-10-01 10:11:01 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-10-01 10:12:09 +0000
commit3e147a1f594751a68fea00a28090d0792bee0b51 (patch)
treec91cdc76aa92320c248a0a16beb953e89cdcaed9 /shells/bash
parent270d32558409af5d445b63ff185a99b784927f8b (diff)
downloadports-3e147a1f594751a68fea00a28090d0792bee0b51.tar.gz
ports-3e147a1f594751a68fea00a28090d0792bee0b51.zip
shells/bash: fix static build
The logic in m4/strtoimax.m4 is inverted: it replaces strtoimax() if and only if it is present and functional. files/patch-configure avoids having to run autoreconf in the port and can be removed once the fix has been adopted upstream. differential Revision: https://reviews.freebsd.org/D36849
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile4
-rw-r--r--shells/bash/files/patch-configure11
-rw-r--r--shells/bash/files/patch-m4_strtoimax.m411
3 files changed, 23 insertions, 3 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 6fdb145d7cb3..59e37945f965 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -5,7 +5,7 @@ PORTNAME= bash
#PATCHLEVEL= 0
#PORTVERSION= 5.2.${PATCHLEVEL:S/^0//g}
PORTVERSION= 5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= GNU
#DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -59,8 +59,6 @@ PORTS_READLINE_BROKEN= ld: error: undefined symbol: rl_trim_arg_from_keyseq
PORTS_READLINE_USES= readline
PORTS_READLINE_CONFIGURE_WITH= installed-readline
-STATIC_BROKEN= multiple definition of strtoimax
-
.if empty(PKGNAMESUFFIX)
CONFLICTS+= bash-static bash52-static
.else
diff --git a/shells/bash/files/patch-configure b/shells/bash/files/patch-configure
new file mode 100644
index 000000000000..0ca11a5d826f
--- /dev/null
+++ b/shells/bash/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2022-09-23 14:13:22 UTC
++++ configure
+@@ -20443,7 +20443,7 @@ fi
+
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $bash_cv_func_strtoimax" >&5
+ printf "%s\n" "$bash_cv_func_strtoimax" >&6; }
+-if test $bash_cv_func_strtoimax = yes; then
++if test $bash_cv_func_strtoimax = no ; then
+ case " $LIBOBJS " in
+ *" strtoimax.$ac_objext "* ) ;;
+ *) LIBOBJS="$LIBOBJS strtoimax.$ac_objext"
diff --git a/shells/bash/files/patch-m4_strtoimax.m4 b/shells/bash/files/patch-m4_strtoimax.m4
new file mode 100644
index 000000000000..3c047bd97654
--- /dev/null
+++ b/shells/bash/files/patch-m4_strtoimax.m4
@@ -0,0 +1,11 @@
+--- m4/strtoimax.m4.orig 2022-04-11 20:31:52 UTC
++++ m4/strtoimax.m4
+@@ -29,7 +29,7 @@ AC_CACHE_VAL(bash_cv_func_strtoimax,
+ fi
+ ])
+ AC_MSG_RESULT($bash_cv_func_strtoimax)
+-if test $bash_cv_func_strtoimax = yes; then
++if test $bash_cv_func_strtoimax = no; then
+ AC_LIBOBJ(strtoimax)
+ fi
+ ])