aboutsummaryrefslogtreecommitdiff
path: root/shells/bash
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-08-24 19:03:08 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-08-24 19:03:08 +0000
commitb83961e1e30e33dcfdacc0fd30ac6c459a5ae2fa (patch)
tree9e8fcb431064c0c662bacdcff8a7048fa9812614 /shells/bash
parent32be5870ce1e041292195993a4e32890641fc286 (diff)
downloadports-b83961e1e30e33dcfdacc0fd30ac6c459a5ae2fa.tar.gz
ports-b83961e1e30e33dcfdacc0fd30ac6c459a5ae2fa.zip
Update manual page to refer to ${LOCALBASE}/etc/profile instead of /etc/profile.
See also ports/UPDATING (entry 20200716). PR: 248805 (based on) Submitted by: 0mp
Notes
Notes: svn path=/head/; revision=546106
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile5
-rw-r--r--shells/bash/files/patch-doc_bash.135
2 files changed, 36 insertions, 4 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 3ba3d1a91314..8b11b76e2f26 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 18
PORTVERSION= 5.0.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= shells
MASTER_SITES= GNU
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -81,7 +81,8 @@ post-patch:
# Ensure y.tab.c is regenerated
${TOUCH} ${WRKSRC}/parse.y
${RM} ${WRKSRC}/y.tab.c
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ ${WRKSRC}/doc/bash.1
.if ${PORT_OPTIONS:MSYSLOG}
@${REINPLACE_CMD} \
-e "s|/\*.*#define SYSLOG_HISTORY .*\*/|#define SYSLOG_HISTORY|g" \
diff --git a/shells/bash/files/patch-doc_bash.1 b/shells/bash/files/patch-doc_bash.1
index 2ac97835c24e..b6c1f4c78df4 100644
--- a/shells/bash/files/patch-doc_bash.1
+++ b/shells/bash/files/patch-doc_bash.1
@@ -12,6 +12,33 @@
.\" .}f
.\" ..
.\"
+@@ -204,7 +204,7 @@ library to read command lines when the shell is intera
+ .TP
+ .B \-\-noprofile
+ Do not read either the system-wide startup file
+-.FN /etc/profile
++.FN %%LOCALBASE%%/etc/profile
+ or any of the personal initialization files
+ .IR ~/.bash_profile ,
+ .IR ~/.bash_login ,
+@@ -316,7 +316,7 @@ When
+ .B bash
+ is invoked as an interactive login shell, or as a non-interactive shell
+ with the \fB\-\-login\fP option, it first reads and
+-executes commands from the file \fI/etc/profile\fP, if that
++executes commands from the file \fI%%LOCALBASE%%/etc/profile\fP, if that
+ file exists.
+ After reading that file, it looks for \fI~/.bash_profile\fP,
+ \fI~/.bash_login\fP, and \fI~/.profile\fP, in that order, and reads
+@@ -373,7 +373,7 @@ while conforming to the POSIX standard as well.
+ When invoked as an interactive login shell, or a non-interactive
+ shell with the \fB\-\-login\fP option, it first attempts to
+ read and execute commands from
+-.I /etc/profile
++.I %%LOCALBASE%%/etc/profile
+ and
+ .IR ~/.profile ,
+ in that order.
@@ -2444,7 +2444,7 @@ The value of this parameter is expanded (see
.SM
.B PROMPTING
@@ -21,7 +48,7 @@
.TP
.B PS2
The value of this parameter is expanded as with
-@@ -10880,7 +10880,7 @@ http://tiswww.case.edu/~chet/bash/POSIX -- a descripti
+@@ -10880,10 +10880,10 @@ http://tiswww.case.edu/~chet/bash/POSIX -- a descripti
.SH FILES
.PD 0
.TP
@@ -29,4 +56,8 @@
+.FN %%PREFIX%%/bin/bash
The \fBbash\fP executable
.TP
- .FN /etc/profile
+-.FN /etc/profile
++.FN %%LOCALBASE%%/etc/profile
+ The systemwide initialization file, executed for login shells
+ .TP
+ .FN ~/.bash_profile