aboutsummaryrefslogtreecommitdiff
path: root/shells/ksh2020/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-02-09 05:32:45 +0000
committerCy Schubert <cy@FreeBSD.org>2020-02-09 05:32:45 +0000
commit235a81d83cdb34c11be89b5e6c7bfea9b4bcf6fb (patch)
tree31b988805e78d0fae5cd8d57b88270663436c398 /shells/ksh2020/Makefile
parent7aae71ff082920a1de8093c55caaa840b1a2518e (diff)
downloadports-235a81d83cdb34c11be89b5e6c7bfea9b4bcf6fb.tar.gz
ports-235a81d83cdb34c11be89b5e6c7bfea9b4bcf6fb.zip
att/ast on Github has branched ksh2020 and reverted mainline back to
ksh93u+ and v-. See github commit 0be82553e98be77238577bc0eaafda0f1cf807fe. To learn how and why our att/ast upstream made this decision see https://github.com/att/ast/issues/1464 and https://github.com/att/ast/issues/1466. The next steps will be to update shells/ksh93-devel to att/ast master. shells/ksh93 will likely be based on att/ast master at 0be82553e98be77238577bc0eaafda0f1cf807fe or some future tag or branch.
Notes
Notes: svn path=/head/; revision=525624
Diffstat (limited to 'shells/ksh2020/Makefile')
-rw-r--r--shells/ksh2020/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/shells/ksh2020/Makefile b/shells/ksh2020/Makefile
new file mode 100644
index 000000000000..da526975bd01
--- /dev/null
+++ b/shells/ksh2020/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= ksh2020
+PORTVERSION= 2020
+CATEGORIES= shells
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Development branch of AT&T KornShell 93
+
+LICENSE= EPL
+
+USES= compiler:c11 meson ninja python:build
+
+USE_GITHUB= yes
+GH_ACCOUNT= att
+GH_PROJECT= ast
+GH_TAGNAME= ksh2020
+
+KSH_CONFLICTS= pdksh-*
+KSH93_CONFLICTS= ksh93-* ast-ksh-*
+
+MESON_BUILD_DIR= build
+
+OPTIONS_DEFAULT= KSH93
+OPTIONS_SINGLE= BIN_KSH
+OPTIONS_SINGLE_BIN_KSH= KSH KSH93
+KSH_DESC= Install to ${PREFIX}/bin/ksh
+KSH93_DESC= Install to ${PREFIX}/bin/ksh93
+
+KSH93_EXTRA_PATCHES= ${FILESDIR}/extra-patch-install-as-ksh93 \
+ ${FILESDIR}/extra-patch-install-as-ksh93-doc
+
+KSH_PLIST_SUB= 93=""
+KSH93_PLIST_SUB= 93="93"
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e '/for name in/ s|python.*|${PYTHON_CMD}|g' ${WRKSRC}/scripts/python.sh
+ @${REINPLACE_CMD} -e 's|SF_FLAGS|SFIO_FLAGS|g' ${WRKSRC}/src/lib/libast/include/sfio*.h ${WRKSRC}/src/lib/libast/sfio/*.c
+.if ${PORT_OPTIONS:MKSH93}
+ @${MV} ${WRKSRC}/src/cmd/ksh93/docs/ksh.1 ${WRKSRC}/src/cmd/ksh93/docs/ksh93.1
+.endif
+.if ${PORT_OPTIONS:MKSH}
+ @# Keep portlint happy
+.endif
+
+.include <bsd.port.mk>