aboutsummaryrefslogtreecommitdiff
path: root/shells/psh/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-29 02:27:02 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-29 02:27:02 +0000
commitd158e99d339876e2ee8cd317b5dbb3be376999e3 (patch)
tree9d243c2fa926181e6e9280f7fb21edfd88eed55b /shells/psh/Makefile
parent61ab6ea6beb5c79a6941bab54dd32e022e7f709e (diff)
downloadports-d158e99d339876e2ee8cd317b5dbb3be376999e3.tar.gz
ports-d158e99d339876e2ee8cd317b5dbb3be376999e3.zip
Upgrade shells/perlsh to new version (perlsh 0.007).
1) Update pkg/PLIST. 2) Change to depend on perlsh's install mechanism. 3) New patch (patch-aa) fixes PREFIX problem. 4) Account for broken TCP/IP on MASTER_SITES. 5) General Makefile cleanups. 6) Addition of perlsh to perl5 virtual category. 7) Use PKGNAME to match port's name. 8) Remove unnecessary perl substitution. PR: 17031 Submitted by: Maintainer
Notes
Notes: svn path=/head/; revision=26421
Diffstat (limited to 'shells/psh/Makefile')
-rw-r--r--shells/psh/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
index fd310560a7e0..b59a8f2077a8 100644
--- a/shells/psh/Makefile
+++ b/shells/psh/Makefile
@@ -1,31 +1,29 @@
# New ports collection makefile for: perlsh
-# Version required: 0.004pre2
+# Version required: 0.007
# Date created: 11 Dec 1999
# Whom: Will Andrews <andrews@technologist.com>
#
# $FreeBSD$
#
-DISTNAME= psh-0.004pre2
-CATEGORIES= shells
+DISTNAME= psh-${VERSION}
+PKGNAME= perlsh-${VERSION}
+CATEGORIES= shells perl5
MASTER_SITES= http://www.focusresearch.com/gregor/psh/
MAINTAINER= andrews@technologist.com
-do-build:
- @(cd ${WRKSRC} && ${PERL} Makefile.PL && ${MAKE})
+VERSION= 0.007
+USE_PERL5= yes
+FETCH_BEFORE_ARGS+= -t
+MAKE_ENV+= PPREFIX="${PREFIX}"
+MAN1= psh.1
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-post-build:
- @${PERL} -pi -e "s/\/usr\/local\/bin\/perl/\/usr\/bin\/perl/g" ${WRKSRC}/psh
+.include "${.CURDIR}/files/man3"
-do-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/perlsh
-.for DOC in CHANGES MANIFEST README TODO psh.NEWS pshrc test.pl psh.pod
- @${INSTALL_DATA} ${WRKSRC}/${DOC} ${PREFIX}/share/perlsh
-.endfor
-.endif
- @${INSTALL_SCRIPT} ${WRKSRC}/psh ${PREFIX}/bin
+do-build:
+ @(cd ${WRKSRC} && ${PERL} Makefile.PL && ${MAKE})
post-install:
@${ECHO} "Updating /etc/shells"