aboutsummaryrefslogtreecommitdiff
path: root/shells/psh
diff options
context:
space:
mode:
authorWes Peters <wes@FreeBSD.org>2000-01-03 19:33:18 +0000
committerWes Peters <wes@FreeBSD.org>2000-01-03 19:33:18 +0000
commit46d2d8fa30197a09758ee00a329c8f2345e929d5 (patch)
treecc77153e1c4512dcf6019dca3ed590a3a8a82679 /shells/psh
parent9c8ec23437f0404c114ef276d5efd8c538b19765 (diff)
downloadports-46d2d8fa30197a09758ee00a329c8f2345e929d5.tar.gz
ports-46d2d8fa30197a09758ee00a329c8f2345e929d5.zip
Commit perlsh 0.004pre2 port.
PR: 15412 Submitted by: Will Andrews <andrews@technologist.com>
Notes
Notes: svn path=/head/; revision=24389
Diffstat (limited to 'shells/psh')
-rw-r--r--shells/psh/Makefile37
-rw-r--r--shells/psh/distinfo1
-rw-r--r--shells/psh/pkg-comment1
-rw-r--r--shells/psh/pkg-descr4
-rw-r--r--shells/psh/pkg-plist10
5 files changed, 53 insertions, 0 deletions
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
new file mode 100644
index 000000000000..fd310560a7e0
--- /dev/null
+++ b/shells/psh/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: perlsh
+# Version required: 0.004pre2
+# Date created: 11 Dec 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= psh-0.004pre2
+CATEGORIES= shells
+MASTER_SITES= http://www.focusresearch.com/gregor/psh/
+
+MAINTAINER= andrews@technologist.com
+
+do-build:
+ @(cd ${WRKSRC} && ${PERL} Makefile.PL && ${MAKE})
+
+post-build:
+ @${PERL} -pi -e "s/\/usr\/local\/bin\/perl/\/usr\/bin\/perl/g" ${WRKSRC}/psh
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/perlsh
+.for DOC in CHANGES MANIFEST README TODO psh.NEWS pshrc test.pl psh.pod
+ @${INSTALL_DATA} ${WRKSRC}/${DOC} ${PREFIX}/share/perlsh
+.endfor
+.endif
+ @${INSTALL_SCRIPT} ${WRKSRC}/psh ${PREFIX}/bin
+
+post-install:
+ @${ECHO} "Updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/psh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/psh) > /etc/shells
+ @${RM} /etc/shells.bak
+
+.include <bsd.port.mk>
diff --git a/shells/psh/distinfo b/shells/psh/distinfo
new file mode 100644
index 000000000000..75c2db0f9e8a
--- /dev/null
+++ b/shells/psh/distinfo
@@ -0,0 +1 @@
+MD5 (psh-0.004pre2.tar.gz) = 9b8f0ef1bd3708cb8fa4101ab4d6c1b4
diff --git a/shells/psh/pkg-comment b/shells/psh/pkg-comment
new file mode 100644
index 000000000000..eecef2c36cd5
--- /dev/null
+++ b/shells/psh/pkg-comment
@@ -0,0 +1 @@
+New shell made entirely out of a Perl script.
diff --git a/shells/psh/pkg-descr b/shells/psh/pkg-descr
new file mode 100644
index 000000000000..f0e2a2dfd58c
--- /dev/null
+++ b/shells/psh/pkg-descr
@@ -0,0 +1,4 @@
+Perl Shell is a new shell that combines the power of bash
+and several other shells with the power of perl programming.
+
+WWW: http://www.focusresearch.com/gregor/psh/index.html
diff --git a/shells/psh/pkg-plist b/shells/psh/pkg-plist
new file mode 100644
index 000000000000..ac3a1eb131e4
--- /dev/null
+++ b/shells/psh/pkg-plist
@@ -0,0 +1,10 @@
+bin/psh
+share/perlsh/CHANGES
+share/perlsh/MANIFEST
+share/perlsh/README
+share/perlsh/TODO
+share/perlsh/psh.NEWS
+share/perlsh/pshrc
+share/perlsh/test.pl
+share/perlsh/psh.pod
+@dirrm share/perlsh