aboutsummaryrefslogtreecommitdiff
path: root/shells/scponly
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2015-11-24 15:06:49 +0000
committerRenato Botelho <garga@FreeBSD.org>2015-11-24 15:06:49 +0000
commit04bfb78d7fff9c1201ef22ab092ec3dab1e18870 (patch)
tree0bb753f02b434dc7c2328f7658dfd294a770d616 /shells/scponly
parent5260bfe6a1f7153dd629ffc748a9c97a4856bf8b (diff)
downloadports-04bfb78d7fff9c1201ef22ab092ec3dab1e18870.tar.gz
ports-04bfb78d7fff9c1201ef22ab092ec3dab1e18870.zip
- Add openssh-portable dependency explicit when /usr/bin/sftp is not present
- Remove ${PORTSDIR} from depends - Take maintainership PR: 204779 Approved by: gjb (maintainer) Obtained from: pfSense Sponsored by: Rubicon Communications (Netgate)
Notes
Notes: svn path=/head/; revision=402366
Diffstat (limited to 'shells/scponly')
-rw-r--r--shells/scponly/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 949cc8185172..e5ca40d13376 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -3,14 +3,16 @@
PORTNAME= scponly
PORTVERSION= 4.8.20110526
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-snapshots
DISTNAME= ${PORTNAME}-20110526
-MAINTAINER= gjb@FreeBSD.org
+MAINTAINER= garga@FreeBSD.org
COMMENT= Tiny shell that only permits scp and sftp
+LICENSE= BSD2CLAUSE
+
PORTDOCS= BUILDING-JAILS.TXT INSTALL README SECURITY
USES= tar:tgz
@@ -31,20 +33,22 @@ WINSCP_DESC= WinSCP support
OPTIONS_SUB= yes
-BUILD_DEPENDS= sftp:${PORTSDIR}/security/openssh-portable
+.if !exists(/usr/bin/sftp)
+BUILD_DEPENDS= ${LOCALBASE}/bin/sftp:security/openssh-portable
+.endif
DEFAULT_CHDIR_CONFIGURE_ON= --with-default-chdir=${SCPONLY_DEFAULT_CHDIR}
WILDCARDS_CONFIGURE_ENABLE= wildcards
GFTP_CONFIGURE_ENABLE= gftp-compat
CHROOT_CONFIGURE_ENABLE= chrooted-binary
CHROOT_USE= RC_SUBR=scponlyc
-RSYNC_BUILD_DEPENDS= rsync:${PORTSDIR}/net/rsync
+RSYNC_BUILD_DEPENDS= rsync:net/rsync
RSYNC_CONFIGURE_ENABLE= rsync-compat
SCP_CONFIGURE_ENABLE= scp-compat
SVN_CONFIGURE_ENABLE= svn-compat
-SVN_BUILD_DEPENDS= svn:${PORTSDIR}/devel/subversion
-SVNSERVE_BUILD_DEPENDS= svn:${PORTSDIR}/devel/subversion
+SVN_BUILD_DEPENDS= svn:devel/subversion
+SVNSERVE_BUILD_DEPENDS= svn:devel/subversion
SVNSERVE_CONFIGURE_ENABLE= svnserv-compat
-UNISON_BUILD_DEPENDS= unison:${PORTSDIR}/net/unison
+UNISON_BUILD_DEPENDS= unison:net/unison
UNISON_CONFIGURE_ENABLE= unison-compat
WINSCP_CONFIGURE_ENABLE= winscp-compat
@@ -62,7 +66,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/config.h ${STAGEDIR}${EXAMPLESDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/$i ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>