aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh-navigation-tools
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-05-16 16:29:44 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-05-16 16:29:44 +0000
commitf030704c5572b7d4e22f7d1533f23c504b43fb96 (patch)
treefa891b35b298244a88b03d5b6e05a1269897924f /shells/zsh-navigation-tools
parent8776139ba238e8ef13e4db648893b119f1957471 (diff)
downloadports-f030704c5572b7d4e22f7d1533f23c504b43fb96.tar.gz
ports-f030704c5572b7d4e22f7d1533f23c504b43fb96.zip
Add shell/zsh-navigation-tools.
Set of Zsh tools with features like incremental multi-word searching, approximate matching, ANSI coloring, themes, unique mode, horizontal scroll and advanced history management. Selected tools provided: - n-history - full-screen history searcher and manager - n-kill - browses process list, allows quick searching and sending signal to selected process - n-panelize - loads output of given command for browsing and multi-word searching - n-cd - browses dirstack and bookmarked directories, allows to enter selected directory - n-functions - browses functions, relegates editing to vared Written in pure Zsh, with use of curses module. Can be configured from zshrc. Binds n-history to Ctrl-R. Provides widgets for n-cd and n-kill. WWW: https://github.com/psprint/zsh-navigation-tools PR: 209263 Submitted by: Sebastian Gniazdowski
Notes
Notes: svn path=/head/; revision=415339
Diffstat (limited to 'shells/zsh-navigation-tools')
-rw-r--r--shells/zsh-navigation-tools/Makefile24
-rw-r--r--shells/zsh-navigation-tools/distinfo3
-rw-r--r--shells/zsh-navigation-tools/files/pkg-message.in2
-rw-r--r--shells/zsh-navigation-tools/pkg-descr16
-rw-r--r--shells/zsh-navigation-tools/pkg-plist31
5 files changed, 76 insertions, 0 deletions
diff --git a/shells/zsh-navigation-tools/Makefile b/shells/zsh-navigation-tools/Makefile
new file mode 100644
index 000000000000..0241c62d792c
--- /dev/null
+++ b/shells/zsh-navigation-tools/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= zsh-navigation-tools
+PORTVERSION= 2.1.15
+DISTVERSIONPREFIX= v
+CATEGORIES= shells
+
+MAINTAINER= sgniazdowski@gmail.com
+COMMENT= Curses-based tools for Zshell, e.g. multi-word history searcher
+
+LICENSE= GPLv3 MIT
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= zsh:shells/zsh
+
+NO_ARCH= yes
+OPTIONS_DEFINE= DOCS
+SUB_FILES= pkg-message
+
+USE_GITHUB= yes
+GH_ACCOUNT= psprint
+
+.include <bsd.port.mk>
diff --git a/shells/zsh-navigation-tools/distinfo b/shells/zsh-navigation-tools/distinfo
new file mode 100644
index 000000000000..fd989f90a3b3
--- /dev/null
+++ b/shells/zsh-navigation-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463415985
+SHA256 (psprint-zsh-navigation-tools-v2.1.15_GH0.tar.gz) = 9f4794984f7ea206b227d385dc9d84238f75854df808500ac61640dea8a140b8
+SIZE (psprint-zsh-navigation-tools-v2.1.15_GH0.tar.gz) = 138334
diff --git a/shells/zsh-navigation-tools/files/pkg-message.in b/shells/zsh-navigation-tools/files/pkg-message.in
new file mode 100644
index 000000000000..a563f75df2ea
--- /dev/null
+++ b/shells/zsh-navigation-tools/files/pkg-message.in
@@ -0,0 +1,2 @@
+To enable zsh-navigation-tools, add the following to your zshrc:
+source %%DATADIR%%/zsh-navigation-tools.plugin.zsh
diff --git a/shells/zsh-navigation-tools/pkg-descr b/shells/zsh-navigation-tools/pkg-descr
new file mode 100644
index 000000000000..c34a0c4a788c
--- /dev/null
+++ b/shells/zsh-navigation-tools/pkg-descr
@@ -0,0 +1,16 @@
+Set of Zsh tools with features like incremental multi-word searching,
+approximate matching, ANSI coloring, themes, unique mode, horizontal
+scroll and advanced history management. Selected tools provided:
+ - n-history - full-screen history searcher and manager
+ - n-kill - browses process list, allows quick searching and
+ sending signal to selected process
+ - n-panelize - loads output of given command for browsing and
+ multi-word searching
+ - n-cd - browses dirstack and bookmarked directories, allows to
+ enter selected directory
+ - n-functions - browses functions, relegates editing to vared
+
+Written in pure Zsh, with use of curses module. Can be configured from
+zshrc. Binds n-history to Ctrl-R. Provides widgets for n-cd and n-kill.
+
+WWW: https://github.com/psprint/zsh-navigation-tools
diff --git a/shells/zsh-navigation-tools/pkg-plist b/shells/zsh-navigation-tools/pkg-plist
new file mode 100644
index 000000000000..edd428c7d17c
--- /dev/null
+++ b/shells/zsh-navigation-tools/pkg-plist
@@ -0,0 +1,31 @@
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/n-history2.png
+%%DATADIR%%/.config/znt/n-aliases.conf
+%%DATADIR%%/.config/znt/n-cd.conf
+%%DATADIR%%/.config/znt/n-env.conf
+%%DATADIR%%/.config/znt/n-functions.conf
+%%DATADIR%%/.config/znt/n-history.conf
+%%DATADIR%%/.config/znt/n-kill.conf
+%%DATADIR%%/.config/znt/n-list.conf
+%%DATADIR%%/.config/znt/n-options.conf
+%%DATADIR%%/.config/znt/n-panelize.conf
+%%DATADIR%%/.revision-hash
+%%DATADIR%%/_n-kill
+%%DATADIR%%/n-aliases
+%%DATADIR%%/n-cd
+%%DATADIR%%/n-env
+%%DATADIR%%/n-functions
+%%DATADIR%%/n-help
+%%DATADIR%%/n-history
+%%DATADIR%%/n-kill
+%%DATADIR%%/n-list
+%%DATADIR%%/n-list-draw
+%%DATADIR%%/n-list-input
+%%DATADIR%%/n-options
+%%DATADIR%%/n-panelize
+%%DATADIR%%/znt-cd-widget
+%%DATADIR%%/znt-history-widget
+%%DATADIR%%/znt-kill-widget
+%%DATADIR%%/znt-usetty-wrapper
+%%DATADIR%%/zsh-navigation-tools.plugin.zsh