aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-20 23:30:10 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-20 23:30:10 +0000
commitc5eb15edbf984773e8b4389dac187ee010a58565 (patch)
tree8040b31c489e8b82ca6ee2cdf980e031cbbfa651 /shells/zsh/Makefile
parent1fee50ba5a9d9c86a0d6d04ce8e7a7fad2a21957 (diff)
downloadports-c5eb15edbf984773e8b4389dac187ee010a58565.tar.gz
ports-c5eb15edbf984773e8b4389dac187ee010a58565.zip
- update to 5.0.1
Notes
Notes: svn path=/head/; revision=309333
Diffstat (limited to 'shells/zsh/Makefile')
-rw-r--r--shells/zsh/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 569f6f1a4ddd..d981a14d1fd7 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: zsh
-# Date created: 11 Feb. 1995
-# Whom: torstenb
-#
+# Created by: torstenb
# $FreeBSD$
-#
PORTNAME= zsh
-PORTVERSION= 5.0.0
-PORTREVISION= 1
+PORTVERSION= 5.0.1
CATEGORIES= shells
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}-doc/${PORTVERSION}:doc
@@ -39,7 +34,8 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-bsdtar
#EXTRA_COMPLETION_FILES= _sockstat
#EXTRA_COMPLETION_DIR= Completion/BSD/Command
-OPTIONS_DEFINE= GDBM MEM SECURE_FREE MAILDIR MULTIBYTE PCRE STATIC DOCS DEBUG
+OPTIONS_DEFINE= GDBM MEM SECURE_FREE MAILDIR MULTIBYTE PCRE STATIC DOCS DEBUG \
+ EXAMPLES
OPTIONS_DEFAULT= SECURE_FREE MAILDIR MULTIBYTE
GDBM_DESC= Enable GDBM support (GPL)
@@ -59,7 +55,7 @@ PORTDOCS= *
PORTEXAMPLES= zlogin zshenv zshrc
SHELLS= /etc/shells
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
DISTFILES+= ${DISTNAME}-doc${EXTRACT_SUFX}:doc
@@ -150,10 +146,10 @@ INFO= zsh
.endif
post-install:
- ${LN} ${PREFIX}/bin/zsh ${PREFIX}/bin/rzsh
+ ${LN} -f ${PREFIX}/bin/zsh ${PREFIX}/bin/rzsh
${TEST} -d ${ZSH_ETCDIR} || ${MKDIR} ${ZSH_ETCDIR}
${TEST} -d ${ZSH_SITEFNDIR} || ${MKDIR} ${ZSH_SITEFNDIR}
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/StartupFiles && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
.endif
@@ -174,4 +170,4 @@ post-install:
${CHMOD} 644 $$i.zwc ; \
done'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>