aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2017-03-30 12:41:08 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2017-03-30 12:41:08 +0000
commit3d7c7f2ece8ed9c065251c8b4f175c48be2f7c8c (patch)
tree4d512ac16b6263609f7087bfb6bf565d26b81634 /shells/zsh
parent3d632fbe8e5f70d3808e9bfaada4b4cade6be2aa (diff)
downloadports-3d7c7f2ece8ed9c065251c8b4f175c48be2f7c8c.tar.gz
ports-3d7c7f2ece8ed9c065251c8b4f175c48be2f7c8c.zip
Fix bug in kldload completion (also reported upstream).
Approved by: bapt@
Notes
Notes: svn path=/head/; revision=437285
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile1
-rw-r--r--shells/zsh/files/patch-Completion-BSD-Command-_kld11
2 files changed, 12 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index abaf00f239ac..5db772edf778 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= zsh
DISTVERSION= 5.3.1
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.zsh.org/pub/ \
SF \
diff --git a/shells/zsh/files/patch-Completion-BSD-Command-_kld b/shells/zsh/files/patch-Completion-BSD-Command-_kld
new file mode 100644
index 000000000000..48eda64ee75e
--- /dev/null
+++ b/shells/zsh/files/patch-Completion-BSD-Command-_kld
@@ -0,0 +1,11 @@
+--- Completion/BSD/Command/_kld.orig
++++ Completion/BSD/Command/_kld
+@@ -26,7 +26,7 @@
+ case "$service" in
+ kldload)
+ _arguments -s -S -A "-*" \
+- "-n[don't try to load module if already loaded]"
++ "-n[don't try to load module if already loaded]" \
+ '-v[be verbose]' \
+ '-q[silence any extraneous warnings]' \
+ '*:module to load:_kld_module'