aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-07 07:58:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-07 07:58:28 +0000
commit1e48ead47ee3aa052ea1d7d267223f0de6c02b2f (patch)
tree08207c0b8f0a5b28845e738545c9f91d4ee47e0e /shells
parentd526191223fa50016717515a84de2e8b56a107d2 (diff)
downloadports-1e48ead47ee3aa052ea1d7d267223f0de6c02b2f.tar.gz
ports-1e48ead47ee3aa052ea1d7d267223f0de6c02b2f.zip
- Respect DESTDIR for all my ports
Reviewed by: gabor Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=169917
Diffstat (limited to 'shells')
-rw-r--r--shells/osh/Makefile10
-rw-r--r--shells/osh/pkg-plist4
2 files changed, 7 insertions, 7 deletions
diff --git a/shells/osh/Makefile b/shells/osh/Makefile
index f79daa1123c1..c4425cc18cde 100644
--- a/shells/osh/Makefile
+++ b/shells/osh/Makefile
@@ -16,10 +16,10 @@ COMMENT= An implementation of the UNIX 6th Edition shell
MAN1= fd2.1 goto.1 if.1 osh.1
post-install:
- @${ECHO_MSG} "updating /etc/shells"
- @${CP} /etc/shells /etc/shells.bak
- @(${GREP} -v ${PREFIX}/bin/osh /etc/shells.bak; \
- ${ECHO_CMD} ${PREFIX}/bin/osh) > /etc/shells
- @${RM} /etc/shells.bak
+ @${ECHO_MSG} "updating ${DESTDIR}/etc/shells"
+ @${CP} ${DESTDIR}/etc/shells ${DESTDIR}/etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/osh ${DESTDIR}/etc/shells.bak; \
+ ${ECHO_CMD} ${PREFIX}/bin/osh) > ${DESTDIR}/etc/shells
+ @${RM} ${DESTDIR}/etc/shells.bak
.include <bsd.port.mk>
diff --git a/shells/osh/pkg-plist b/shells/osh/pkg-plist
index 9125442c7601..9dbc744d35e8 100644
--- a/shells/osh/pkg-plist
+++ b/shells/osh/pkg-plist
@@ -2,5 +2,5 @@ bin/fd2
bin/goto
bin/if
bin/osh
-@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
-@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
+@exec echo "updating ${DESTDIR}/etc/shells"; cp ${DESTDIR}/etc/shells ${DESTDIR}/etc/shells.bak; (grep -v %D/%F ${DESTDIR}/etc/shells.bak; echo %D/%F) >${DESTDIR}/etc/shells
+@unexec echo "updating ${DESTDIR}/etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells