aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-08-14 04:08:02 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-08-14 04:08:02 +0000
commit4a6b440781fce7e5e00b01f8e3b0026aef5b3705 (patch)
treeec76581865429a55b97c41e17913a7edc69067f0 /shells
parentae8f5d05912d85bd9859a2d59ee74204ba4a85d1 (diff)
downloadports-4a6b440781fce7e5e00b01f8e3b0026aef5b3705.tar.gz
ports-4a6b440781fce7e5e00b01f8e3b0026aef5b3705.zip
Various plan9 utilities. It's such a complete collection, I'm going
to import it all at once! Submitted by: Eric L. Hernes <erich@lodgenet.com>
Notes
Notes: svn path=/head/; revision=2055
Diffstat (limited to 'shells')
-rw-r--r--shells/es/Makefile14
-rw-r--r--shells/es/distinfo1
-rw-r--r--shells/es/files/patch-aa88
-rw-r--r--shells/es/pkg-comment1
-rw-r--r--shells/es/pkg-descr13
-rw-r--r--shells/es/pkg-plist3
-rw-r--r--shells/rc/Makefile15
-rw-r--r--shells/rc/distinfo1
-rw-r--r--shells/rc/files/patch-aa93
-rw-r--r--shells/rc/pkg-comment1
-rw-r--r--shells/rc/pkg-descr34
-rw-r--r--shells/rc/pkg-plist8
12 files changed, 272 insertions, 0 deletions
diff --git a/shells/es/Makefile b/shells/es/Makefile
new file mode 100644
index 000000000000..3dceedad1109
--- /dev/null
+++ b/shells/es/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: es
+# Version required: 0.9a1
+# Date created: Sun Aug 13 12:36:14 CDT 1995
+# Whom: erich@rrnet.com
+#
+# $Id$
+#
+
+DISTNAME= es-0.9-alpha1
+PKGNAME= es-0.9a1
+CATEGORIES+= plan9
+MASTER_SITES= ftp://ftp.sys.toronto.edu/pub/es/
+
+.include <bsd.port.mk>
diff --git a/shells/es/distinfo b/shells/es/distinfo
new file mode 100644
index 000000000000..cef218f706f8
--- /dev/null
+++ b/shells/es/distinfo
@@ -0,0 +1 @@
+MD5 (es-0.9-alpha1.tar.gz) = 2e7372fc4c8eaeb00571e721730b6108
diff --git a/shells/es/files/patch-aa b/shells/es/files/patch-aa
new file mode 100644
index 000000000000..f491e82fb15f
--- /dev/null
+++ b/shells/es/files/patch-aa
@@ -0,0 +1,88 @@
+*** Makefile.orig Tue May 30 06:14:14 1995
+--- Makefile Fri Aug 11 16:02:11 1995
+***************
+*** 33,40 ****
+ SHELL = /bin/sh
+ CC = cc
+ #CC = gcc
+! CFLAGS = -g
+! #CFLAGS = -g -O -Wall
+ LDFLAGS =
+ LIBS =
+
+--- 33,40 ----
+ SHELL = /bin/sh
+ CC = cc
+ #CC = gcc
+! #CFLAGS = -g
+! CFLAGS = -O2
+ LDFLAGS =
+ LIBS =
+
+***************
+*** 52,57 ****
+--- 52,66 ----
+ tree.o util.o var.o vec.o version.o y.tab.o
+ OTHER = Makefile parse.y mksignal
+ GEN = esdump y.tab.c y.tab.h y.output token.h sigmsgs.c initial.c
++
++ all: es
++
++ install:
++ $(INSTALL) -c es $(PREFIX)/bin
++ $(INSTALL) -c esdebug $(PREFIX)/bin/esdebug
++ $(INSTALL) -c es.1 $(PREFIX)/man/man1
++ strip $(PREFIX)/bin/es
++ gzip -9nf $(PREFIX)/man/man1/es.1
+
+ es : ${OFILES} initial.o
+ ${CC} -o es ${LDFLAGS} ${OFILES} initial.o ${LIBS}
+*** esdebug~ Mon Jul 31 13:54:29 1995
+--- esdebug Mon Jul 31 13:54:45 1995
+***************
+*** 1,4 ****
+! #! /bin/es -p
+ # esdebug: a debugger for es scripts ($Revision: 1.4 $)
+
+ # TODO
+--- 1,4 ----
+! #!/usr/local/bin/es -p
+ # esdebug: a debugger for es scripts ($Revision: 1.4 $)
+
+ # TODO
+*** prim-sys.c~ Mon Jul 31 16:20:31 1995
+--- prim-sys.c Mon Jul 31 16:21:25 1995
+***************
+*** 194,200 ****
+
+ static void printlimit(const Limit *limit, Boolean hard) {
+ struct rlimit rlim;
+! long lim;
+ getrlimit(limit->flag, &rlim);
+ if (hard)
+ lim = rlim.rlim_max;
+--- 194,200 ----
+
+ static void printlimit(const Limit *limit, Boolean hard) {
+ struct rlimit rlim;
+! u_quad_t lim;
+ getrlimit(limit->flag, &rlim);
+ if (hard)
+ lim = rlim.rlim_max;
+***************
+*** 213,219 ****
+ }
+ }
+
+! static long parselimit(const Limit *limit, char *s) {
+ long lim;
+ char *t;
+ const Suffix *suf = limit->suffix;
+--- 213,219 ----
+ }
+ }
+
+! static u_quad_t parselimit(const Limit *limit, char *s) {
+ long lim;
+ char *t;
+ const Suffix *suf = limit->suffix;
diff --git a/shells/es/pkg-comment b/shells/es/pkg-comment
new file mode 100644
index 000000000000..2ecdaa9b7e00
--- /dev/null
+++ b/shells/es/pkg-comment
@@ -0,0 +1 @@
+Es -- an extensible shell, derrived from plan9's rc
diff --git a/shells/es/pkg-descr b/shells/es/pkg-descr
new file mode 100644
index 000000000000..6b6cdba3348f
--- /dev/null
+++ b/shells/es/pkg-descr
@@ -0,0 +1,13 @@
+Es is an extensible shell. The language was derived from the Plan 9
+shell, rc, and was influenced by functional programming languages,
+such as Scheme, and the Tcl embeddable programming language. This
+implementation is derived from Byron Rakitzis's public domain
+implementation of rc.
+
+Es is in the public domain. We hold no copyrights or patents on
+the source code, and do not place any restrictions on its distribution.
+We would appreciate it if any distributions do credit the authors.
+
+Enjoy!
+
+-- Paul Haahr & Byron Rakitzis
diff --git a/shells/es/pkg-plist b/shells/es/pkg-plist
new file mode 100644
index 000000000000..03aafe9fe6b3
--- /dev/null
+++ b/shells/es/pkg-plist
@@ -0,0 +1,3 @@
+bin/es
+bin/esdebug
+man/man1/es.1.gz
diff --git a/shells/rc/Makefile b/shells/rc/Makefile
new file mode 100644
index 000000000000..194310cd8fa1
--- /dev/null
+++ b/shells/rc/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: rc
+# Version required: 1.5b1
+# Date created: Sun Aug 13 12:36:14 CDT 1995
+# Whom: erich@rrnet.com
+#
+# $Id$
+#
+
+DISTNAME= rc-1.5betadev-1
+PKGNAME= rc-1.5b1
+CATEGORIES+= plan9
+MASTER_SITES= ftp://ftp.sys.toronto.edu/pub/rc/
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/shells/rc/distinfo b/shells/rc/distinfo
new file mode 100644
index 000000000000..a510c99d59aa
--- /dev/null
+++ b/shells/rc/distinfo
@@ -0,0 +1 @@
+MD5 (rc-1.5betadev-1.tar.gz) = 4ddd5d227fe3817da9cf2781702a6c8b
diff --git a/shells/rc/files/patch-aa b/shells/rc/files/patch-aa
new file mode 100644
index 000000000000..8d0ff6190e1f
--- /dev/null
+++ b/shells/rc/files/patch-aa
@@ -0,0 +1,93 @@
+*** Makefile.orig Sun Mar 6 21:32:46 1994
+--- Makefile Fri Aug 11 16:00:41 1995
+***************
+*** 16,23 ****
+ #ADDON=addon.o
+
+ # Use an ANSI compiler (or at least one that groks prototypes and void *):
+! CC=gcc -g -O
+! CFLAGS=
+ LDFLAGS=
+
+ # You may substitute "bison -y" for yacc. (You want to choose the one that
+--- 16,23 ----
+ #ADDON=addon.o
+
+ # Use an ANSI compiler (or at least one that groks prototypes and void *):
+! CC=gcc
+! CFLAGS= -O2
+ LDFLAGS=
+
+ # You may substitute "bison -y" for yacc. (You want to choose the one that
+***************
+*** 29,34 ****
+--- 29,47 ----
+ nalloc.o open.o print.o redir.o sigmsgs.o signal.o status.o tree.o \
+ utils.o var.o version.o wait.o walk.o which.o y.tab.o
+
++ all: rc history
++
++ install:
++ $(INSTALL) -c rc $(PREFIX)/bin
++ $(INSTALL) -c history/history $(PREFIX)/bin
++ for i in - -- -p --p; do rm -f $(PREFIX)/bin/$$i; ln $(PREFIX)/bin/history $(PREFIX)/bin/$$i; done
++ $(INSTALL) -c rc.1 $(PREFIX)/man/man1
++ $(INSTALL) -c history/history.1 $(PREFIX)/man/man1
++ strip $(PREFIX)/bin/rc
++ strip $(PREFIX)/bin/history
++ gzip -9nf $(PREFIX)/man/man1/rc.1
++ gzip -9nf $(PREFIX)/man/man1/history.1
++
+ # If rc is compiled with READLINE defined, you must supply the correct
+ # arguments to ld on this line. Typically this would be something like:
+ #
+*** builtins.c.orig Sun Mar 6 21:32:49 1994
+--- builtins.c Mon Jul 31 12:27:12 1995
+***************
+*** 466,477 ****
+
+ #ifndef SYSVR4
+ extern int getrlimit(int, struct rlimit *);
+ extern int setrlimit(int, struct rlimit *);
+ #endif
+
+ static void printlimit(const Limit *limit, bool hard) {
+ struct rlimit rlim;
+! long lim;
+ getrlimit(limit->flag, &rlim);
+ if (hard)
+ lim = rlim.rlim_max;
+--- 466,481 ----
+
+ #ifndef SYSVR4
+ extern int getrlimit(int, struct rlimit *);
++
++ #ifndef __FreeBSD__
+ extern int setrlimit(int, struct rlimit *);
+ #endif
+
++ #endif
++
+ static void printlimit(const Limit *limit, bool hard) {
+ struct rlimit rlim;
+! u_quad_t lim;
+ getrlimit(limit->flag, &rlim);
+ if (hard)
+ lim = rlim.rlim_max;
+***************
+*** 490,496 ****
+ }
+ }
+
+! static long parselimit(const Limit *limit, char *s) {
+ char *t;
+ int len = strlen(s);
+ long lim = 1;
+--- 494,500 ----
+ }
+ }
+
+! static u_quad_t parselimit(const Limit *limit, char *s) {
+ char *t;
+ int len = strlen(s);
+ long lim = 1;
diff --git a/shells/rc/pkg-comment b/shells/rc/pkg-comment
new file mode 100644
index 000000000000..5a5234eccdea
--- /dev/null
+++ b/shells/rc/pkg-comment
@@ -0,0 +1 @@
+rc, version 1.5beta-1 -- a unix incarnation of the plan9 shell.
diff --git a/shells/rc/pkg-descr b/shells/rc/pkg-descr
new file mode 100644
index 000000000000..43142d5d5263
--- /dev/null
+++ b/shells/rc/pkg-descr
@@ -0,0 +1,34 @@
+This is release 1.5 of rc.
+
+Read COPYRIGHT for copying information. All files are
+
+Copyright 1991, Byron Rakitzis.
+
+CREDITS
+
+This shell was written by me, Byron Rakitzis, but kudos go to Paul
+Haahr for letting me know what a shell should do and for contributing
+certain bits and pieces to rc (notably the limits code, print.c,
+most of which.c and the backquote redirection code), and to Hugh
+Redelmeier for running rc through his fussy ANSI compiler and
+thereby provoking interesting discussions about portability, and
+also for providing many valuable suggestions for improving rc's
+code in general. Finally, many thanks go to David Sanderson, for
+reworking the man page to format well with troff, and for providing
+many suggestions both for rc and its man page.
+
+Thanks to Boyd Roberts for the original history.c, and to Hugh
+again for re-working parts of that code.
+
+Of course, without Tom Duff's design of the original rc, I could
+not have written this shell (though I probably would have written
+*a* shell). Almost of all of the features, with minor exceptions,
+have been implemented as described in the Unix v10 manuals. Hats
+off to td for designing a C-like, minimal but very useful shell.
+
+Tom Duff has kindly given permission for the paper he wrote for
+UKUUG to be distributed with this version of rc (called "plan9.ps"
+in the same ftp directory as the shell). Please read this paper
+bearing in mind that it describes a program that was written at
+AT&T and that the version of rc presented here differs in some
+respects.
diff --git a/shells/rc/pkg-plist b/shells/rc/pkg-plist
new file mode 100644
index 000000000000..dfe16872b94e
--- /dev/null
+++ b/shells/rc/pkg-plist
@@ -0,0 +1,8 @@
+bin/rc
+bin/history
+bin/-
+bin/--
+bin/-p
+bin/--p
+man/man1/history.1.gz
+man/man1/rc.1.gz