aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-05-21 11:55:18 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-05-21 11:55:18 +0000
commit5186c7bfb3d62d27c4538a00ed7694c5bd5ee6ef (patch)
treed9638d109d9ad1d0ff71b8b5447a18fc0d73f359 /shells
parentfe7f6d09d0fa41220899c676f1eba175a041002f (diff)
downloadports-5186c7bfb3d62d27c4538a00ed7694c5bd5ee6ef.tar.gz
ports-5186c7bfb3d62d27c4538a00ed7694c5bd5ee6ef.zip
- Fix segmentation fault on completion
- Bump PORTREVISION PR: ports/123490 Submitted by: garga Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=213452
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile1
-rw-r--r--shells/zsh/files/patch-Src_Zle_compresult.c28
2 files changed, 29 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 48182f50650e..ac99eff352ba 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -22,6 +22,7 @@
PORTNAME= zsh
PORTVERSION= 4.3.6
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= SF
.if !defined(NOPORTDOCS)
diff --git a/shells/zsh/files/patch-Src_Zle_compresult.c b/shells/zsh/files/patch-Src_Zle_compresult.c
new file mode 100644
index 000000000000..a41e2c2c0938
--- /dev/null
+++ b/shells/zsh/files/patch-Src_Zle_compresult.c
@@ -0,0 +1,28 @@
+--- Src/Zle/compresult.c.orig 2008-05-07 10:19:11.000000000 -0300
++++ Src/Zle/compresult.c 2008-05-07 10:19:35.000000000 -0300
+@@ -1188,6 +1188,12 @@
+ {
+ int was_meta;
+
++ /* Just list the matches if the list was requested. */
++ if (lst == COMP_LIST_COMPLETE) {
++ showinglist = -2;
++ return;
++ }
++
+ /* Already metafied when called from domenuselect already */
+ if (zlemetaline == NULL) {
+ was_meta = 0;
+@@ -1195,12 +1201,6 @@
+ } else
+ was_meta = 1;
+
+- /* Just list the matches if the list was requested. */
+- if (lst == COMP_LIST_COMPLETE) {
+- showinglist = -2;
+- return;
+- }
+-
+ /* Otherwise go to the next match in the array... */
+ do {
+ if (!*++(minfo.cur)) {