aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 20:09:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 20:09:45 +0000
commit7ab7659224e6ada8a27d61e83ec1ac89a3d9e804 (patch)
tree9e292ac3150bef3bedd2198323b2f2432a2945ad /shells
parentab2a75c0bfaa190d1765bec66365c2cf6e2e3ee0 (diff)
downloadports-7ab7659224e6ada8a27d61e83ec1ac89a3d9e804.tar.gz
ports-7ab7659224e6ada8a27d61e83ec1ac89a3d9e804.zip
shells/klish: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'shells')
-rw-r--r--shells/klish/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/shells/klish/Makefile b/shells/klish/Makefile
index 31adf3ba8363..9175376840f9 100644
--- a/shells/klish/Makefile
+++ b/shells/klish/Makefile
@@ -11,8 +11,16 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENCE
USES= libtool tar:xz
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
INSTALL_TARGET= install-strip
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
.include <bsd.port.mk>