aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
commit7ae7b018ccf7760013f368fcb83aad9ecd8982a8 (patch)
treee83ee6693050a76e305a95a376451aa583df151e /shells
parenta35ba13770957a577275c3575d979457605f2aff (diff)
downloadports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.tar.gz
ports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=417166
Diffstat (limited to 'shells')
-rw-r--r--shells/ibsh/Makefile2
-rw-r--r--shells/ibsh/files/patch-Makefile40
2 files changed, 21 insertions, 21 deletions
diff --git a/shells/ibsh/Makefile b/shells/ibsh/Makefile
index a2f75fb6581a..fc2ef1d9d315 100644
--- a/shells/ibsh/Makefile
+++ b/shells/ibsh/Makefile
@@ -12,7 +12,7 @@ COMMENT= Restricted unix shell
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake
+USES= dos2unix gmake
ALL_TARGET= ibsh
INSTALL_TARGET= ibsh_install
MAKE_ARGS= CC="${CC}" PREFIX="${STAGEDIR}${PREFIX}"
diff --git a/shells/ibsh/files/patch-Makefile b/shells/ibsh/files/patch-Makefile
index eee459054000..311cf9078496 100644
--- a/shells/ibsh/files/patch-Makefile
+++ b/shells/ibsh/files/patch-Makefile
@@ -1,21 +1,21 @@
---- Makefile.orig 2005-06-03 13:47:32 UTC
+--- Makefile.orig 2016-06-20 15:08:34 UTC
+++ Makefile
-@@ -30,12 +30,12 @@ delbadfiles.o: delbadfiles.c ibsh.h
- ${CC} -c delbadfiles.c
-
- ibsh_install:
-- cp ./ibsh /bin/
-- mkdir /etc/ibsh
-- mkdir /etc/ibsh/cmds
-- mkdir /etc/ibsh/xtns
-- cp ./globals.cmds /etc/ibsh/
-- cp ./globals.xtns /etc/ibsh/
-+ cp ./ibsh ${PREFIX}/bin/
-+ mkdir ${PREFIX}/etc/ibsh
-+ mkdir ${PREFIX}/etc/ibsh/cmds
-+ mkdir ${PREFIX}/etc/ibsh/xtns
-+ cp ./globals.cmds ${PREFIX}/etc/ibsh/
-+ cp ./globals.xtns ${PREFIX}/etc/ibsh/
-
- ibsh_uninstall:
- rm -rf /etc/ibsh/globals.cmds
+@@ -30,12 +30,12 @@ delbadfiles.o: delbadfiles.c ibsh.h
+ ${CC} -c delbadfiles.c
+
+ ibsh_install:
+- cp ./ibsh /bin/
+- mkdir /etc/ibsh
+- mkdir /etc/ibsh/cmds
+- mkdir /etc/ibsh/xtns
+- cp ./globals.cmds /etc/ibsh/
+- cp ./globals.xtns /etc/ibsh/
++ cp ./ibsh ${PREFIX}/bin/
++ mkdir ${PREFIX}/etc/ibsh
++ mkdir ${PREFIX}/etc/ibsh/cmds
++ mkdir ${PREFIX}/etc/ibsh/xtns
++ cp ./globals.cmds ${PREFIX}/etc/ibsh/
++ cp ./globals.xtns ${PREFIX}/etc/ibsh/
+
+ ibsh_uninstall:
+ rm -rf /etc/ibsh/globals.cmds