aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-19 11:25:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-19 11:25:29 +0000
commita2262e931305294882ca078238da1ce88deba4bb (patch)
tree84c7cf412c9b595212c74612c2651e087a7a7203 /shells
parent86cad8dff1ee6acc3f95e860c18e2ecebfc20d7f (diff)
downloadports-a2262e931305294882ca078238da1ce88deba4bb.tar.gz
ports-a2262e931305294882ca078238da1ce88deba4bb.zip
Remove unnecessary evals that do-fetch was using.
Turns out that env(1) knows how to parse a properly quoted string using -S "string", it makes the double eval used for the fetch command to be unnecessary. This is because running: eval "foo $(escape $bar)" is silly when this works: foo $bar So remove escaping and quoting, and sillyness. PR: 210198 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6779
Notes
Notes: svn path=/head/; revision=417110
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index 86a25c56773b..f222a95524c9 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -26,7 +26,7 @@ LICENSE= EPL
OPTIONS_DEFINE= EXAMPLES STATIC
-FETCH_ENV= HTTP_AUTH='basic:*:I accept www.opensource.org/licenses/cpl:.'
+FETCH_ENV= HTTP_AUTH=basic:*:I\ accept\ www.opensource.org/licenses/cpl:.
LDFLAGS+= -lm
MAKE_ENV= CCFLAGS="${CFLAGS}"
NO_WRKSUBDIR= yes