aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2006-06-09 03:54:02 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2006-06-09 03:54:02 +0000
commiteca44c8543205df1fed9c3ac0e2b7fed0d40030f (patch)
tree327dc129eeff9f28e11193b239aa09fd0f4d567c /shells
parent6f5170362d8c82688b04a38f54fa23c09b95929c (diff)
downloadports-eca44c8543205df1fed9c3ac0e2b7fed0d40030f.tar.gz
ports-eca44c8543205df1fed9c3ac0e2b7fed0d40030f.zip
Add vendor patch fixing array expansion fails with an arithmetic
syntax error when the subscript appears within double quotes. For example: ${a["4"]}.
Notes
Notes: svn path=/head/; revision=164872
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile3
-rw-r--r--shells/bash/distinfo3
2 files changed, 5 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index c1c1367fe492..db95143040bb 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -1,3 +1,4 @@
+# ex:ts=8
# New ports collection makefile for: bash3
# Date created: 30 Jul 2004
# Whom: Oliver Eikemeier
@@ -19,7 +20,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
PATCH_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/
PATCH_SITE_SUBDIR= ${PORTNAME}/${DISTNAME}-patches/
-.for patch in 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16
+.for patch in 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17
PATCHFILES+= ${PORTNAME}${PORTVERSION:R:S/.//g}-0${patch}
PATCHLEVEL= ${patch}
.endfor
diff --git a/shells/bash/distinfo b/shells/bash/distinfo
index c78a39ca7c60..8da2ba3c5669 100644
--- a/shells/bash/distinfo
+++ b/shells/bash/distinfo
@@ -49,5 +49,8 @@ SIZE (bash/bash31-015) = 3089
MD5 (bash/bash31-016) = fbc981edfff97a0940487937db3fb202
SHA256 (bash/bash31-016) = 2438b71c7fadf2971141e6854d317804e143d86eefd6d7b4479d62afd385ebad
SIZE (bash/bash31-016) = 1295
+MD5 (bash/bash31-017) = b08ffabafce3a967e3a7e0a5b29d8331
+SHA256 (bash/bash31-017) = 8fb3ac54b9536ad1ba829f229f1ab906ab2af005f2bfa733f2687245e1569407
+SIZE (bash/bash31-017) = 3640
MD5 (bash/FAQ) = IGNORE
SHA256 (bash/FAQ) = IGNORE