aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-20 22:57:23 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-20 22:57:23 +0000
commitf6e6105ff836ed6f4094a8f311d85b6a35799b9b (patch)
treec5ec60c607361ad1397f09c1f3d11009832c21ce /shells
parenta65ed2e51bf631a6b8ab766f984bf33c686d239a (diff)
downloadports-f6e6105ff836ed6f4094a8f311d85b6a35799b9b.tar.gz
ports-f6e6105ff836ed6f4094a8f311d85b6a35799b9b.zip
Add NO_STAGE all over the place in preparation for the staging support (cat: shells)
Notes
Notes: svn path=/head/; revision=327770
Diffstat (limited to 'shells')
-rw-r--r--shells/44bsd-csh/Makefile8
-rw-r--r--shells/ambit/Makefile7
-rw-r--r--shells/bash-completion/Makefile5
-rw-r--r--shells/bash-devel/Makefile1
-rw-r--r--shells/bash-static-devel/Makefile1
-rw-r--r--shells/bash-static/Makefile3
-rw-r--r--shells/bash/Makefile1
-rw-r--r--shells/bashc/Makefile1
-rw-r--r--shells/ch/Makefile7
-rw-r--r--shells/dash/Makefile1
-rw-r--r--shells/es/Makefile1
-rw-r--r--shells/esh/Makefile1
-rw-r--r--shells/fd/Makefile7
-rw-r--r--shells/fish/Makefile1
-rw-r--r--shells/flash/Makefile7
-rw-r--r--shells/heirloom-sh/Makefile7
-rw-r--r--shells/ibsh/Makefile7
-rw-r--r--shells/jailkit/Makefile1
-rw-r--r--shells/ksh93/Makefile1
-rw-r--r--shells/lshell/Makefile7
-rw-r--r--shells/mksh/Makefile1
-rw-r--r--shells/nologinmsg/Makefile8
-rw-r--r--shells/osh/Makefile1
-rw-r--r--shells/p5-Bash-Completion/Makefile1
-rw-r--r--shells/p5-Shell-Perl/Makefile1
-rw-r--r--shells/p5-Term-ShellUI/Makefile1
-rw-r--r--shells/pdksh/Makefile1
-rw-r--r--shells/pear-PHP_Shell/Makefile7
-rw-r--r--shells/psh/Makefile1
-rw-r--r--shells/rc/Makefile1
-rw-r--r--shells/rssh/Makefile1
-rw-r--r--shells/sash/Makefile3
-rw-r--r--shells/scponly/Makefile1
-rw-r--r--shells/shell-include/Makefile1
-rw-r--r--shells/tcsh_nls/Makefile7
-rw-r--r--shells/tcshrc/Makefile7
-rw-r--r--shells/v7sh/Makefile7
-rw-r--r--shells/viewglob/Makefile1
-rw-r--r--shells/vshnu/Makefile1
-rw-r--r--shells/wapsh/Makefile7
-rw-r--r--shells/zoidberg/Makefile1
-rw-r--r--shells/zsh/Makefile1
42 files changed, 59 insertions, 77 deletions
diff --git a/shells/44bsd-csh/Makefile b/shells/44bsd-csh/Makefile
index 098f8e9f0f11..dfaedd019f30 100644
--- a/shells/44bsd-csh/Makefile
+++ b/shells/44bsd-csh/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: csh
-# Date created: 23 January 2000
-# Whom: David O'Brien <obrien@NUXI.com>
-#
+# Created by: David O'Brien <obrien@NUXI.com>
# $FreeBSD$
-#
PORTNAME= 44bsd-csh
PORTVERSION= 20001106
PORTREVISION= 3
@@ -20,6 +15,7 @@ USE_BZIP2= yes
NO_WRKSUBDIR= yes
MAN1= 44bsd-csh.1
PORTDOCS= paper.ascii.gz
+NO_STAGE= yes
post-extract:
cd ${WRKSRC} ; co RCS/*,v; chmod u+w *
cd ${WRKSRC}/USD.doc ; co RCS/*,v
diff --git a/shells/ambit/Makefile b/shells/ambit/Makefile
index 5c6d2d5f4d60..49c079f7e856 100644
--- a/shells/ambit/Makefile
+++ b/shells/ambit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ambit
-# Date created: 2011-08-09
-# Whom: Sascha Klauder <sklauder@trimind.de>
-#
+# Created by: Sascha Klauder <sklauder@trimind.de>
# $FreeBSD$
-#
PORTNAME= ambit
PORTVERSION= 2.0.39
@@ -27,6 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_SUB= AMBITDIR=${AMBITDIR}
+NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} \
-e "s!/bin/bash!${LOCALBASE}/bin/bash!" \
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index b6e59ddf515f..ce83f56890f4 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -1,7 +1,5 @@
-# Created by: kirk@strauser.com
-#
+# Created by: kirk@strauser.com
# $FreeBSD$
-#
PORTNAME= bash-completion
PORTVERSION= 2.1
@@ -29,6 +27,7 @@ SUB_FILES= pkg-message
SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
PORTDOCS= *
+NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
diff --git a/shells/bash-devel/Makefile b/shells/bash-devel/Makefile
index dac812c9683a..4284fba32f8e 100644
--- a/shells/bash-devel/Makefile
+++ b/shells/bash-devel/Makefile
@@ -33,6 +33,7 @@ HELP_DESC= Enable builtin help
USES= bison
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMPLICITCD}
diff --git a/shells/bash-static-devel/Makefile b/shells/bash-static-devel/Makefile
index 870532816449..5c68ab81a367 100644
--- a/shells/bash-static-devel/Makefile
+++ b/shells/bash-static-devel/Makefile
@@ -5,4 +5,5 @@ MASTERDIR= ${.CURDIR}/../../shells/bash-devel
OPTIONS_SLAVE= STATIC
+NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/shells/bash-static/Makefile b/shells/bash-static/Makefile
index e29ab9b24ae0..f5063a0149a3 100644
--- a/shells/bash-static/Makefile
+++ b/shells/bash-static/Makefile
@@ -1,8 +1,9 @@
-# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
MASTERDIR= ${.CURDIR}/../../shells/bash
OPTIONS_SLAVE= STATIC
+NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index a5be8b1024df..c2ae8f30584a 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -34,6 +34,7 @@ HELP_DESC= Install the help files
USES+= bison
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMPLICITCD}
diff --git a/shells/bashc/Makefile b/shells/bashc/Makefile
index 5843abe918c1..82adee7ba2b5 100644
--- a/shells/bashc/Makefile
+++ b/shells/bashc/Makefile
@@ -18,6 +18,7 @@ PLIST_FILES= bin/bashc \
etc/bash_commander \
etc/bash_dialog
+NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|autoconf|${TRUE}|' ${WRKSRC}/Makefile.in
diff --git a/shells/ch/Makefile b/shells/ch/Makefile
index b237479f9e0a..43981b31b064 100644
--- a/shells/ch/Makefile
+++ b/shells/ch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ch
-# Date created: 2 August 2006
-# Whom: conrads@cox.net
-#
+# Created by: conrads@cox.net
# $FreeBSD$
-#
PORTNAME= ch
PORTVERSION= 7.0.0
@@ -27,6 +23,7 @@ MAN1= installpkg.1 strconcat.1 strjoin.1. strputc.1 pkginstall.1 strgetc.1 gnup
MAN1PREFIX= ${PREFIX}/${PORTNAME}/docs
MANCOMPRESSED= no
+NO_STAGE= yes
.include <bsd.port.pre.mk>
post-extract:
diff --git a/shells/dash/Makefile b/shells/dash/Makefile
index 25a7ae4ccff6..34036191b91c 100644
--- a/shells/dash/Makefile
+++ b/shells/dash/Makefile
@@ -16,6 +16,7 @@ USES= gmake
PLIST_FILES= bin/dash
MAN1= dash.1
+NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/COMMON_CFLAGS =/ s|$$| ${CFLAGS}|' \
${WRKSRC}/src/Makefile.in
diff --git a/shells/es/Makefile b/shells/es/Makefile
index 6a4004d5b905..6a96e26357e2 100644
--- a/shells/es/Makefile
+++ b/shells/es/Makefile
@@ -20,4 +20,5 @@ ALL_TARGET= es
MAN1= es.1
PLIST_FILES= bin/es
+NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/shells/esh/Makefile b/shells/esh/Makefile
index 8b9dedea8142..c20f48548274 100644
--- a/shells/esh/Makefile
+++ b/shells/esh/Makefile
@@ -18,6 +18,7 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
INFO= esh
+NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|<readline.h>|<readline/readline.h>| ; \
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 2ba9165bb24d..964407873486 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: FDclone
-# Date created: 20 Feb 1996
-# Whom: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
-#
+# Created by: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
# $FreeBSD$
-#
PORTNAME= fd
PORTVERSION= 3.01a
@@ -32,6 +28,7 @@ DOCS_JA= FAQ \
TECHKNOW \
ToAdmin
+NO_STAGE= yes
post-configure:
${REINPLACE_CMD} -E -e 's|^(#[[:space:]]*define[[:space:]]+EXTENDCCOPT[[:space:]]+"([^"]+ )?)-O(["[:space:]])|\1${CFLAGS}\3|' ${WRKSRC}/machine.h
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index 92b1148299f2..6098f7b7d709 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -24,6 +24,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -pthread
MAN1= fish.1 fish_indent.1 fish_pager.1 fishd.1 mimedb.1
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/shells/flash/Makefile b/shells/flash/Makefile
index 87333e8e4abe..50132292057a 100644
--- a/shells/flash/Makefile
+++ b/shells/flash/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: flash
-# Date created: 11 Dec 1999
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= flash
PORTVERSION= 0.9.5
@@ -29,6 +25,7 @@ DATA= system.bg.Netsoc.3 system.bg.Netsoc.4 system.flashlogin \
system.maillogin system.module system.module.9798 system.rc \
system.rc.mailshell
+NO_STAGE= yes
post-patch:
.for file in ${SCRIPT}
@${REINPLACE_CMD} -e "s:/usr/slocal:${PREFIX}:g" ${WRKSRC}/orcasetup/${file}
diff --git a/shells/heirloom-sh/Makefile b/shells/heirloom-sh/Makefile
index 4dc5b9be25d0..0631dd828bbe 100644
--- a/shells/heirloom-sh/Makefile
+++ b/shells/heirloom-sh/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: heirloom-sh
-# Date created: 2008-03-28
-# Whom: Danijel Tasov <danielt@pilgerer.org>
-#
+# Created by: Danijel Tasov <danielt@pilgerer.org>
# $FreeBSD$
-#
PORTNAME= heirloom-sh
PORTVERSION= 050706
@@ -21,6 +17,7 @@ PORTDOCS= CALDERA.LICENSE OPENSOLARIS.LICENSE CHANGES README
PKGINSTALL= pkg-install
PKGDEINSTALL= pkg-deinstall
+NO_STAGE= yes
do-build:
cd ${WRKSRC} && make
diff --git a/shells/ibsh/Makefile b/shells/ibsh/Makefile
index 76e7fa486fac..8ac32e80bb41 100644
--- a/shells/ibsh/Makefile
+++ b/shells/ibsh/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ibsh
-# Date created: 1 Oct 2005
-# Whom: Vaida Bogdan
-#
+# Created by: Vaida Bogdan
# $FreeBSD$
-#
PORTNAME= ibsh
PORTVERSION= 0.3e
@@ -21,6 +17,7 @@ SUB_FILES= pkg-message
PORTDOCS= AUTHORS BUGS CONTRIBUTORS COPYING COPYRIGHT ChangeLog \
INSTALL README TODO VERSION
+NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
diff --git a/shells/jailkit/Makefile b/shells/jailkit/Makefile
index 34a78d61d88d..2e56d86d138f 100644
--- a/shells/jailkit/Makefile
+++ b/shells/jailkit/Makefile
@@ -32,6 +32,7 @@ MANCOMPRESSED= yes
PORTDOCS= COPYRIGHT README.txt
+NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index 7817c4d22ebc..1356b2fb16d3 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -36,6 +36,7 @@ MAN1= ksh93.1
INITVERSION= 2013-05-24
KSHVERSION= 2012-08-01
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSTATIC}
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
index 231faebbf72d..1552581993d4 100644
--- a/shells/lshell/Makefile
+++ b/shells/lshell/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lshell
-# Date created: 2009-08-01
-# Whom: Sylvio Cesar <scjamorim@bsd.com.br>
-#
+# Created by: Sylvio Cesar <scjamorim@bsd.com.br>
# $FreeBSD$
-#
PORTNAME= lshell
PORTVERSION= 0.9.15.1
@@ -22,6 +18,7 @@ MAN1= lshell.1
PORTDOCS= CHANGES COPYING README
+NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g; \
s|share/man|${LOCALBASE}/man|g; 45d' ${WRKSRC}/setup.py
diff --git a/shells/mksh/Makefile b/shells/mksh/Makefile
index e6d0ce045c21..930256733a23 100644
--- a/shells/mksh/Makefile
+++ b/shells/mksh/Makefile
@@ -15,6 +15,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= mksh.1
+NO_STAGE= yes
.include <bsd.port.pre.mk>
do-build:
diff --git a/shells/nologinmsg/Makefile b/shells/nologinmsg/Makefile
index 6d62ea4cc3f7..5b1e759e727e 100644
--- a/shells/nologinmsg/Makefile
+++ b/shells/nologinmsg/Makefile
@@ -1,10 +1,5 @@
-# Ports collection makefile for: nologinmsg
-# Whom: Richard Rose <freebsd-security@rikrose.net>
-# Date created: 20020710
-#
+# Created by: Richard Rose <freebsd-security@rikrose.net>
# $FreeBSD$
-#
-# The port is self contained in the src directory
PORTNAME= nologinmsg
PORTVERSION= 1.0
@@ -18,6 +13,7 @@ COMMENT= More functional native binary replacement for /sbin/nologin
MAN8= nologinmsg.8
MANCOMPRESSED= yes
+NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKSRC}
.for i in Makefile nologinmsg.c nologinmsg.8 pathnames.h
diff --git a/shells/osh/Makefile b/shells/osh/Makefile
index 2adb257338ac..eb3e53dbee1c 100644
--- a/shells/osh/Makefile
+++ b/shells/osh/Makefile
@@ -18,6 +18,7 @@ MAN1= fd2.1 goto.1 if.1 osh.1 sh6.1 glob6.1
PORTDOCS= *
PORTEXAMPLES= *
+NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
diff --git a/shells/p5-Bash-Completion/Makefile b/shells/p5-Bash-Completion/Makefile
index 9027e8947ca3..9c0ceb8c6e13 100644
--- a/shells/p5-Bash-Completion/Makefile
+++ b/shells/p5-Bash-Completion/Makefile
@@ -31,6 +31,7 @@ MAN3= App::BashComplete.3 \
Bash::Completion::Request.3 \
Bash::Completion::Utils.3
+NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501400
diff --git a/shells/p5-Shell-Perl/Makefile b/shells/p5-Shell-Perl/Makefile
index a5fc9d0ebb01..49687c04dca6 100644
--- a/shells/p5-Shell-Perl/Makefile
+++ b/shells/p5-Shell-Perl/Makefile
@@ -27,4 +27,5 @@ USE_PERL5= configure
MAN1= pirl.1
MAN3= Shell::Perl.3 Shell::Perl::Dumper.3
+NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/shells/p5-Term-ShellUI/Makefile b/shells/p5-Term-ShellUI/Makefile
index 6df0545e8ab4..656ef6161d45 100644
--- a/shells/p5-Term-ShellUI/Makefile
+++ b/shells/p5-Term-ShellUI/Makefile
@@ -20,6 +20,7 @@ USE_PERL5= configure
MAN3= Term::ShellUI.3 \
Text::Shellwords::Cursor.3
+NO_STAGE= yes
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}/
diff --git a/shells/pdksh/Makefile b/shells/pdksh/Makefile
index 1442ce1ac8ef..48ead8f89ac3 100644
--- a/shells/pdksh/Makefile
+++ b/shells/pdksh/Makefile
@@ -22,6 +22,7 @@ LICENSE= BSD
GNU_CONFIGURE= yes
MAN1= ksh.1
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${OSVERSION} >= 1000039
diff --git a/shells/pear-PHP_Shell/Makefile b/shells/pear-PHP_Shell/Makefile
index 517fc4cfdc61..c754807ec3c2 100644
--- a/shells/pear-PHP_Shell/Makefile
+++ b/shells/pear-PHP_Shell/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-PHP_Shell
-# Date created: 05 August 2007
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= PHP_Shell
PORTVERSION= 0.3.2
@@ -19,6 +15,7 @@ RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
PEAR_AUTOINSTALL= yes
+NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
index 2f6425a67b92..e962c1886855 100644
--- a/shells/psh/Makefile
+++ b/shells/psh/Makefile
@@ -84,6 +84,7 @@ MAN3= Psh::Builtins::Alias.3 \
Psh::Strategy::Perlfunc_heavy.3 \
Psh::Strategy::Perlscript.3
+NO_STAGE= yes
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/shells/rc/Makefile b/shells/rc/Makefile
index dbe672053dad..6e92106084d9 100644
--- a/shells/rc/Makefile
+++ b/shells/rc/Makefile
@@ -18,6 +18,7 @@ MAN1= history.1 rc.1
OPTIONS_DEFINE= READLINE
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MREADLINE}
diff --git a/shells/rssh/Makefile b/shells/rssh/Makefile
index bfe5b37fccab..285b4f0781c3 100644
--- a/shells/rssh/Makefile
+++ b/shells/rssh/Makefile
@@ -17,6 +17,7 @@ MAN5= rssh.conf.5
OPTIONS_DEFINE= RDIST
RDIST_DESC= rdist support
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MRDIST}
diff --git a/shells/sash/Makefile b/shells/sash/Makefile
index 81e2e0328461..19f2c610f128 100644
--- a/shells/sash/Makefile
+++ b/shells/sash/Makefile
@@ -1,4 +1,4 @@
-# Created by: Patrick Gardella <patrick@freebsd.org>
+# Created by: Patrick Gardella <patrick@FreeBSD.org>
# $FreeBSD$
PORTNAME= sash
@@ -11,6 +11,7 @@ COMMENT= A Stand-Alone shell combining many common utilities
MAN1= sash.1
+NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sash ${PREFIX}/bin/sash
${INSTALL_MAN} ${WRKSRC}/sash.1 ${MAN1PREFIX}/man/man1/sash.1
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 0575ae7305b5..9267db3720ec 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -32,6 +32,7 @@ SVNSERVE_DESC= Suversion support for svn+ssh://
UNISON_DESC= Unisson support
WINSCP_DESC= WinSCP support
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if(!exists(/usr/bin/sftp))
diff --git a/shells/shell-include/Makefile b/shells/shell-include/Makefile
index fbc730af2ad7..4d2f9c319a62 100644
--- a/shells/shell-include/Makefile
+++ b/shells/shell-include/Makefile
@@ -21,6 +21,7 @@ MAN7= shell-include.7
WRKSRC= ${WRKDIR}/${DISTNAME}
#nothing to configure
+NO_STAGE= yes
do-configure:
@${ECHO} -n
diff --git a/shells/tcsh_nls/Makefile b/shells/tcsh_nls/Makefile
index d6b234a4eb07..3cf519aed4de 100644
--- a/shells/tcsh_nls/Makefile
+++ b/shells/tcsh_nls/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tcsh_nls
-# Date created: 14 Feb 2006
-# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
-#
+# Created by: Hajimu UMEMOTO <ume@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tcsh_nls
PORTVERSION= 1.0
@@ -61,6 +57,7 @@ NLS_CATALOGS= de_DE.ISO8859-1:de_AT.UTF-8 \
uk_UA.KOI8-U:uk_UA.ISO8859-5 \
uk_UA.KOI8-U:uk_UA.UTF-8 \
+NO_STAGE= yes
do-fetch:
@${DO_NADA}
diff --git a/shells/tcshrc/Makefile b/shells/tcshrc/Makefile
index 674dc501519f..bd7249107a4a 100644
--- a/shells/tcshrc/Makefile
+++ b/shells/tcshrc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tcshrc
-# Date created: 2003-09-09
-# Whom: Sean Chittenden <seanc@FreeBSD.org>
-#
+# Created by: Sean Chittenden <seanc@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tcshrc
PORTVERSION= 1.6.2
@@ -20,6 +16,7 @@ NO_BUILD= yes
INSTALL_TARGET= systeminstall
MAKE_ARGS= BIN=${LOCALBASE}/bin SHARETCSHRC=${DATADIR}
+NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's#/usr/share#${PREFIX}/share#g' \
${WRKSRC}/tcshrc_config
diff --git a/shells/v7sh/Makefile b/shells/v7sh/Makefile
index e6111230bd39..fd7e9219c069 100644
--- a/shells/v7sh/Makefile
+++ b/shells/v7sh/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: v7sh
-# Date created: 4 June 2004
-# Whom: Cyrille.Lefevre@laposte.net
-#
+# Created by: Cyrille.Lefevre@laposte.net
# $FreeBSD$
-#
PORTNAME= v7sh
PORTVERSION= 1.0
@@ -37,6 +33,7 @@ SYSIII_DESC= System III enhancements
RENO_DESC= 4.3BSD-Reno enhancements
ULTRIX_DESC= Ultrix 3.1 enhancements
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSYSIII}
diff --git a/shells/viewglob/Makefile b/shells/viewglob/Makefile
index 99c99083651c..9b68f86ad19f 100644
--- a/shells/viewglob/Makefile
+++ b/shells/viewglob/Makefile
@@ -20,4 +20,5 @@ GNU_CONFIGURE= yes
MAN1= vgd.1 vgseer.1 viewglob.1
+NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/shells/vshnu/Makefile b/shells/vshnu/Makefile
index d83c01004ba1..2599c4132490 100644
--- a/shells/vshnu/Makefile
+++ b/shells/vshnu/Makefile
@@ -16,4 +16,5 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
+NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
index d396f4a08753..655c576ffcd1 100644
--- a/shells/wapsh/Makefile
+++ b/shells/wapsh/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wapsh
-# Date created: 13 January 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
+# Created by: George Reid <greid@ukug.uk.freebsd.org>
# $FreeBSD$
-#
PORTNAME= wapsh
PORTVERSION= 1.0.1
@@ -42,6 +38,7 @@ HTDOCS= command.php command_html.inc command_wml.inc \
login_html.php login_wml.php scroll_wml.php \
shortcuts_wml.php index.html
+NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 900007
diff --git a/shells/zoidberg/Makefile b/shells/zoidberg/Makefile
index bfdd9bef4b53..92a314057786 100644
--- a/shells/zoidberg/Makefile
+++ b/shells/zoidberg/Makefile
@@ -51,6 +51,7 @@ MAN3= Bundle::Zoidberg.3 \
Zoidberg::Utils::GetOpt.3 \
Zoidberg::Utils::Output.3
+NO_STAGE= yes
post-install:
@${ECHO_CMD} ${PREFIX}/bin/zoid >> /etc/shells
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 639b48e9e043..4d953769898f 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -71,6 +71,7 @@ STATIC_CONFIGURE_OFF= --enable-dynamic
DEBUG_CONFIGURE_ENABLE= zsh-debug
MULTIBYTE_CONFIGURE_ENABLE= multibyte
+NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSTATIC}