aboutsummaryrefslogtreecommitdiff
path: root/sysutils/agedu/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-20 06:43:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-20 06:43:16 +0000
commitc869616c0a9b37632632fa90f6fa090672fa4e0c (patch)
tree53c9d340081b3428b2bf043a90142003b3dab5df /sysutils/agedu/Makefile
parent37de4ed629b4479e2101d819d04434f72475109d (diff)
downloadports-c869616c0a9b37632632fa90f6fa090672fa4e0c.tar.gz
ports-c869616c0a9b37632632fa90f6fa090672fa4e0c.zip
- Add agedu 9251
Unix provides the standard du utility, which scans your disk and tells you which directories contain the largest amounts of data. That can help you narrow your search to the things most worth deleting. However, that only tells you what's big. What you really want to know is what's too big. By itself, du won't let you distinguish between data that's big because you're doing something that needs it to be big, and data that's big because you unpacked it once and forgot about it. Most Unix file systems, in their default mode, helpfully record when a file was last accessed. Not just when it was written or modified, but when it was even read. So if you generated a large amount of data years ago, forgot to clean it up, and have never used it since, then it ought in principle to be possible to use those last-access time stamps to tell the difference between that and a large amount of data you're still using regularly. agedu is a program which does this. It does basically the same sort of disk scan as du, but it also records the last-access times of everything it scans. Then it builds an index that lets it efficiently generate reports giving a summary of the results for each subdirectory, and then it produces those reports on demand. WWW: http://www.chiark.greenend.org.uk/~sgtatham/agedu/
Notes
Notes: svn path=/head/; revision=282044
Diffstat (limited to 'sysutils/agedu/Makefile')
-rw-r--r--sysutils/agedu/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/sysutils/agedu/Makefile b/sysutils/agedu/Makefile
new file mode 100644
index 000000000000..46837e446363
--- /dev/null
+++ b/sysutils/agedu/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: agedu
+# Date created: 2011-08-17
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= agedu
+PORTVERSION= 9251
+CATEGORIES= sysutils
+MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/${PORTNAME}/ \
+ LOCAL/sunpoet
+DISTNAME= ${PORTNAME}-r${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A Unix utility for tracking down wasted disk space
+
+GNU_CONFIGURE= yes
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>