aboutsummaryrefslogtreecommitdiff
path: root/sysutils/amazon-ssm-agent
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
commit3726f942547e374490d375baf83216d7644a7162 (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /sysutils/amazon-ssm-agent
parent1de291090d9121f4d238a639b441f64372c239c1 (diff)
downloadports-3726f942547e374490d375baf83216d7644a7162.tar.gz
ports-3726f942547e374490d375baf83216d7644a7162.zip
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Notes
Notes: svn path=/head/; revision=505321
Diffstat (limited to 'sysutils/amazon-ssm-agent')
-rw-r--r--sysutils/amazon-ssm-agent/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/amazon-ssm-agent/Makefile b/sysutils/amazon-ssm-agent/Makefile
index 730cc559a971..7395eaaee04d 100644
--- a/sysutils/amazon-ssm-agent/Makefile
+++ b/sysutils/amazon-ssm-agent/Makefile
@@ -10,9 +10,10 @@ COMMENT= Amazon Simple Systems Manager Agent
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= go:lang/go
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+USES= go
+
USE_GITHUB= yes
GH_ACCOUNT= aws
GH_SUBDIR= src/github.com/aws/amazon-ssm-agent