aboutsummaryrefslogtreecommitdiff
path: root/sysutils/anacron/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-16 15:51:38 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-16 15:51:38 +0000
commit610bc835b1230320760f51685d16856b344d5c7a (patch)
treec579ddc1260aa9376572b0dafef590f0a5a2cc80 /sysutils/anacron/Makefile
parenta6555c8d3b759431cdf4acc1d1427c3a3e283536 (diff)
downloadports-610bc835b1230320760f51685d16856b344d5c7a.tar.gz
ports-610bc835b1230320760f51685d16856b344d5c7a.zip
[1]:
- Add a rcNG startup script - Use mkstemp() instead of the insecure tempnam() Moreover: - Also create /var/spool/anacron when installed from a package - Try to remove /var/spool/anacron when deinstalling the package; if it fails, hint the user about removing it manually - Respect ${CC} - Install/deinstall ${PREFIX}/etc/anacrontab - Split the monolithic patch-aa into separate patches - Refactor some patches into ${REINPLACE_CMD} invocations - Install the program ourselves (it is more straightforward than fixing the vendor's Makefile) - Use SUB_FILES=pkg-message PR: ports/82168 [1] Submitted by: maintainer [1]
Notes
Notes: svn path=/head/; revision=137561
Diffstat (limited to 'sysutils/anacron/Makefile')
-rw-r--r--sysutils/anacron/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/sysutils/anacron/Makefile b/sysutils/anacron/Makefile
index 0dfa6d52c06f..bcef69ba6728 100644
--- a/sysutils/anacron/Makefile
+++ b/sysutils/anacron/Makefile
@@ -7,7 +7,7 @@
PORTNAME= anacron
PORTVERSION= 2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= anacron
@@ -17,14 +17,27 @@ COMMENT= Schedules periodic jobs on systems that are not permanently up
MAN8= anacron.8
MAN5= anacrontab.5
+USE_REINPLACE= yes
USE_GMAKE= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-post-install:
- ${CAT} ${PKGMESSAGE}
- ${STRIP_CMD} ${PREFIX}/sbin/anacron
+USE_RC_SUBR= anacron.sh
+SUB_FILES= pkg-message
+MAKE_ENV= CC="${CC}"
post-patch:
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
+.for f in Makefile anacron.8 anacrontab.5
+ @${REINPLACE_CMD} -e 's|\(/etc/anacrontab\)|${PREFIX}\1|' ${WRKSRC}/${f}
+.endfor
+ @${REINPLACE_CMD} -e 's|^CFLAGS = .*||' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/anacron ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/anacron.8 ${MAN8PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/anacrontab.5 ${MAN5PREFIX}/man/man5
+ ${INSTALL_DATA} ${FILESDIR}/anacrontab.default ${PREFIX}/etc
+ [ -f ${PREFIX}/etc/anacrontab ] || ${INSTALL_DATA} ${FILESDIR}/anacrontab.default ${PREFIX}/etc/anacrontab
+ ${MKDIR} /var/spool/anacron
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>