aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ansible
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-04-23 22:19:51 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-04-23 22:19:51 +0000
commit4260ccb35f7e6d995ea63d28a6af99583311e541 (patch)
treeb88d70fd799d26aad76ab68655b6faf7b750dfd9 /sysutils/ansible
parenta980ddbf70c3e6a237b2c4f12595f55618489452 (diff)
downloadports-4260ccb35f7e6d995ea63d28a6af99583311e541.tar.gz
ports-4260ccb35f7e6d995ea63d28a6af99583311e541.zip
Make the service module respect the sleep option.
PR: 208996 Submitted by: me Approved by: Nikolai Lifanov <lifanov at mail.lifanov.com> (maintainer)
Notes
Notes: svn path=/head/; revision=413917
Diffstat (limited to 'sysutils/ansible')
-rw-r--r--sysutils/ansible/Makefile3
-rw-r--r--sysutils/ansible/files/extra-patch-8aac5ae16
2 files changed, 19 insertions, 0 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 79cabe8c0c4e..be74819ddce7 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ansible
PORTVERSION?= 2.0.2.0
+PORTREVISION?= 1
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -17,6 +18,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2
+EXTRA_PATCHES?= ${FILESDIR}/extra-patch-8aac5ae
+
NO_ARCH= yes
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
diff --git a/sysutils/ansible/files/extra-patch-8aac5ae b/sysutils/ansible/files/extra-patch-8aac5ae
new file mode 100644
index 000000000000..4d8c5c908887
--- /dev/null
+++ b/sysutils/ansible/files/extra-patch-8aac5ae
@@ -0,0 +1,16 @@
+--- lib/ansible/modules/core/system/service.py.orig 2016-04-19 21:55:24 UTC
++++ lib/ansible/modules/core/system/service.py
+@@ -1003,7 +1003,12 @@ class FreeBsdService(Service):
+ if self.action == "reload":
+ self.action = "onereload"
+
+- return self.execute_command("%s %s %s %s" % (self.svc_cmd, self.name, self.action, self.arguments))
++ ret = self.execute_command("%s %s %s %s" % (self.svc_cmd, self.name, self.action, self.arguments))
++
++ if self.sleep:
++ time.sleep(self.sleep)
++
++ return ret
+
+ # ===========================================
+ # Subclass: OpenBSD