aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ansible
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-02-21 13:46:22 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-02-21 13:46:22 +0000
commitc96f75587dc70d738437676df3e5338a138037ab (patch)
treed3ab7ef4892f14529860b9c88385d943900613b3 /sysutils/ansible
parent1a48f62bbe4a714f64aa553cfb10694916c5e470 (diff)
downloadports-c96f75587dc70d738437676df3e5338a138037ab.tar.gz
ports-c96f75587dc70d738437676df3e5338a138037ab.zip
Upgrade to version 1.8.4.
PR: 197787 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=379513
Diffstat (limited to 'sysutils/ansible')
-rw-r--r--sysutils/ansible/Makefile5
-rw-r--r--sysutils/ansible/distinfo4
-rw-r--r--sysutils/ansible/files/patch-lib_ansible_modules_core_database_postgresql_postgresql__privs.py20
3 files changed, 4 insertions, 25 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 40fe74a39749..2f7f88bd577f 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION= 1.8.2
-PORTREVISION= 3
+PORTVERSION= 1.8.4
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -18,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}paramiko>0:${PORTSDIR}/security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2
-OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFINE= EXAMPLES
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index 8d82d1c28632..f6a3e70edd21 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ansible-1.8.2.tar.gz) = 2cd01ff4d67acb410bae0a9438956f6fc36d01babd956b0dc3b700620f2372b9
-SIZE (ansible-1.8.2.tar.gz) = 754435
+SHA256 (ansible-1.8.4.tar.gz) = d37c04b3abce9b036a6c8311fccb360c5cbc3ec895445f805243b0448d239ec1
+SIZE (ansible-1.8.4.tar.gz) = 758916
diff --git a/sysutils/ansible/files/patch-lib_ansible_modules_core_database_postgresql_postgresql__privs.py b/sysutils/ansible/files/patch-lib_ansible_modules_core_database_postgresql_postgresql__privs.py
deleted file mode 100644
index 605bfd914a21..000000000000
--- a/sysutils/ansible/files/patch-lib_ansible_modules_core_database_postgresql_postgresql__privs.py
+++ /dev/null
@@ -1,20 +0,0 @@
-
-$FreeBSD$
-
---- lib/ansible/modules/core/database/postgresql/postgresql_privs.py.orig
-+++ lib/ansible/modules/core/database/postgresql/postgresql_privs.py
-@@ -462,10 +462,13 @@
- if obj_type == 'group':
- set_what = ','.join(pg_quote_identifier(i, 'role') for i in obj_ids)
- else:
-+ # function types are already quoted above
-+ if obj_type != 'function':
-+ obj_ids = [pg_quote_identifier(i, 'table') for i in obj_ids]
- # Note: obj_type has been checked against a set of string literals
- # and privs was escaped when it was parsed
- set_what = '%s ON %s %s' % (','.join(privs), obj_type,
-- ','.join(pg_quote_identifier(i, 'table') for i in obj_ids))
-+ ','.join(obj_ids))
-
- # for_whom: SQL-fragment specifying for whom to set the above
- if roles == 'PUBLIC':