aboutsummaryrefslogtreecommitdiff
path: root/sysutils/apcupsd/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2010-04-03 08:47:33 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2010-04-03 08:47:33 +0000
commit9e4d77a01e489a9e7f637d1fa8a732b3806a8706 (patch)
tree5c2afc2044c9e3f080333b82ed42061e4e35238c /sysutils/apcupsd/Makefile
parente2f99f2f5e77b7d32e76bafc49d926acf1f55916 (diff)
downloadports-9e4d77a01e489a9e7f637d1fa8a732b3806a8706.tar.gz
ports-9e4d77a01e489a9e7f637d1fa8a732b3806a8706.zip
- Update to 3.14.8
- Among other things, the SNMP driver that does not require libsnmp.so - Adjust pkg-message to point to the right manual [1] Full list of changes: http://apcupsd.cvs.sourceforge.net/viewvc/*checkout*/apcupsd/apcupsd/ReleaseNotes?pathrev=Release-3_14_8 Submitted by: Scott Bennett <bennett@cs.niu.edu> [1] Tested by: Ulrich Drolshagen <u.drolshagen@t-online.de>, imp@inbox.ru, Warren Block <wblock@wonkity.com>, mack@
Notes
Notes: svn path=/head/; revision=252106
Diffstat (limited to 'sysutils/apcupsd/Makefile')
-rw-r--r--sysutils/apcupsd/Makefile33
1 files changed, 14 insertions, 19 deletions
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index 77fd87a3586e..5c3f1042075c 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= apcupsd
-PORTVERSION= 3.14.5
-PORTREVISION= 1
+PORTVERSION= 3.14.8
+PORTREVISION= 0
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20-%20Stable/${PORTVERSION}:src_sf \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/:src_bk \
@@ -37,7 +37,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN8= apcupsd.8
+MAN5= apcupsd.conf.5
+MAN8= apcaccess.8 apccontrol.8 apctest.8 apcupsd.8
OPTIONS= APCSMART_DRV "Compile APC SmartUPS serial driver" on \
APCDUMB_DRV "Compile dumb UPS driver" on \
@@ -46,10 +47,10 @@ OPTIONS= APCSMART_DRV "Compile APC SmartUPS serial driver" on \
PCNET_DRV "Compile PowerChute Network Shutdown driver" on \
USB "Compile with USB Support driver" on \
SNMP_DRV "Compile with SNMP driver" on \
+ SNMP_DRV_OLD "Compile with old SNMP driver" off \
TCP_WRAPPERS "Compile with TCP_WRAPPERS support" on\
TEST_DRV "Compile TEST driver" off \
GAPCMON "Build GTK GUI front-end" off
-# POWERFLUTE "Compile powerflute program" off
PORTDOCS= ${PORTNAME}.pdf
@@ -96,26 +97,23 @@ CONFIGURE_ARGS+= --enable-pcnet
CONFIGURE_ARGS+= --disable-pcnet
.endif
-# disabled upstream
-.ifdef(WITH_POWERFLUTE)
-CONFIGURE_ARGS+= --enable-powerflute
-CONFIGURE_ENV+= LIBS+="-lcurses -lmenu"
-PLIST_SUB+= POWERFL=""
-.else
-PLIST_SUB+= POWERFL="@comment "
-.endif
-
.ifdef(WITH_USB)
CONFIGURE_ARGS+= --enable-usb
.endif
.ifdef(WITH_SNMP_DRV)
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+= --enable-snmp
.else
CONFIGURE_ARGS+= --disable-snmp
.endif
+.ifdef(WITH_SNMP_DRV_OLD)
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+CONFIGURE_ARGS+= --enable-net-snmp
+.else
+CONFIGURE_ARGS+= --disable-net-snmp
+.endif
+
.ifdef(WITH_TCP_WRAPPERS)
CONFIGURE_ARGS+= --with-libwrap=yes
.endif
@@ -145,12 +143,9 @@ pre-configure:
@${FALSE}
.endif
-post-configure:
- @${REINPLACE_CMD} -e "s|%PREFIX%|${PREFIX}|g" ${WRKSRC}/doc/apcupsd.man
-
post-install:
-# If the files presaved are identical with the new one, include then in
-# the package list. So the port could be removed without problems
+# If the files presaved are identical with the new one, include them in
+# the package list, so the port can be removed without problems
for na in apccontrol commfailure mainsback mastertimeout \
changeme commok masterconnect onbattery; do \
if [ -f ${ETCDIR}/$$na.orig ]; then \