aboutsummaryrefslogtreecommitdiff
path: root/sysutils/atf-master
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2019-02-05 15:30:29 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2019-02-05 15:30:29 +0000
commitf8fd817c79e491a897d6e37c2cdc1e52cce1c0ca (patch)
treed5126fa77cbf5bbf4e572c129a1353ea975f55e2 /sysutils/atf-master
parent83dc5a133c687a269fce3b058542bb2bdc80eac1 (diff)
downloadports-f8fd817c79e491a897d6e37c2cdc1e52cce1c0ca.tar.gz
ports-f8fd817c79e491a897d6e37c2cdc1e52cce1c0ca.zip
Add a new atf-master master port.
ARM Arm Trusted Framework (sometimes called TF-A for reasons ...) provides a reference implementation of secure world software for Armv7-A and Armv8-A, including a Secure Monitor executing at Exception Level 3 (EL3). We had a port for Alwinner A64/H5 chip, but we need to introduced more ports. So convert this to a master/slave port scheme like u-boot. atf-allwinner is now badly named, when it was introduced it only support A64, now it both support A64 and H5 and there is another ATF platform for H6. Rename it with the platform name
Notes
Notes: svn path=/head/; revision=492250
Diffstat (limited to 'sysutils/atf-master')
-rw-r--r--sysutils/atf-master/Makefile40
-rw-r--r--sysutils/atf-master/distinfo3
-rw-r--r--sysutils/atf-master/pkg-descr1
3 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/atf-master/Makefile b/sysutils/atf-master/Makefile
new file mode 100644
index 000000000000..1ecb8d804103
--- /dev/null
+++ b/sysutils/atf-master/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= atf
+PORTVERSION?= ${ATF_VERSION}
+CATEGORIES= sysutils
+PKGNAMESUFFIX?= -${PLAT}
+
+MAINTAINER= uboot@FreeBSD.org
+COMMENT= ARM TF-A for platform ${PLAT}
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS+= aarch64-none-elf-gcc:devel/aarch64-none-elf-gcc
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= ARM-software
+GH_PROJECT= arm-trusted-firmware
+GH_TAGNAME= ${ATF_VERSION}
+
+SSP_UNSAFE= yes
+MAKE_ENV+= CROSS_COMPILE="aarch64-none-elf-"
+ALL_TARGET= ARCH="aarch64" PLAT=${PLAT} V=1 bl31
+
+# Default to the latest release
+ATF_VERSION?= v2.0
+
+PLIST_FILES?= ${PREFIX}/share/${PORTNAME}-${PLAT}/${BL31:T}
+
+DESCR?= ${.CURDIR}/pkg-descr
+
+NO_ARCH= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/share/${PORTNAME}-${PLAT}/
+ ${INSTALL_DATA} ${WRKSRC}/build/${PLAT}/release/${BL31} ${STAGEDIR}/${PREFIX}/share/${PORTNAME}-${PLAT}/
+ ${INSTALL_DATA} ${DESCR} ${STAGEDIR}/${INST}/README
+
+.include <bsd.port.mk>
diff --git a/sysutils/atf-master/distinfo b/sysutils/atf-master/distinfo
new file mode 100644
index 000000000000..46b69b1c952e
--- /dev/null
+++ b/sysutils/atf-master/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549376667
+SHA256 (ARM-software-arm-trusted-firmware-2.0.20181123-98aab97_GH0.tar.gz) = e5496f84f6cd550ed494d83e3c82fb75d8ebeb3d3034aa741e62cbdccfdc761c
+SIZE (ARM-software-arm-trusted-firmware-2.0.20181123-98aab97_GH0.tar.gz) = 3385437
diff --git a/sysutils/atf-master/pkg-descr b/sysutils/atf-master/pkg-descr
new file mode 100644
index 000000000000..b703d5064965
--- /dev/null
+++ b/sysutils/atf-master/pkg-descr
@@ -0,0 +1 @@
+ARM TF-A (ATF) master port.