aboutsummaryrefslogtreecommitdiff
path: root/sysutils/autojump
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-18 20:44:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-18 20:44:55 +0000
commitf9483de96231b84df8c18d2b0bd7f0c0f8cf5080 (patch)
treeb9149158a715e1bc0ba7460f873c92ca788c7b22 /sysutils/autojump
parent7f3c33bd55965753a3003526ce4fb2ff4cd1bfee (diff)
downloadports-f9483de96231b84df8c18d2b0bd7f0c0f8cf5080.tar.gz
ports-f9483de96231b84df8c18d2b0bd7f0c0f8cf5080.zip
sysutils/autojump: Unbreak by fixing shebang
Also remove ZSH option: shell completions are now installed unconditionally. Approved by: portmgr (port compliance, infrastructure)
Notes
Notes: svn path=/head/; revision=464953
Diffstat (limited to 'sysutils/autojump')
-rw-r--r--sysutils/autojump/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/sysutils/autojump/Makefile b/sysutils/autojump/Makefile
index c00c8a2663fa..0625e1fec057 100644
--- a/sysutils/autojump/Makefile
+++ b/sysutils/autojump/Makefile
@@ -3,6 +3,7 @@
PORTNAME= autojump
PORTVERSION= 13
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.vermatech.com/distfiles/
DISTNAME= autojump_v${PORTVERSION}
@@ -14,8 +15,9 @@ LICENSE= GPLv3
RUN_DEPENDS= bash:shells/bash
+USES= python:run shebangfix
NO_BUILD= yes
-USES= python:run
+SHEBANG_FILES= autojump jumpapplet
SUB_FILES= pkg-install
PLIST_FILES= bin/autojump \
@@ -23,13 +25,8 @@ PLIST_FILES= bin/autojump \
man/man1/autojump.1.gz \
share/autojump/autojump.bash \
share/autojump/autojump.zsh \
- share/autojump/icon.png
-
-OPTIONS_DEFINE= ZSH
-OPTIONS_DEFAULT= ZSH
-
-ZSH_RUN_DEPENDS= zsh:shells/zsh
-ZSH_PLIST_FILES= share/zsh/site-functions/_j
+ share/autojump/icon.png \
+ share/zsh/site-functions/_j
post-patch:
@${REINPLACE_CMD} -e '/#!\/usr\/bin/s|python|env &|' \
@@ -38,8 +35,6 @@ post-patch:
do-install:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${SH} ./install.sh \
--prefix ${STAGEDIR}${PREFIX})
-
-do-install-ZSH-on:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
${INSTALL_DATA} ${WRKSRC}/_j \
${STAGEDIR}${PREFIX}/share/zsh/site-functions