aboutsummaryrefslogtreecommitdiff
path: root/sysutils/automount
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-04-28 06:50:59 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-04-28 06:50:59 +0000
commit25e1b431bef18d3373737ac31d7a1794cb3796ce (patch)
treeb62e6fd1cb6772c14d13959004af188ad44c5148 /sysutils/automount
parentfcb8f07dc515caf37c23984606729eadb8b71fae (diff)
downloadports-25e1b431bef18d3373737ac31d7a1794cb3796ce.tar.gz
ports-25e1b431bef18d3373737ac31d7a1794cb3796ce.zip
automount is a devd(8) based automounter for FreeBSD.
It supports most popular file systems: NTFS/MSDOS/exFAT/EXT2/EXT3/EXT4/UFS WWW: https://github.com/vermaden/automount/ PR: ports/166275 Submitted by: vermaden <vermaden@interia.pl>
Notes
Notes: svn path=/head/; revision=295639
Diffstat (limited to 'sysutils/automount')
-rw-r--r--sysutils/automount/Makefile28
-rw-r--r--sysutils/automount/distinfo2
-rw-r--r--sysutils/automount/pkg-descr6
-rw-r--r--sysutils/automount/pkg-install15
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/automount/Makefile b/sysutils/automount/Makefile
new file mode 100644
index 000000000000..ef0c1e4b7722
--- /dev/null
+++ b/sysutils/automount/Makefile
@@ -0,0 +1,28 @@
+# New ports collection Makefile for: automount
+# Date created: 04 March 2012
+# Whom: Slawomir Wojciech Wojtczak <vermaden@interia.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= automount
+PORTVERSION= 1.3.1
+CATEGORIES= sysutils
+MASTER_SITES= https://raw.github.com/vermaden/automount/master/
+
+MAINTAINER= vermaden@interia.pl
+COMMENT= FreeBSD's devd(8) based automount sollution
+
+LICENSE= BSD
+
+PLIST_FILES= sbin/automount etc/devd/automount_devd.conf etc/automount.conf.sample
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/automount ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/automount_devd.conf ${PREFIX}/etc/devd/automount_devd.conf
+ ${INSTALL_DATA} ${WRKSRC}/automount.conf.sample ${PREFIX}/etc/automount.conf.sample
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/sysutils/automount/distinfo b/sysutils/automount/distinfo
new file mode 100644
index 000000000000..4c7f5b8ea38c
--- /dev/null
+++ b/sysutils/automount/distinfo
@@ -0,0 +1,2 @@
+SHA256 (automount-1.3.1.tar.gz) = 1bc38c82b513c03bdd9e1f65edf552e3d1b74a64a90d628bad39a35d07ff0f7d
+SIZE (automount-1.3.1.tar.gz) = 3636
diff --git a/sysutils/automount/pkg-descr b/sysutils/automount/pkg-descr
new file mode 100644
index 000000000000..36c1f3921e6c
--- /dev/null
+++ b/sysutils/automount/pkg-descr
@@ -0,0 +1,6 @@
+automount is a devd(8) based automounter for FreeBSD.
+
+It supports most popular file systems:
+NTFS/MSDOS/exFAT/EXT2/EXT3/EXT4/UFS
+
+WWW: https://github.com/vermaden/automount/
diff --git a/sysutils/automount/pkg-install b/sysutils/automount/pkg-install
new file mode 100644
index 000000000000..869dc336dd7f
--- /dev/null
+++ b/sysutils/automount/pkg-install
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+case ${2} in
+ (POST-INSTALL)
+ /etc/rc.d/devd restart
+ echo
+ echo
+ echo "Check /usr/local/sbin/automount --help for available options."
+ echo
+ echo
+ ;;
+ (PRE-INSTALL)
+ :
+ ;;
+esac