aboutsummaryrefslogtreecommitdiff
path: root/sysutils/backuppc
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-12-24 15:56:20 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-12-24 15:56:20 +0000
commitcf56bd065fe714e568a68966d04611e494299266 (patch)
tree7980c9efed1dd2b18747e7a8731c7b64501e4918 /sysutils/backuppc
parent61c397213585b3c6fc3cd3a7559a064d3751a575 (diff)
downloadports-cf56bd065fe714e568a68966d04611e494299266.tar.gz
ports-cf56bd065fe714e568a68966d04611e494299266.zip
- add www/p5-CGI dependency (CGI was removed in Perl 5.22)
- escape "{" literal in regexps (was deprecated in Perl 5.22) PR: 214308 Submitted by: moiseev@mezonplus.ru (maintainer)
Notes
Notes: svn path=/head/; revision=429367
Diffstat (limited to 'sysutils/backuppc')
-rw-r--r--sysutils/backuppc/Makefile10
-rw-r--r--sysutils/backuppc/files/patch-lib_BackupPC_Lib.pm20
2 files changed, 28 insertions, 2 deletions
diff --git a/sysutils/backuppc/Makefile b/sysutils/backuppc/Makefile
index 5a57068c9187..5197d4f9cc33 100644
--- a/sysutils/backuppc/Makefile
+++ b/sysutils/backuppc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= backuppc
PORTVERSION= 3.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF
DISTNAME= BackupPC-${PORTVERSION}
@@ -134,4 +134,10 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/backuppc
${CP} ${WRKSRC}/update.pl ${STAGEDIR}${PREFIX}/libexec/backuppc/update.pl
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502200
+RUN_DEPENDS+= p5-CGI>0:www/p5-CGI
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/backuppc/files/patch-lib_BackupPC_Lib.pm b/sysutils/backuppc/files/patch-lib_BackupPC_Lib.pm
new file mode 100644
index 000000000000..95c19255dc0e
--- /dev/null
+++ b/sysutils/backuppc/files/patch-lib_BackupPC_Lib.pm
@@ -0,0 +1,20 @@
+--- lib/BackupPC/Lib.pm.orig 2016-11-08 08:08:02 UTC
++++ lib/BackupPC/Lib.pm
+@@ -1261,7 +1261,7 @@ sub cmdVarSubstitute
+ #
+ # Replace scalar variables first
+ #
+- $arg =~ s[\${(\w+)}(\+?)]{
++ $arg =~ s[\$\{(\w+)}(\+?)]{
+ exists($vars->{$1}) && ref($vars->{$1}) ne "ARRAY"
+ ? ($2 eq "+" ? $bpc->shellEscape($vars->{$1}) : $vars->{$1})
+ : "\${$1}$2"
+@@ -1270,7 +1270,7 @@ sub cmdVarSubstitute
+ # Now replicate any array arguments; this just works for just one
+ # array var in each argument.
+ #
+- if ( $arg =~ m[(.*)\${(\w+)}(\+?)(.*)] && ref($vars->{$2}) eq "ARRAY" ) {
++ if ( $arg =~ m[(.*)\$\{(\w+)}(\+?)(.*)] && ref($vars->{$2}) eq "ARRAY" ) {
+ my $pre = $1;
+ my $var = $2;
+ my $esc = $3;